Risultati da 1 a 5 di 5

Discussione: Confronta testo in due celle e scrivi il risultato in una terza cella



  1. #1
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    24
    Messaggi
    23
    Versione Office
    mac 2016
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Confronta testo in due celle e scrivi il risultato in una terza cella

    Buongiorno a tutti,


    sto cercando una formula per confrontare due celle e restituire (in una terza cella) una parola contenuta nella cella in cui voglio cercare.

    So che sembra una supercazzola ma ecco un esempio:

    - la cella fissa (per il confronto) contine il nome "jessica"
    - la cella in cui cercare contiene, ad esempio, "jessica è ad una festa"
    - il risultato che mi aspetto di trovare nella terza cella è "jessica"

    Ho provato con Rimpiazza, Stringa.Estrai e qualche cerca ma non mi esce nulla anche perchè la parola che cerco può cambiare posizione all'interno della frase ed essere ad esempio: "ad una festa c'è jessica" oppure "c'è jessica ad una festa".

    Grazie mile!
    Ultima modifica fatta da:Canapone; 15/10/16 alle 11:55

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    36
    Messaggi
    2595
    Versione Office
    2016
    Mi Piace ricevuti
    706
    Mi Piace dati
    624

    Re: Confronta testo in due celle e scrivi il risultato in una terza cella

    Ciao,

    senza un file con varie casistiche non si capisce bene il criterio che segui....
    sembrerebbe che se nella stringa di testo è presente la parola di confronto allora ti restituisce quella parola.

    Se è cosi:
    supponendo di avere in A1 la parola da cercare e in B1 la frase in cui cercare, nella cella C1 puoi scrivere semplicemente:

    =SE(VAL.ERRORE(TROVA(A1;B1));"";A1)

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3700
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1104
    Mi Piace dati
    653

    Re: Confronta testo in due celle e scrivi il risultato in una terza cella

    Ciao a tutti,
    giusto per dare un'alternativa alla formula di Cromagno<.

    =SE.ERRORE(SE(RICERCA(A1;B1)>0;A1);"")

    Ho messo la funzione RICERCA invece che TROVA perchè non tiene conto delle maiuscole/minuscole
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    36
    Messaggi
    2595
    Versione Office
    2016
    Mi Piace ricevuti
    706
    Mi Piace dati
    624

    Re: Confronta testo in due celle e scrivi il risultato in una terza cella

    Citazione Originariamente Scritto da ges Visualizza Messaggio

    Ho messo la funzione RICERCA invece che TROVA perchè non tiene conto delle maiuscole/minuscole
    Hai ragione ges, meglio usare RICERCA()

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #5
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    24
    Messaggi
    23
    Versione Office
    mac 2016
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: Confronta testo in due celle e scrivi il risultato in una terza cella

    Perfetto! Grazie mille :D

Discussioni Simili

  1. [Risolto] Macro per divisione cella di testo in più celle
    Di mkback nel forum Domande su Excel VBA e MACRO
    Risposte: 26
    Ultimo Messaggio: 21/09/16, 09:02
  2. Cambiare colore a riga/colonna di celle se una cella uguale ad un testo
    Di Cavier80 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 22/05/16, 12:23
  3. Estrarre testo da piu celle ed unificarla in unica cella
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 22/04/16, 14:58
  4. Risposte: 13
    Ultimo Messaggio: 27/01/16, 17:25
  5. dividere il testo di una cella in più celle senza spezzare le parole
    Di alex nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 09/11/15, 12:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •