Risultati da 1 a 8 di 8

Discussione: Riordinare dati cella in base al valore della cella stessa



  1. #1
    L'avatar di Samuela
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    padova
    Messaggi
    60
    Versione Office
    2013
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Riordinare dati cella in base al valore della cella stessa

    Ciao a tutti,

    precedentemente ho chiesto aiuto per riordinare alcune celle e GES mi ha fatto questa formula che funziona benissimo. Il problema è che se cambio formato alle celle non funziona più

    Allego anche il file originale, grazie mille.


    =SE.ERRORE(INDICE(E$7:E$11;CONFRONTA($B4;$F$7:$F$11;0));"")

    P:S allego nuovo file più chiaro, scusate ...
    File Allegati File Allegati
    Ultima modifica fatta da:Samuela; 15/10/16 alle 11:49 Motivo: file confuso

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3650
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1087
    Mi Piace dati
    638

    Re: Riordinare dati cella in base al valore della cella stessa

    Ciao Samuela,
    cosa intendi per "se cambio formato alle celle"? Che li formatti come testo?
    E quali celle... quelle di tutto il foglio?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    61
    Messaggi
    610
    Versione Office
    2016
    Mi Piace ricevuti
    197
    Mi Piace dati
    35

    Re: Riordinare dati cella in base al valore della cella stessa

    ciao
    non è che cambi formato
    da quel che si capisce vuoi i risultati in più colonne

    allora intervieni qui

    =SE.ERRORE(INDICE(G$5:G$10;CONFRONTA($B4;$H$5:$H$10;0));"")

    la prima visto che ti sposti a destra

    Codice: 
    $G$5:$G$10
    la blocchi
    per la seconda non ho capito
    se i dati sono incolonnati o messi an caso
    con celle vuote

  4. #4
    L'avatar di Samuela
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    padova
    Messaggi
    60
    Versione Office
    2013
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: Riordinare dati cella in base al valore della cella stessa

    allego esempio con formula ma non funzionante. grazie
    File Allegati File Allegati

  5. #5
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    61
    Messaggi
    610
    Versione Office
    2016
    Mi Piace ricevuti
    197
    Mi Piace dati
    35

    Re: Riordinare dati cella in base al valore della cella stessa

    Ciao
    prova a formattare le colonne come generale
    e noterai una certa discrepanza tra i dati

    visto che non so da dove li prendi
    non saprei cosa dirti

    fai copia della colonna con i numeri
    e incollala sulla colonna dove hai la
    tabella formattata in generale e vedi che funziona

    comunque tutta un'altra cosa dai file che hai allegato prima

  6. #6
    L'avatar di Samuela
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    padova
    Messaggi
    60
    Versione Office
    2013
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: Riordinare dati cella in base al valore della cella stessa

    ciao,
    si hai ragione i dati sono diversi, purtroppo però la fonte non la posso sostituire.
    Sapresti dire se in qualche maniera si possono uniformare al tipo di dati nell'ultima colonna ?

    Grazie

  7. #7
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    61
    Messaggi
    610
    Versione Office
    2016
    Mi Piace ricevuti
    197
    Mi Piace dati
    35

    Re: Riordinare dati cella in base al valore della cella stessa

    Ciao
    metti la formula che utilizzi per importare i dati

    magari con arrotonda o intero si riesce a sistemare

  8. #8
    L'avatar di Samuela
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    padova
    Messaggi
    60
    Versione Office
    2013
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: Riordinare dati cella in base al valore della cella stessa

    purtroppo non ho formule, ho solo 2 colonne dati tipo quelle inviate nel file ....

    p.s. trovato, con stringa estrai si risolve. grazie di esserti accorto dell'errore.
    Ciao

Discussioni Simili

  1. Immagini al variare del valore della cella
    Di cguizzardi86 nel forum Domande su Excel VBA e MACRO
    Risposte: 0
    Ultimo Messaggio: 23/10/16, 14:56
  2. [Risolto] Riordinare dati cella in base al valore della cella stessa
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 07/10/16, 14:45
  3. Spostare Celle in base al valore di una cella stessa
    Di ShLomo nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 22/07/16, 17:38
  4. trovare testo cella e restituire valore della cella vicino a quella trovata
    Di ceppa8 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 19/07/16, 18:05
  5. Risposte: 3
    Ultimo Messaggio: 08/04/16, 11:34

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •