Risultati da 1 a 5 di 5

Discussione: Formule "Rimpiazza" e "Sostituisci" per i numeri



  1. #1
    L'avatar di giteti58
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Abruzzo
    Età
    58
    Messaggi
    65
    Versione Office
    Excel 2016
    Utile ricevuti
    2
    Utile dati
    32

    Formule "Rimpiazza" e "Sostituisci" per i numeri

    Ciao a tutti,
    una semplicissima domanda: non è possibile utilizzare le formule "Rimpiazza" e "Sostituisci" con celle di soli numeri?
    Cioè, più chiaramente: se in una colonna A1:A20 ho dei numeri ed ho necessità di sostituire, in maniera automatica, tutto il contenuto della cella A8, con il contenuto della cella C4, non esiste una formula che me lo consente?

    (non ho allegato un file perché mi sembrava superfluo ma, se serve, è pronto).

    Grazie
    Ultima modifica fatta da:Gerardo Zuccalà; 16/10/16 alle 18:58 Motivo: Messo risolto

  2. #2
    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    5049
    Versione Office
    2011MAC 2016WIN
    Utile ricevuti
    1643
    Utile dati
    1051

    Re: Formule "Rimpiazza" e "Sostituisci" per i numeri

    Ciao,
    per quel che hai chiesto:

    =SOSTITUISCI($A$8;$A$8;$A$4)

    Se vuoi partire dalla riga 1 a scendere, cioè i numeri sono nella colonna A, in B1 da trascinare in basso:

    =SE(A1=$A$8;SOSTITUISCI($A$8;$A$8;$A$4)+0;A1)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di giteti58
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Abruzzo
    Età
    58
    Messaggi
    65
    Versione Office
    Excel 2016
    Utile ricevuti
    2
    Utile dati
    32

    Re: Formule "Rimpiazza" e "Sostituisci" per i numeri

    Ti ringrazio per la celerità nella risposta e ti prego di perdonarmi se non ho allegato il file né sono stato abbastanza chiaro nella richiesta. In effetti la formula va digitata in una cella diversa sia da quella col nuovo valore sia da quella da sostituire.
    Allego comunque l'esempio e ti ringrazio.
    File Allegati File Allegati

  4. #4
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    1454
    Versione Office
    2016
    Utile ricevuti
    382
    Utile dati
    86

    Re: Formule "Rimpiazza" e "Sostituisci" per i numeri

    Ciao
    se vuoi la sostituzione su un'altra cella va bene
    la formula di GES ( salutoni maestro)
    però scrivendola giusta

    Codice: 
    =SOSTITUISCI($E$10;E10;J18)
    se invece vuoi cambiare dentro la tabella ci vuole il VBA

    metti nel foglio interessato ( nel tuo caso il 4 )

    Codice: 
    Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
    If Not Intersect(Target, Range("c5:f12")) Is Nothing Then
    If Cells(18, 10).Value <> "" Then
    ActiveCell.Value = Cells(18, 10).Value
    End If
    End If
    End Sub
    e al doppio click su una cella della tabella
    questa prende il valore della cella J18
    se diverso da vuoto

    volendo puoi azzerare la cella e selezionare la prima della tabella
    così
    Codice: 
    Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
    If Not Intersect(Target, Range("c5:f12")) Is Nothing Then
    If Cells(18, 10).Value <> "" Then
    ActiveCell.Value = Cells(18, 10).Value
    End If
    End If
    Cells(5, 3).Select
    Cells(18, 10).Value = ""
    End Sub

  5. I seguenti 2 utenti hanno dato un "Like" a Gianfranco55 per questo post:


  6. #5
    L'avatar di giteti58
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Abruzzo
    Età
    58
    Messaggi
    65
    Versione Office
    Excel 2016
    Utile ricevuti
    2
    Utile dati
    32

    Re: Formule "Rimpiazza" e "Sostituisci" per i numeri

    Perfetto!!
    Caro il mio Gianfranco55, era proprio quello che volevo.
    Ho dovuto soltanto adattare la tua formula alle mie esigenze con un pulsante che, se ricorre l'eventuale condizione che considero possa verificarsi, va cliccato ed attiva la macro "AGGIORNA".
    Ora mi basterà completare quella macro Excel VBA che andrà a ricercarmi, in modo automatico, quella casella che, volta per volta, corrisponde all'intersezione (nel mio caso E10) per la necessaria sostituzione.
    Grazie.

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 12:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 12:54
  3. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 09:44
  4. [Risolto] Codice non funzionante dopo il passaggio da "Windows" a "Mac"...
    Di joondeep nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 19:09
  5. Collegamento "foglio elenco" e "fogli singoli"
    Di Maurizio76 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/11/15, 08:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •