Risultati da 1 a 18 di 18

Discussione: Ricerca formula giusta



  1. #1
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3

    Ricerca formula giusta

    ciao
    sono nuovo del forum è spero di aver postato la domanda nel modo giusto.

    avrei bisogno di una formula x questo:
    se il mio numero si trova tra:
    66 e 68,5 il risultato è 1
    se si trova tra
    69 e 71,5 il risultato è 2
    se si trova tra
    72 e 75,5 il risultato è 3.
    se magari avete qualche video che lo spiego è ben accetto.
    aspetto una vostra risposta.
    buona giornata a tutti
    Invia MPPM 

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    in A1 il numero.

    In B1

    =E(A1>=66;A1<=68,5)+E(A1>=69;A1<=71,5)*2+E(A1>=72;A1<=75,5)*3

    Ci sono altri sistemi
    Invia MPPM 

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    u saluto a Stefano

    nel caso specifico potrebbe bastare:
    =INT((A1-66)/3)+1
    op
    =max(0;INT((A1-66)/3)+1) (se vi sono numeri minori di 66)

    op

    =CONFRONTA(A1;{0.66.69.72})-1

    ed altri
    Invia MPPM 

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    ho provato questa formula è va bene, solo che hai dimenticato di fare *1:
    E(A1>=66;A1<=68,5)*1+E(A1>=69;A1<=71,5)*2+E(A1>=72;A1<=75,5)*3
    però per il resto va bene.
    x quello che dovevo fare io ho utilizzato la formula di "ninai":
    =INT((A1-66)/3)+1
    è risultata molto più facile e va oltre il 75,5 aggiungendo sempre +1 ogni 3 di differenza.
    grazie mille
    :188:

    Invia MPPM 

  6. #5
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    u saluto a Stefano

    nel caso specifico potrebbe bastare:
    =INT((A1-66)/3)+1
    op
    =max(0;INT((A1-66)/3)+1) (se vi sono numeri minori di 66)

    op

    =CONFRONTA(A1;{0.66.69.72})-1


    ed altri
    ciao ho provato le tue formule e vanno tutte bene.
    quella ke ho utilizzato alla fine è questa:
    =max(0;INT((A1-66)/3)+1) (se vi sono numeri minori di 66)
    solo che inserendo la formula a tutta la colonna mi compaiono gli "0" prima che metto il numero.
    come faccio a far rimanere vuoto fino all'inserimento di quest'ultimo?
    Invia MPPM 

  7. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    riprendo la formula prodotta da Ninai (ciao!)

    =SE(MAX(0;INT((A1-66)/3)+1);MAX(0;INT((A1-66)/3)+1);"")

    oppure (mescolo un po' le formule):

    =SE(E(A1>=66;A1<=75,5);INT((A1-66)/3)+1;"")



    --------------------------

    Solo per didattica: il "*1" non era stato dimenticato nella formula con la serie di E.

    La formula restituisce gli stessi risultati.

    Saluti


    Edit: mi sono mangiato nella seconda formula un ",5". Stavo controllando i risultati con un cerca.vert

    =CERCA.VERT(A1;{0\"".66\1.69\2.72,5\3.75,500001\""};2)

    Se servisse
    Ultima modifica fatta da:Canapone; 16/09/15 alle 15:48
    Invia MPPM 

  8. #7
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao,

    riprendo la formula prodotta da Ninai (ciao!)

    =SE(MAX(0;INT((A1-66)/3)+1);MAX(0;INT((A1-66)/3)+1);"")

    oppure (mescolo un po' le formule):

    =SE(E(A1>=66;A1<=75,5);INT((A1-66)/3)+1;"")



    --------------------------

    Solo per didattica: il "*1" non era stato dimenticato nella formula con la serie di E.

    La formula restituisce gli stessi risultati.

    Saluti


    Edit: mi sono mangiato nella seconda formula un ",5". Stavo controllando i risultati con un cerca.vert

    =CERCA.VERT(A1;{0\"".66\1.69\2.72,5\3.75,500001\""};2)

    Se servisse
    anche questa formula va in parte bene:
    =SE(E(A1>=66;A1<=75,5);INT((A1-66)/3)+1;"")
    solo che ora se ad esempio scrivo:65 la casella esce vuota mentre deve uscire "0" come in questa formula: =max(0;INT((A1-66)/3)+1)
    a me lo "0" serve quando scrivo un numero inferiore a "66" però serve anche che prima che scrivo qualsiasi numero la casella resti vuota e non con lo "0"
    Invia MPPM 

  9. #8

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0
    Tanto per partecipare:

    A
    B
    1
    75
    =SOMMA(SOGLIA(A1;{66.69.72}))
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
    Invia MPPM 

  10. I seguenti utenti hanno dato un "Like"


  11. #9
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Tanto per partecipare:

    A
    B
    1
    75
    =SOMMA(SOGLIA(A1;{66.69.72}))
    anche questa va bene solo che quando in A non c'è scritto niente l'altra cella deve essere vuota.
    Invia MPPM 

  12. #10
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Occhio al 75

    Ciao a tutti,

    saluto Scossa. Forte SOGLIA! Mai usato

    Sto facendo qualche confronto usando:

    =SE(E(A1>=65;A1<=75,5);E(A1>=66;A1<=68,5)+E(A1>=69;A1<=71,5)*2+E(A1>=72,5;A1<=75;5)*3;"")

    Stessi risultati da formula di SCOSSA

    =SE(E(A1>=65;A1<=75,5);SOMMA(SOGLIA(A1;{66.69.72}));"")


    Spero sia d'aiuto
    Ultima modifica fatta da:Canapone; 16/09/15 alle 16:48
    Invia MPPM 

  13. #11
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    la formula migliore che mi avete mandato è questa:

    =max(0;INT((A1-66)/3)+1)

    mi serve solo aggiungere che fino a quando non scrivo il numero nella casella del risultato non deve esserci niente.
    Invia MPPM 

  14. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Tanto per partecipare:

    A
    B
    1
    75
    =SOMMA(SOGLIA(A1;{66.69.72}))
    :208:

    sta cavolo di SOGLIA(), mi devo decidere a prenderla in considerazione, se no finisce come con MEDIANA() e l'intervallo d'intersezione.
    :262:

    volendo , si può fare anche così:
    =MATR.SOMMA.PRODOTTO(--(A1>={66.69.72}))
    op
    =SOMMA(--(A1>={66.69.72}))
    matriciale
    Ultima modifica fatta da:ninai; 16/09/15 alle 16:21
    Invia MPPM 

  15. I seguenti utenti hanno dato un "Like"


  16. #13
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da marktiello Visualizza Messaggio
    =max(0;INT((A1-66)/3)+1)

    mi serve solo aggiungere che fino a quando non scrivo il numero nella casella del risultato non deve esserci niente.
    =SE(a1;max(0;INT((A1-66)/3)+1);"")
    Invia MPPM 

  17. #14
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    =SE(a1;max(0;INT((A1-66)/3)+1);"")
    ok:208:
    questa è perfetta...

    grazie a tutti x l'aiuto...

    alla prossima:300::43:
    Invia MPPM 

  18. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Grazie del tuo riscontro positivo .
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menuStrumenti Discussione”quindi scegliere “Segna questo Thread come risolto”
    Invia MPPM 

  19. I seguenti utenti hanno dato un "Like"


  20. #16
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Grazie del tuo riscontro positivo .
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menuStrumenti Discussione”quindi scegliere “Segna questo Thread come risolto”
    scusa ma mi esce solo segnale come irrisolto.
    come mai?
    Invia MPPM 

  21. #17
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da marktiello Visualizza Messaggio
    scusa ma mi esce solo segnale come irrisolto.
    come mai?
    Ciao markitiello
    Perdonami sono stato io, perchè io insieme ai moderatori siamo gli unici a poter inserire [RISOLTO] oltre a colui che ha iniziato la discussione
    avrei dovuto avere un pò di fiducia in te, essendo questo uno strumento nuovo pensavo fosse sottovalutato
    Ok la prossima volta avrò un po pazienza in più
    Sorry!!
    :253:
    Invia MPPM 

  22. #18
    L'avatar di marktiello
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    napoli
    Età
    29
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao markitiello
    Perdonami sono stato io, perchè io insieme ai moderatori siamo gli unici a poter inserire [RISOLTO] oltre a colui che ha iniziato la discussione
    avrei dovuto avere un pò di fiducia in te, essendo questo uno strumento nuovo pensavo fosse sottovalutato
    Ok la prossima volta avrò un po pazienza in più
    Sorry!!
    :253:
    nessun problema, essendo nuovo del forum alcune cose devo ancora impararle quindi qualsiasi consiglio e ben accetto.
    saluti a tutti:43:
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Formula giusta
    Di givi79 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 29/12/16, 18:31
  2. [Risolto] Cerco la formula giusta
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 15/11/16, 12:07
  3. Ricerca formula
    Di g8trading nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 31/10/16, 21:15
  4. Ricerca formula
    Di marktiello nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 19/09/15, 18:55
  5. [Risolto] Indice confronta
    Di scapu65 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 19/06/15, 22:36

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •