Risultati da 1 a 10 di 10

Discussione: Somma condizionata



  1. #1
    L'avatar di Sasyjoe
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Italy
    Età
    27
    Messaggi
    45
    Versione Office
    EXCEL 2010
    Likes ricevuti
    2
    Likes dati
    0

    Somma condizionata

    Ciao,
    rieccomi con una domanda per voi credo facile

    ho un elenco di celle nelle quali vi è scritto

    2+3 = 5
    4+2 = 6
    3+8 = 11
    0,5 + 2 = 2,5

    Attenzione:
    2+3 = 5 è tutto all'interno della cella A1 tramite la funzione concatena
    Vi è sempre uno spazio prima e dopo l'uguale

    Mi occorre la somma dopo l'uguale

    Cioè mi occorre questo risultato:
    24,5

    Grazie
    Excel 2007 WindowsXp
    Ultima modifica fatta da:Sasyjoe; 22/09/15 alle 14:59
    Invia MPPM 

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao sasyjoe,
    sicuramente si può fare anche in una solo formala.
    in ogni modo. in B1 scrivi
    =STRINGA.ESTRAI(A1; TROVA("=";A1; 1)+1; 6)
    e trascini giu quanto basta e poi ti fai la somma di quanto ottenuto.
    ciao
    ale
    Invia MPPM 

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao a tutti,

    se A1:A4 contengono le stringhe

    =MATR.SOMMA.PRODOTTO(DESTRA(SOSTITUISCI(A1:A4;"=";RIPETI(" ";100));20)+0)

    Edit: mi piace poco. Me lo dico da solo...
    Ultima modifica fatta da:Canapone; 22/09/15 alle 15:40
    Invia MPPM 

  5. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    altro tentativo. Da confermare con control+maiusc+invio

    Codice: 
    =SOMMA(SE(VAL.NUMERO(TROVA("=";$A$1:$A$100));DESTRA(SOSTITUISCI($A$1:$A$100;"=";RIPETI(" ";100));20)+0))
    Migliorabile
    Invia MPPM 

  6. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    anche la formula di alessandro, in forma matriciale, dovrebbe andare bene:
    =SOMMA(STRINGA.ESTRAI(A1:A4; TROVA("=";A1:A4; 1)+1; 6)*1)

    oppure da inviare normalmente:
    =MATR.SOMMA.PRODOTTO(--STRINGA.ESTRAI(A1:A4; TROVA("=";A1:A4; 1)+1; 6))
    Invia MPPM 

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di Sasyjoe
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Italy
    Età
    27
    Messaggi
    45
    Versione Office
    EXCEL 2010
    Likes ricevuti
    2
    Likes dati
    0
    Preferisco questa anche se non ti piace :

    =MATR.SOMMA.PRODOTTO(DESTRA(SOSTITUISCI(A1:A4;"=";RIPETI(" ";100));20)+0)

    Però se la cella è uguale a "" oppure a 0 mi restituisce errore

    Attenzione:
    Ho dimenticato di specificare che nella cella al posto di 3+2 = 5 ci può essere lo 0 oppure il ""


    Scusa per la distrazione
    Invia MPPM 

  9. #7
    L'avatar di Sasyjoe
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Italy
    Età
    27
    Messaggi
    45
    Versione Office
    EXCEL 2010
    Likes ricevuti
    2
    Likes dati
    0

    Talking

    Come si dice dalle mie parti: "' L'ho trovata a botta di ****"

    eccola:

    =+MATR.SOMMA.PRODOTTO(SE(A1:A4<>"";DESTRA(SOSTITUISCI(A1:A4;"=";RIPETI(" ";100));20)+0;0))

    Da confermare come matriciale
    Invia MPPM 

  10. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao a tutti,

    nella risposta #4 avevo proprio ipotizzato questi casi.

    Codice: 
    =SOMMA(SE(VAL.NUMERO(TROVA("=";$A$1:$A$100));DESTRA(SOSTITUISCI($A$1:$A$100;"=";RIPETI(" ";100));20)+0))
    Questa somma ha bisogno del control+maiusc+invio.

    Aggiungo: la formula non somma le celle che contengono semplici numeri. Per questo motivo apro il somma.se con il TROVA...

    Magari non serve, troppa prudenza.
    Ultima modifica fatta da:Canapone; 22/09/15 alle 16:48
    Invia MPPM 

  11. #9
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Sasyjoe

    ti ringrazio del riscontro positivo.
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

    Alla prossima
    Invia MPPM 

  12. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao Sasyjoe

    ti ringrazio del riscontro positivo.
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

    Alla prossima
    Scusatemi se mi intrometto visto e considerato che questa discussione è stata segnanta come risolta, ma non resistevo dalla voglia di inserire la mia soluzione

    =MATR.SOMMA.PRODOTTO(ANNULLA.SPAZI(RIMPIAZZA(A1:A4;1;TROVA("=";A1:A4)+1;"")+0)+0)
    :299:


    Invia MPPM 

Discussioni Simili

  1. [Risolto] scelta condizionata su elenco a discesa
    Di parcot nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/03/17, 23:16
  2. [Risolto] Somma condizionata a certi valori in una cella
    Di andre nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 28/09/16, 22:11
  3. estrazione condizionata dati e somma valori per ogni singolo cliente
    Di GioPL nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 19/07/16, 16:26
  4. Estrazione condizionata dei dati da una tabella
    Di GioPL nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 15/07/16, 20:53
  5. aiuto per formattazione condizionata
    Di suunto69 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 22/02/16, 23:04

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •