Risultati da 1 a 4 di 4

Discussione: Quiz del Giorno #2 Rango e classifica



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Red face Quiz del Giorno #2 Rango e classifica

    Ciao Oggi un bel grattacapo!
    Come potete vedere nella colonna A2:A13 ho dei numeri ordinati dal più grande al più piccolo e nella colonna B2:B13 con la funzione =RANGO(A2;$A$2:$A$21) ho ottenuto un risultato che non mi soddisfa perché quando ci sono dei numeri duplicati mi salta il numero, invece io sono intenzionato ad ottenere un risultato come quello che ho scritto a mano nella colonna C2:C13
    ciao
    Row\Col
    A
    B
    C
    1
    PUNTEGGIO errato Corretto
    2
    200
    1
    1
    3
    200
    1
    1
    4
    160
    3
    2
    5
    150
    4
    3
    6
    150
    4
    3
    7
    125
    6
    4
    8
    125
    6
    4
    9
    125
    6
    4
    10
    100
    9
    5
    11
    100
    9
    5
    12
    99
    11
    6
    13
    99
    11
    6
    Invia MPPM 

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Gerardo.

    ho fatto una prova con questa formula.

    =MATR.SOMMA.PRODOTTO((B2<B$2:B$13)/CONTA.SE(B$2:B$13;B$2:B$13))+1

    Sembra funzioni
    Invia MPPM 

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Canapone sei un Grande!!
    e ti ringrazio di aver accettato di far parte dello Staff di Forumexcel.it

    Io ho provato a fare una formula matrice con il FREQUENZA solo che bisogna fare CTRL+SHIFT+ENTER

    in D2
    =SOMMA(SE(A2<$A$2:$A$21;--(FREQUENZA($A$2:$A$20;$A$2:$A$20)>0)))+1

    Ciao Canapone e grazie per la tua generosità

    Row\Col
    A
    B
    C
    D
    1
    PUNTEGGIO errato Corretto Classifica
    2
    200
    1
    1
    1
    3
    200
    1
    1
    1
    4
    160
    3
    2
    2
    5
    150
    4
    3
    3
    6
    150
    4
    3
    3
    7
    125
    6
    4
    4
    8
    125
    6
    4
    4
    9
    125
    6
    4
    4
    10
    100
    9
    5
    5
    11
    100
    9
    5
    5
    12
    99
    11
    6
    6
    13
    99
    11
    6
    6
    14
    78
    13
    7
    7
    15
    78
    13
    7
    7
    16
    55
    15
    8
    8
    17
    52
    16
    9
    9
    18
    42
    17
    10
    10
    19
    42
    17
    10
    10
    20
    42
    17
    10
    10
    21
    42
    17
    10
    10
    Invia MPPM 

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    stessa formula di Gerardo

    =MATR.SOMMA.PRODOTTO((A2<$A$2:$A$21)*(FREQUENZA($A$2:$A$20;$A$2:$A$20)>0))+1

    non ha bisogno dello stato matriciale.

    Saluti
    Invia MPPM 

  5. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] Estrarre da testo giorno, mese e giorno settimana.
    Di alfrimpa nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 17:39
  2. usare funzione "giorno lavorativo" con frazioni di giorno
    Di CaesarIII nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 25/09/16, 00:23
  3. Salvare i dati di un giorno sotto la colonna dello stesso giorno.
    Di Laura Belli nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 26/08/16, 08:51
  4. Quiz del Giorno #3 Ore Straordinari
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 30
    Ultimo Messaggio: 09/09/15, 12:41
  5. Quiz del Giorno #1
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 13/06/15, 02:02

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •