Risultati da 1 a 16 di 16

Discussione: Alternativa al CERCA.VERT (video EP23)



  1. #1
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Alternativa al CERCA.VERT (video EP23)

    buongiorno a tutti,
    intanto complimenti per l'ottimo lavoro fatto finora . sono domilingos e sto seguendo tutti i tuoi video per perfezionare l'utilizzo di excel.
    Ora sono fermo al video EP23 dove vedo all'esercizio relativo alla funzione SCEGLI(utlizzando il cerca.vert) , quello sul calcolo della spedizione da pagare per il singolo cliente in base alla tabella di appartenenza.
    Per tale calcolo nella formula è stato utilizzato il cerca.vert in questa maniera.
    CERCA.VERT(C30;SCEGLI(INDICE($H$29:$H$31;CONFRONTA(B30;$G$29:$G$31;0);'ROSSI(23)'!$A$3:$B$7;'FUMAGALLI(23)'!$A$3:$B$7;'ESPOSITO(23)'!$A$3:$B$7);2;VERO)
    .
    adesso sto provando (in alternativa al cerca.vert ) ad utilizzare la funzione INDICE senza però riuscire a capire quali sono gli argomenti nel caso specifico .
    Qualcuno può darmi una mano?
    grazie in anticipo .
    saluti
    domilingos

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Domilingos
    prova a mettere un piccolo allegato di esempio con il risultato desiderato cosi da capire bene quello che vuoi!
    ciao grazie

  3. #3
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    ecco l'allegato preso dalla tua playlist ep23

    ovviamente vorrei ottenere quello che hai ottenuto tu nel file ep23 utilizzando però la funzione indice. grazie

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao
    In D9 prova a mettere questa Fomula

    =INDICE(INDIRETTO("'"&B9&"'!B3:B7");CONFRONTA(C9;INDIRETTO("'"&B9&"'!A3:A7")))

    Cosi puoi sfruttare la funzione INDICE e non hai bisogno della colonna aggiuntiva
    Fammi sapere!
    Ciao

    A
    B
    C
    D
    8
    CLIENTE ACQUISTO SPEDIZIONE
    9
    30/01/2016
    ROSSI
    € 2.010,00
    € 100,00
    10
    27/02/2016
    FUMAGALLI
    € 3.254,00
    € 100,00
    11
    26/03/2016
    ESPOSITO
    € 2.154,00
    € 0,00
    12
    23/04/2016
    FUMAGALLI
    € 2.450,00
    € 75,00
    13
    21/05/2016
    ROSSI
    € 4.500,00
    € 200,00
    14
    18/06/2016
    ROSSI
    € 2.548,00
    € 100,00
    15
    16/07/2016
    ESPOSITO
    € 6.800,00
    € 250,00
    16
    13/08/2016
    ESPOSITO
    € 6.580,00
    € 250,00
    17
    10/09/2016
    FUMAGALLI
    € 3.000,00
    € 100,00
    18
    08/10/2016
    ROSSI
    € 3.987,00
    € 150,00
    19
    05/11/2016
    ROSSI
    € 1.259,00
    € 50,00
    20
    03/12/2016
    FUMAGALLI
    € 6.547,00
    € 100,00
    21
    31/12/2016
    FUMAGALLI
    € 1.256,00
    € 20,00


    Sono Sicuro che ci sono tante altre soluzioni
    un saluto a tutti gli amici del forum!

  5. #5
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao,
    prova a vedere qui
    https://support.office.com/it-it/art...2-b56b061328bd
    trovi spiegato molto bene i vari argomenti che tratta la funzione indice
    in ogni modo, io di solito INDICE la utilizzo così:
    =INDICE(tabella dove pescare i dati;nr di riga;nr di colonna)
    tipo una battaglia navale.
    tornando al ns esempio del foglio scegli, potresti fare
    =INDICE($C$9:$E$21;CONFRONTA(F23;$B$9:$B$21;0);CONFRONTA(E23;$C$8:$E$8;0))
    dove volendo spezzare la formula hai
    =INDICE($C$9:$E$21 è la parte dove lui dovrà prendere cio che stai cercando
    CONFRONTA(F23;$B$9:$B$21;0) lui capisce il nr di riga dove deve fermarsi
    CONFRONTA(E23;$C$8:$E$8;0)) lui capisce il nr di colonna dove deve fermarsi
    in F23 ho un nome mentre in E23 ho ciò che voglio prendere (acquisto, spedizione, coln...
    ho specificato io nel senso che i modi poi sono molteplici...
    ciao e buon we.
    ale

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Alessandro!
    Grazie per il tuo contributo!
    ma credo che domiligos voglia una formula alternativa al CERCA.VERT però il problema che le tabelle di riferimento sono disposte su tre fogli diversi, come puoi vedere dall'allegato che ha messo Domilingos nel post #3.
    Ciao

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Oppure questa!
    sempre in D9 e trascina la formula in basso:

    =INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$B$3:$B$7;fumagalli!$B$3:$B$7;esposito!$B$3:$B$7);CONFRONTA(scegli!C9;INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$A$3:$A$7;fumagalli!$A$3:$A$7;esposito!$A$3:$A$7);)))



    Ciao e
    Fammi Sapere!

  8. I seguenti utenti hanno dato un "Like"


  9. #8
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    ciao a tutti ,
    grazie del supporto a coloro che mi hanno risposto. ho provato adesso la soluzione che mi avete proposto , appena metto i riferimenti corretti vi informo se il risultato sperato è stato ottenuto o meno. grazie ancora .

  10. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da domilingos Visualizza Messaggio
    ciao a tutti ,
    grazie del supporto a coloro che mi hanno risposto. ho provato adesso la soluzione che mi avete proposto , appena metto i riferimenti corretti vi informo se il risultato sperato è stato ottenuto o meno. grazie ancora .
    Ok facci sapere!

  11. #10
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    Ho provato la tua formula Gerardo e (non avendo alcun dubbio) funziona alla grande . A capirla però ....

  12. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao grazie per il tuo feedback
    la formula è più semplice di quanto sembra è molto simile a quella che hai visto nel video EP23

    Iniziamo con la funzione INDICE che praticamente è quello che vogliamo che ci venga restituito
    =INDICE(




    Però gli indici sono su tre fogli e allora utilizziamo la funzione SCEGLI per scegliere il foglio
    =INDICE(SCEGLI(



    Per sapere se è il foglio 1 2 o 3 usiamo il CONFRONTA che ci restituisce il numero di foglio che aveva bisogno la funzione indice nell'argomento "indice" che ha bisogno Sempre di un numero
    =INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0)



    A questo punto se il CONFRONTA mi da 1 mi restituisce il foglio Rossi, se 2 fumagalli, se 3 Esposito
    =INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$B$3:$B$7;fumagalli!$B$3:$B$7;esposito!$B$3:$B$7)




    dopo che abbiamo scoperto il foglio dobbiamo scoprire la riga che serve all'indice nell'argomento riga cioè la fascia di reddito... e anche in questo caso usiamo il CONFRONTA che ci serve per farci restituire il nr. d posizione relativa

    =INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$B$3:$B$7;fumagalli!$B$3:$B$7;esposito!$B$3:$B$7);CONFRONTA(scegli!C9;INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$A$3:$A$7;fumagalli!$A$3:$A$7;esposito!$A$3:$A$7);)))

    Ciao Domilingos spero che sia chairo
    Ultima modifica fatta da:Gerardo Zuccalà; 29/09/15 alle 15:33

  13. #12
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    ciao Gerardo,
    allora, dopo aver riflettuto tanto ho alcuni dubbi.
    1) per scegliere il foglio (cioè per vedere se "rossi" appartiene al foglio 1,2 o 3 utilizzi come valori nella funzione SCEGLI le colonne b3:b7 , ma perchè non tutta la tabella , cioè a3:b7 anche se provando ho visto che è errato?
    2) mi spieghi meglio "dobbiamo scoprire la riga che serve all'indice nell'argomento riga cioè la fascia di reddito" ?
    grazie 1000 .

  14. #13
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao domilingos,
    visto che nessuno risponde mi permetto di intervenire.
    1) per gerardo la tabella è proprio B3:B7...la col. A (per capire che foglio prendere) non la tocca proprio...prende solo i valori della "spedizione"...e per capire a quale foglio deve puntare, vede con quel confronta il nome della col. B
    2) una volta capito il foglio, e rimanendo sempre sul range B3:B7, deve capire a quale riga fermarsi per prendere il valore. A questo punto, con l'altro confronta vede che valore (della col. C acquisti) si avvicina ai valori "acquisto" della col.A.
    Da notare (ed è un particolare non indifferente) la differenza dei due confronta: nel primo c'è la corrispondenza esatta, nel secondo si avvicina al valore.
    Ovvero nel primo
    CONFRONTA(B9;$G$8:$G$10;0)
    con quel ;0 ti dice che cerca l'esatta corrispondenza (cioè deve corrispondere esattamente) [nome=nome]
    mentre con l'altro confronta
    CONFRONTA(scegli!C9;INDICE(SCEGLI(CONFRONTA(B9;$G$8:$G$10;0);rossi!$A$3:$A$7;fumagalli!$A$3:$A$7;esposito!$A$3:$A$7);)
    se tu vedi alla fine manca quel ;0 e cioè lui cerca il valore che si avvicina e lo prende anche se non corrisponde.
    come al solito sono stato un po prolisso ma spero di esserti stato d'aiuto.
    ciao
    ale

  15. #14
    L'avatar di domilingos
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    milano
    Età
    35
    Messaggi
    6
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    ciao alessando,
    grazie per la risposta. quindi per il punto 1 siccome devo calcolare la spedizione devo prendere in considerazione la colonna B delle spedizioni e se per assurdo mi serviva un calcolo per l'ammontare speso avrei dovuto prendere in considerazione la col A?
    grazie in anticipo.
    saluti
    domilingos

  16. #15
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Domilingos
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

  17. #16
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    esatto...col. A.
    Cmq fai delle prove.
    ciao
    ale

Discussioni Simili

  1. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  2. Cerca.Vert con Se
    Di jigen nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/08/16, 12:31
  3. Cerca Vert
    Di smanimania nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 22/02/16, 18:13
  4. cerca vert
    Di Lucagiuseppe nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/02/16, 18:58
  5. Cerca.Vert si ferma al primo elemento. Alternativa per analizzare tutti i risultati?
    Di DaylighterSL nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/12/15, 19:17

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •