Pagina 1 di 2 12 UltimaUltima
Risultati da 1 a 30 di 31

Discussione: Quiz del Giorno #3 Ore Straordinari



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127

    Quiz del Giorno #3 Ore Straordinari

    Ciao
    Quante ore di straordinari ci sono dopo le 8 ore lavorate?
    io ho scritto il risultato a mano in D2 ... ma con le formule?
    Grazie per le vostre risposte

    Row\Col
    A
    B
    C
    D
    1
    entrata uscita straordinari
    2
    23:00
    08:00
    01:00

    Ultima modifica fatta da:Gerardo Zuccalà; 11/06/15 alle 20:51 Motivo: errore headers
    Invia MPPM 

  2. #2
    L'avatar di Laura Belli
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Belgio
    Età
    33
    Messaggi
    153
    Versione Office
    excel 2007
    Likes ricevuti
    2
    Likes dati
    5
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao
    Quante ore di straordinari ci sono dopo le 8 ore lavorate?
    io ho scritto il risultato a mano in D2 ... ma con le formule?
    Grazie per le vostre risposte

    Row\Col
    A
    B
    C
    D
    1
    entrata uscita straordinari
    2
    23:00
    08:00
    01:00

    Gerardo la la risposta la sai? O vuoi giocare?
    Invia MPPM 

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da laura belli Visualizza Messaggio
    Gerardo la la risposta la sai? O vuoi giocare?
    Ciao Laura.. certo che la risposta la so, è un quiz perché vorrei animare il forum, sai è appena partito e cè poco traffico.
    comunque questa risposta dovresti saperla!! Ciao Laura
    Invia MPPM 

  4. #4
    L'avatar di Laura Belli
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Belgio
    Età
    33
    Messaggi
    153
    Versione Office
    excel 2007
    Likes ricevuti
    2
    Likes dati
    5
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Laura.. certo che la risposta la so, è un quiz perché vorrei animare il forum, sai è appena partito e cè poco traffico.
    comunque questa risposta dovresti saperla!! Ciao Laura
    infatti penso di saperla , visto che ho imparato anche questo da te ssssssssssssssssss
    Invia MPPM 

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao

    un modo potrebbe essere:

    =MAX(0;+B1-A1+(A1>B1)-8/24)
    Invia MPPM 

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao

    un modo potrebbe essere:

    =MAX(0;+B1-A1+(A1>B1)-8/24)
    Grande Canapone
    io ho anche una soluzione alternativa


    =SE(RESTO(B2-A2;1)>8/24;RESTO(B2-A2;1)-8/24;0)
    un saluto a tutti gli amici di questa discussione
    e in particolare a Laura....
    Invia MPPM 

  7. #7
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Buonasera! Sono molto interessato a questa formula....L'ho applicata e mi funziona perfettamente quando mi conteggia le ore in più di lavoro (straordinario) ma se dovessi finire prima del termine lavorativo (permesso) mi esce errore o meglio.....tanti cancelletti.
    ESEMPIO: Il lavoro dura 8 ore dalle 08:00 alle 16:00 e se inserisco come orario di uscita le 17:00 mi da un'ora di straordinario ma se finisco alle 15:00 non mi da un'ora da recuperare ma ERRORE!
    Invia MPPM 

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao SalsaRico
    Quando si lavora con le ore si mettono i due punti (:) tra le ore e i minuti questo non è solo una formattazione ma si stabilisce delle regole ben precise, cioè excel lavora con delle porzioni di 24 ore esempio le ore 8:00 corrisponde alle 0,3333333333333333 ed excel fa i calcoli con questo ultimo numero invisibile e non con il numero che scriviamo sopra.. tutto questo è stato creato per farci restituire i numeri in sessantesimi, solo che lo svantaggio è che quando il risultato è negativo anzichè restituirci -1:00 ci restituisce ############### all'infinito cioè non sopporta i numeri negativi
    allora per aggirare il problema l'unica cosa che posso consigliarti di trasformare i numeri da sessantesimi es (14:30) a numeri centesimi cioè l'equivalente (14,50)

    inserisci questa formula in C2:

    =SE(RESTO(B2-A2;1)*24>8;RESTO(B2-A2;1)*24-8;RESTO(B2-A2;1)*24-8)

    A
    B
    C
    2
    07:00
    13:00
    -2


    PS sicuramente la formula ti darà un numero 00:00 indipendentemente se il risultato è negativo e positivo, questo perchè la formula ha strappato il formato ore:minuti dalle celle a sinistra e a questo punto cambio il formato cella in formato generale
    Fai CTRL+1 e scegli il formato generale

    fammi sapere!

    Invia MPPM 

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Una possibile alternativa:

    =SE(B2>=A2;(B2-A2)-"8:00";24-(A2-B2)-"8:00")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Una possibile alternativa:

    =SE(B2>=A2;(B2-A2)-"8:00";24-(A2-B2)-"8:00")
    Ciao ges
    c'è qualcosa che non va nella tua formula se
    se il risultato è un numero negativo mi da ################################## (con formato hh:mm)
    se invece gli do il formato generale mi da (esempio -0,00353113154)
    forse dovresti aggiustarla alla fine

    =SE(B2>=A2;(B2-A2)-"8:00";24-(A2-B2)-"8:00")*24

    [EDIT]
    Poi nella tua formula ho notato un'altro problema
    se l'oraro è a cavallo della mezzanotte mi da risultati sballati
    esempio:

    A
    B
    C
    D
    2
    22:00
    02:00
    -4
    Gerardo
    3
    22:00
    02:00
    548
    Ges

    Fammi sapere!
    Ultima modifica fatta da:Gerardo Zuccalà; 05/09/15 alle 02:18
    Invia MPPM 

  11. #11
    L'avatar di Andrea
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Levico Terme
    Età
    60
    Messaggi
    31
    Versione Office
    2013
    Likes ricevuti
    4
    Likes dati
    9
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao SalsaRico
    Quando si lavora con le ore si mettono i due punti (:) tra le ore e i minuti questo non è solo una formattazione ma si stabilisce delle regole ben precise, cioè excel lavora con delle porzioni di 24 ore esempio le ore 8:00 corrisponde alle 0,3333333333333333 ed excel fa i calcoli con questo ultimo numero invisibile e non con il numero che scriviamo sopra.. tutto questo è stato creato per farci restituire i numeri in sessantesimi, solo che lo svantaggio è che quando il risultato è negativo anzichè restituirci -1:00 ci restituisce ############### all'infinito cioè non sopporta i numeri negativi
    allora per aggirare il problema l'unica cosa che posso consigliarti di trasformare i numeri da sessantesimi es (14:30) a numeri centesimi cioè l'equivalente (14,50)

    inserisci questa formula in C2:

    =SE(RESTO(B2-A2;1)*24>8;RESTO(B2-A2;1)*24-8;RESTO(B2-A2;1)*24-8)

    A
    B
    C
    2
    07:00
    13:00
    -2


    PS sicuramente la formula ti darà un numero 00:00 indipendentemente se il risultato è negativo e positivo, questo perchè la formula ha strappato il formato ore:minuti dalle celle a sinistra e a questo punto cambio il formato cella in formato generale
    Fai CTRL+1 e scegli il formato generale

    fammi sapere!


    Ci sarebbe questa possibilità =TESTO(ASS(B2-A2),"-h:mm:ss") però non riesco ad inserirla nella formula
    Invia MPPM 

  12. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao ges
    c'è qualcosa che non va nella tua formula se
    se il risultato è un numero negativo mi da ################################## (con formato hh:mm)
    se invece gli do il formato generale mi da (esempio -0,00353113154)
    forse dovresti aggiustarla alla fine

    =SE(B2>=A2;(B2-A2)-"8:00";24-(A2-B2)-"8:00")*24

    [EDIT]
    Poi nella tua formula ho notato un'altro problema
    se l'oraro è a cavallo della mezzanotte mi da risultati sballati
    esempio:

    A
    B
    C
    D
    2
    22:00
    02:00
    -4
    Gerardo
    3
    22:00
    02:00
    548
    Ges

    Fammi sapere!
    Ho provato diverse volte e a me funzionava .... allora ho approfondito.
    In pratica, utilizzano io il MAC excel il mio excel utilizza il sistema di data 1904 che accetta gli orari negativi, mentre il windows che utilizza il sistema di data 1900 non li accetta e compaiono gli errori che tu hai descritto.
    Se utilizzi la formula senza togliere 8 ore
    =SE(B2>=A2;(B2-A2);24-(A2-B2))
    dovrebbe funzionare anche a te.
    Anche quest'altra formula dovrebbe funzionarti:
    =SE(B2>=A2;(B2-A2);(B2+1)-A2)
    Se però provo a togliere 8 ore a me continua a funzionare per il sistema di data del mio MAC mentre nel tuo windows da errori.
    Può essere anche che questo problema venga corretto con excel 2016 che io già uso.

    https://support.microsoft.com/it-it/kb/182247


    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  13. #13
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    SIETE FANTASTICI RAGAZZI!
    Sono appena rientrato dal ehm......mare (oggi caraibico) ma stasera metterò in pratica le vostre dritte. GRAZIE MILLE!
    Ultima modifica fatta da:SalsaRico; 05/09/15 alle 17:06
    Invia MPPM 

  14. #14
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Troppo forte la curiosità di sapere il risultato e quindi sono andato adesso a curiosare sul mio progetto le vostre formule.....Sono tutte e due perfettamente funzionanti (quella di GES dopo la piccola correzione di Gerardo). Non voglio approfittare della vostra conoscenza e disponibilità e temo che non sarò MAI in grado di aiutarvi perchè io rispetto a voi sono un IGNORANTONE! Un dubbio mi rimane sulle formule suggerite........Se non inserisco alcun orario in tabella mi esce un bel "-8" Come è possibile evitare questo?
    Invia MPPM 

  15. #15
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    @Andrea
    Ciao andrea grazie per il tuo suggerimento infatti sono riuscito ad adattare la tua formula alle esigenze di SalsoRico
    Cioè in caso di permesso e vuole il numero negativo in negativo
    Andrea la tua formula presentava un piccolo grande errore perchè questa formula è stata tradotta male dalla versione d excel in inglese all'Italiano infatti noterai che c'è una virgola (,) anzichè punto e virgola (;)

    =TESTO(ASS(B2-A2),"-h:mm:ss")

    comunque questa è la formula adattata

    =TESTO(ASS(SE(RESTO(B3-A3;1)>8/24;RESTO(B3-A3;1)-8/24;RESTO(B3-A3;1)-8/24));"-hh:mm")

    Attenzione!!!
    però visto che utilizzi la funzione =TESTO questa formula alla fine mi restituisce un testo per cui quella specie di numero negativo che vedi non può più essere utilizzato per farci altri calcoli sopra infatti vedrai il numero allineato sulla parte sinistra della cella a prova del fatto che non è un numero

    A
    B
    C
    D
    2
    22:00
    04:00
    -2
    Gerardo
    3
    22:00
    04:00
    -02:00 Andrea
    Invia MPPM 

  16. #16

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Citazione Originariamente Scritto da SalsaRico Visualizza Messaggio
    Troppo forte la curiosità di sapere il risultato e quindi sono andato adesso a curiosare sul mio progetto le vostre formule.....Sono tutte e due perfettamente funzionanti (quella di GES dopo la piccola correzione di Gerardo). Non voglio approfittare della vostra conoscenza e disponibilità e temo che non sarò MAI in grado di aiutarvi perchè io rispetto a voi sono un IGNORANTONE! Un dubbio mi rimane sulle formule suggerite........Se non inserisco alcun orario in tabella mi esce un bel "-8" Come è possibile evitare questo?
    Mi permetto di usare le formula di Gerardo, che mi sembra la più efficace!
    Per evitare di avere valori se non inserisci le date usa questa correzione:

    =SE(A2*B2=0;"";SE(RESTO(B2-A2;1)*24>8;RESTO(B2-A2;1)*24-8;RESTO(B2-A2;1)*24-8))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  17. #17
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Se utilizzi la formula senza togliere 8 ore
    =SE(B2>=A2;(B2-A2);24-(A2-B2))
    dovrebbe funzionare anche a te.
    Anche quest'altra formula dovrebbe funzionarti:
    =SE(B2>=A2;(B2-A2);(B2+1)-A2)


    @ Ges
    Ciao e grazie per il tuo grande contributo al forum
    infatti come tu hai precisato "con Window la formula funziona......" ma se sottraggo a 8 non funziona più strano.... e comunque non capisco perchè in questo caso MAC è meglio di windows, dovrebbe essere al contrario visto che Excel è un prodotto Microsoft....:253:

    Comunque queste tue ultime formule sono molto migliorate rispetto alla prima perchè se non altro quando lavora a cavallo della mezza-notte funziona bene, mentre nella formula precedente no

    Credo che in questa discussione abbiamo fatto grossi passi in avanti ma non sono pienamente soddisfatto perchè mi piacerebbe vedere un numero negativo in formato -hh:mm

    In attesa che qualcun'altro posso contribuire
    Saluti a tutti gli amici del forum
    Invia MPPM 

  18. #18
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da ges Visualizza Messaggio

    =SE(A2*B2=0;"";SE(RESTO(B2-A2;1)*24>8;RESTO(B2-A2;1)*24-8;RESTO(B2-A2;1)*24-8))
    Simpatico trucchetto se moltiplichi qualcosa per zero ti da zero....:285:

    Comunque sono arrivato ad una conclusione
    se il risultato finale saranno numeri che non utilizzeremo per farci sopra altri calcoli possiamo utilizzare questa soluzione che soddisfa anche l'ultima richiesta di SalsoRico

    =SE(A2*B2=0;"";TESTO(ASS(SE(RESTO(B2-A2;1)>8/24;RESTO(B2-A2;1)-8/24;RESTO(B2-A2;1)-8/24));"-hh:mm"))
    Ultima modifica fatta da:Gerardo Zuccalà; 05/09/15 alle 17:45
    Invia MPPM 

  19. #19

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Simpatico trucchetto se moltiplichi qualcosa per zero ti da zero....:285:
    Con tutte queste formule che mi girano per la testa qualche trucchetto l'ho imparato, no??? :57:


    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    @ Ges
    .... e comunque non capisco perchè in questo caso MAC è meglio di windows, dovrebbe essere al contrario visto che Excel è un prodotto Microsoft....:253:
    ...
    Che dire, excel 2016 è uscito già da alcuni mesi per MAC e dovrà ancora uscire per Windows!!!:92:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  20. #20
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Purtroppo il risultato finale mi servirà per aggiornare le ore totali che ho accumulato nell'arco dell'anno.:187:
    Invia MPPM 

  21. #21
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da SalsaRico Visualizza Messaggio
    Purtroppo il risultato finale mi servirà per aggiornare le ore totali che ho accumulato nell'arco dell'anno.:187:
    ok allora usa questa..

    =SE(A2*B2=0;"";SE(RESTO(B2-A2;1)*24>8;RESTO(B2-A2;1)*24-8;RESTO(B2-A2;1)*24-8))

    l'unica cosa che questa ti restituisce numeri industriali (centesimi) esempio 14,50 che è l' equivalente ( in sessantesimi) a 14:30

    nello svantaggio hai un grande vantaggio perchè con i numeri industriali basta la funzione SOMMA per sommare, invece con i numeri in sessantesimi c'è una procedura completamente diversa per sommare


    PS attenzione numeri industriali sono molto utilizzati perchè facili da sommare
    sappi solamente che hanno un formato diverso con la virgola(,) e devi tenere in mente che sono in centesimi vale a dire che la mezzora non'è 0:30 ma 0,50
    vedi tabella semplificativa:

    A
    B
    7
    sessantesimi industriali
    8
    21:30
    21,50
    9
    14:15
    14,25
    10
    02:45
    2,75
    Ultima modifica fatta da:Gerardo Zuccalà; 05/09/15 alle 18:27
    Invia MPPM 

  22. #22
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Grazie Gerardo! Anche questa soluzione funziona e il risultato si somma alle restanti ore accumulate nell'anno ma..........purtroppo i centesimi possono sostituire le ore e le mezz'ore ma se dovessi fare, per esempio, 15 0 20 minuti di credito o debito sballa tutto
    Invia MPPM 

  23. #23
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    ok
    una soluzione che funziona potrebbe essere questa..

    visto che i numeri negativi ci davano errore ########################
    a questo punto abbiamo trovato la formula che ci scrive anche i numeri negativi però con la gravante che ci restituiva in 100esimi anzichè 60esimi e giustamente come avevi affermato tu alla fine sommando il risultato ti sballava

    credo che comunque il risultato/somma di questi numeri sarà sempre un numero positivo (perchè parliamo di ore lavorate) a questo punto il risulto finale lo dividi per 24

    esempio in A1 hai un numero cosi 221,25
    in B1 fai questa formula =A1/24
    verrà fuori un numero strano
    a quel punto gli dai il formato cella [hh]:mm

    PS attenzione Ricordati di aprire e chiudere la parentesi quadra [hh]:mm


    Invia MPPM 

  24. #24
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Come posso inviarti in allegato il progetto fac-simile?
    Invia MPPM 

  25. #25
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da SalsaRico Visualizza Messaggio
    Come posso inviarti in allegato il progetto fac-simile?
    Puoi tranquillamente inserire un allegato in questo forum in questa discussione, ma hai provato a fare diviso 24 e poi formattare il numero?
    comunque se non sai come inserire un allegato guarda questo video!
    http://www.forumexcel.it/forum/2-ann...-xlsm-docx-pdf
    Invia MPPM 

  26. #26
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    ecco il mio progetto!
    Ci sentiamo domani.....Buonanotte!
    Ultima modifica fatta da:SalsaRico; 07/09/15 alle 01:39
    Invia MPPM 

  27. #27
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao SalsoRico
    Forse se avessimo messo sin da subito un piccolo allegato ci saremmo capiti meglio infatti parte delle formule che abbiamo creato non facevano per il nostro caso.

    Questa formula qui sotto serve per avere la somma giornaliera senza la pausa, questa formula tiene conto anche se ci sono turni a cavallo di mezzanotte. Questa formula è con formato in sessantesimi hh:mm
    in I6 e copia in basso:
    =SOMMA(RESTO(E6-D6;1);RESTO(H6-G6;1))


    poi in I11 ho fatto la somma ti tutte le ore settimanali
    =SOMMA(I6:I10) però attenzione quando premo invio excel mi da lo stesso formato che c'è sopra hh:mm ma io ho bisogno di dare questo formato [hh]:mm perchè cosi mi calcola tutto ciò che cè superiore alle 24 ore


    Adesso c'è il vero problema da sciogliere e per fare questo ho aggiunto una cella,
    per scoprire il saldo settimanale (sotto le 36 ore) sarebbe stato semplice se il saldo fosse sempre positivo ma potrebbero eserci dei permessi e inevitabilmente vai in negativo, questo è un problema perchè excel da PC non riconosce i numeri negativi in formato hh:mm (sessantesimi)
    e mi da errore ########## indi per cui ho fatto una semplice escamotage ho convertito da sessantesimi a centesimi (formato generale) e quindi ho creato questa formula:
    =I11-36/24 (Attenzione dai il formato generale!)

    Per sapere le ore accumulate durante l'anno è semplicissimo
    basta sommare il saldo precedente esempio 100 ore al saldo settimanale però attenzione visto che alla fine vorrei che le ore vengano visualizzate in formato hh:mm (sessantesimi) devo mettere anche la parentesi quadra cosi [hh]:mm

    vedi allegato e fammi sapere!
    Ciao






    Ultima modifica fatta da:Gerardo Zuccalà; 07/09/15 alle 16:30
    Invia MPPM 

  28. #28
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Ho letto il messaggio solo ora!
    Ti ringrazio dell'aiuto e del tempo che hai speso per me. Oggi sono fuori sede ma al rientro seguirò le tue dritte.
    Ti tengo aggiornato GRAZIE!
    Invia MPPM 

  29. #29
    L'avatar di SalsaRico
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Pescara
    Età
    52
    Messaggi
    9
    Versione Office
    2014 PC
    Likes ricevuti
    0
    Likes dati
    0
    Ho aperto il file di excel da te CREATO! Ho fatto delle prove simulando tutte le situazioni possibili e ora posso dire con estrema soddisfazione che funziona PERFETTAMENTE!
    Ti ringrazio per la tua pazienza e disponibilità!
    Vorrei attivare il quesito RISOLTO ma andando nel menù a tendina di "Strumenti di discussione" mi escono le seguenti opzioni: Visualizza versione stampabile - Invia questa pagina via email - Annulla Sottoscrizione e Questa Discussione.
    Vorrei scegliere "Segna questo Thread come risolto" ma non riesco a trovarlo. Certo della mia imbranataggine con l'attenuante che ho fatto il turno di notte, ti chiedo un ultimo imbarazzante aiuto.
    Grazie mille Gerardo!
    Invia MPPM 

  30. #30
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da SalsaRico Visualizza Messaggio
    Ho aperto il file di excel da te CREATO! Ho fatto delle prove simulando tutte le situazioni possibili e ora posso dire con estrema soddisfazione che funziona PERFETTAMENTE!
    Ti ringrazio per la tua pazienza e disponibilità!
    !
    Ciao SalsaRico Grazie per il tuo riscontro Positivo
    Sono contento che siamo riusciti a risolvere questo problema

    Vorrei attivare il quesito RISOLTO
    Non so come mai non riesci a vedere il pulsante risolto, forse bisogna attivare i permessi, in attesa di risolvere il problema ho messo io RISOLTO

    Salsa Rico, una curiosità ho visto che nel box dell' avatar hai inserito Versione di Office 2014 scusami ma io non la conosco, mi sono perso qualcosa? sapresti spiegarmi o è solo un'errore di digitazione
    Ciao e torna quando vuoi!!
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Estrarre da testo giorno, mese e giorno settimana.
    Di alfrimpa nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 17:39
  2. usare funzione "giorno lavorativo" con frazioni di giorno
    Di CaesarIII nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 25/09/16, 00:23
  3. Salvare i dati di un giorno sotto la colonna dello stesso giorno.
    Di Laura Belli nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 26/08/16, 08:51
  4. Quiz del Giorno #2 Rango e classifica
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 13/06/15, 06:50
  5. Quiz del Giorno #1
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 13/06/15, 02:02

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •