Risultati da 1 a 9 di 9

Discussione: Selezionare record



  1. #1
    L'avatar di balu5
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    pisa
    Età
    63
    Messaggi
    3
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Selezionare record

    Buonasera.
    Seguo il calcio e sono un tifoso del Pisa (so che già questa affermazione mi renderà antipatico ad una buona parte di voi... ma si sa... ognuno ha i propri difetti...).
    Sto cercando di ricostruire tutti i risultati della mia squadra e sono a buon punto.
    Mi piacerebbe riuscire ad estrarre e ricapitolare i risultati ottenuti contro una qualsiasi avversaria (Juventus, Milan, Inter, Modena, Livorno, Pontedera, ecc.) per ottenere
    così il numero di partite giocate, vinte, nulle, perse, reti fatte, reti subite, magari suddivise anche tra gare interne ed esterne ed anche evidenziando il tipo di campionato (Serie A, Serie B, Coppa Italia, ecc.).
    Allego un sottoinsieme del database (più grande il forum non lo accetta) chiedendo suggerimenti.
    Ovviamente non pretendo una soluzione completa ed esaustiva, ma qualunque suggerimento sarebbe oltremodo ben accetto.
    Grazie in anticipo a tutti voi.
    Luca
    Invia MPPM 

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    in L6 prova a scrivere Turris

    in M6 da confermare con control+maiusc+invio

    =SE.ERRORE(INDICE(A$6:A$510;PICCOLO(SE($J$6:$J$510=$L$6;RIF.RIGA($6:$510)-5);RIGHE($A$1:$A1)));"")

    Una volta confermata la formula copiala in basso ed a sinistra sino alla colonna T

    Saluti
    Invia MPPM 

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da balu5 Visualizza Messaggio
    Buonasera.
    Seguo il calcio e sono un tifoso del Pisa (so che già questa affermazione mi renderà antipatico ad una buona parte di voi... ma si sa... ognuno ha i propri difetti...).
    Ciao Luca e benvenuto nel forum
    Vai tranquillo qui vogliamo bene a tutti


    Allego un sottoinsieme del database (più grande il forum non lo accetta) chiedendo suggerimenti.
    Ti volevo solo informare che se hai dei file grossi, li puoi allegare con una delle tante piattaforme di Hosting on-line come DropBox, Box, GoogleDrive, File dropper, Dropcanvas ecc

    Luca per evitare equivoci come preferisci che vengano visulaizzati i dati?
    li Vuoi su piu fogli? magari campionato per campionati, potresti fare un piccolo esempio con il risultato desiderato scritto a mano di come e dove vuoi che vengano scritti i dati che adiamo ad estrarre

    Luca ci sono diversi modi per estrarre, con i Filtri, con le formule, con le tabelle Pivot facci sapere come preferisci
    ciao

    [EDIT]
    Vedo che Canapone ha capito tutto al volo, come al solito :98:
    Ultima modifica fatta da:Gerardo Zuccalà; 25/09/15 alle 20:14
    Invia MPPM 

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    ancora più semplice. In L6 la squadra da filtrare, in M6 basta copiare (non serve il control+maiusc+invio)

    =SE.ERRORE(INDICE(A$6:A$510;PICCOLO(INDICE(($J$6:$J$510=$L$6)*(RIF.RIGA($6:$510)-5););CONTA.SE($J$6:$J$510;"<>"&$L$6)+RIGHE($A$1:$A1)));"")

    Poi copia in basso ed a sinistra.

    Formatta la colonna N come "data"

    Saluti
    Invia MPPM 

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7140
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Soluzione con convalida dati (in modo da avere un elenco) e colonna d'appoggio (nascosta).
    Allego file https://www.dropbox.com/s/b9yb5v5kda...mpio.xlsx?dl=0
    Invia MPPM 

  6. #6
    L'avatar di balu5
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    pisa
    Età
    63
    Messaggi
    3
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Risultato IDEALE

    Questo sarebbe il risultato IDEALE:

    JUVENTUS
    Riepilogo globale
    TOTALI CASA FUORI
    G V N P RF RS G V N P RF RS G V N P RF RS
    7 1 2 4 3 8 4 1 1 2 2 5 3 0 1 2 1 3
    Serie A
    TOTALI CASA FUORI
    G V N P RF RS G V N P RF RS G V N P RF RS
    4 1 1 2 2 5 2 1 0 1 1 2 2 0 1 1 1 3
    Coppa Italia
    TOTALI CASA FUORI
    G V N P RF RS G V N P RF RS G V N P RF RS
    3 0 1 2 2 6 2 0 1 1 1 3 1 0 0 1 1 3
    Invia MPPM 

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Balu5
    Ecco qui quello che mi hai chiesto
    ho aggiunto anche un menu a tendina per scegliere la serie o il torneo
    Per fare queste formule ho usato la definizione dei nomi
    Poi ho fatto tutte le formule con il MATR.SOMMA.PRODOTTO
    Qui in allegato

    http://dropcanvas.com/tv0ux



    IN CASA:
    Giocate =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2))

    Vinte =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE>RETI_ESTERNE))

    Pareggiate =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE=RETI_ESTERNE);--(RETI_INTERNE<>""))

    Perse =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE<RETI_ESTERNE))

    Reti fatte =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);RETI_INTERNE)

    Reti Subite =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);RETI_ESTERNE)


    Se hai domande non esitare
    Ultima modifica fatta da:Gerardo Zuccalà; 27/09/15 alle 19:25 Motivo: Ortografico
    Invia MPPM 

  8. #8
    L'avatar di balu5
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    pisa
    Età
    63
    Messaggi
    3
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Balu5
    Ecco qui quello che mi hai chiesto
    ho aggiunto anche un menu a tendina per scegliere la serie o il torneo
    Per fare queste formule ho usato la definizione dei nomi
    Poi ho fatto tutte le formule con il MATR.SOMMA.PRODOTTO
    Qui in allegato

    http://dropcanvas.com/tv0ux



    IN CASA:
    Giocate =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2))

    Vinte =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE>RETI_ESTERNE))

    Pareggiate =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE=RETI_ESTERNE);--(RETI_INTERNE<>""))

    Perse =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);--(RETI_INTERNE<RETI_ESTERNE))

    Reti fatte =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);RETI_INTERNE)

    Reti Subite =MATR.SOMMA.PRODOTTO(--(SERIE=B10);--(CASA=A1);--(FUORI=A2);RETI_ESTERNE)


    Se hai domande non esitare






    Visto... grazie...
    ora cerco di adattarlo al file completo...

    Comunque... permettimi una considerazione...
    SEI VERAMENTE FORTISSIMO ! ! !
    Invia MPPM 

  9. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Grazie del tuo riscontro positivo.

    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

    Balu5
    Sse vuoi capire le formule che ho fatto dai una occhiata a questi 2 video
    cosi magari la prossima volta puoi fare le formule da solo
    Ciao



    Invia MPPM 

Discussioni Simili

  1. [Risolto] Selezionare da elenco a discesa e
    Di profet86 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 24/03/17, 10:31
  2. [Risolto] Macro che crea nel foglio tre un record dopo un altro record
    Di Mcmatt nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 16/03/17, 10:34
  3. Come selezionare due celle con una macro
    Di simone1979 nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 20/02/17, 19:06
  4. [Risolto] selezionare più celle
    Di maxilrosso nel forum Domande su Excel VBA e MACRO
    Risposte: 14
    Ultimo Messaggio: 03/02/17, 14:04
  5. Selezionare il prossimo dato.
    Di Laura Belli nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 29/09/15, 18:02

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •