Risultati da 1 a 6 di 6

Discussione: Acquisire un commento



  1. #1
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    Acquisire un commento

    Ciao a tutti,
    sto girando un po in rete ma non ho trovato niente che faccia al mio caso.
    con i soliti cerca.vert o indici acquisisco il contenuto della cella.
    ma se volessi acquisire anche il commento che è all'interno della cella trovata?
    anche una soluzione vba andrebbe bene, anche se la vedo dura...
    grazie anche per dei consigli.
    ciao
    ale
    Invia MPPM 

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ho trovato la soluzione
    http://www.andreaperotti.ch/apps/wor...a-celle-excel/
    olè.
    ciao
    ale
    Invia MPPM 

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ale Questa funzione è fortissima!

    =GetCommentText(A1)
    Codice: 
    Function GetCommentText(rCommentCell As Range)Dim strGotIt As String
    On Error Resume Next
    strGotIt = WorksheetFunction.Clean _
    (rCommentCell.Comment.Text)
    GetCommentText = strGotIt
    On Error GoTo 0
    End Function

    :98:
    Ultima modifica fatta da:Gerardo Zuccalà; 29/09/15 alle 15:08
    Invia MPPM 

  4. #4
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao gerardo...grazie.
    se può esser d'aiuto con questa
    =SE.ERRORE(STRINGA.ESTRAI(getCommentText(INDIRETTO(INDIRIZZO(CONFRONTA(E40;name;0);CONFRONTA(A40;date2;0))));TROVA(":"; getCommentText(INDIRETTO(INDIRIZZO(CONFRONTA(E40;name;0);CONFRONTA(A40;date2;0)))); 1)+1; 50);"")
    adattandola, si ha il commento pulito senza il nome iniziale.
    ciao
    ale
    Invia MPPM 

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Alessandro Visualizza Messaggio
    ciao gerardo...grazie.
    se può esser d'aiuto con questa
    =SE.ERRORE(STRINGA.ESTRAI(getCommentText(INDIRETTO(INDIRIZZO(CONFRONTA(E40;name;0);CONFRONTA(A40;date2;0))));TROVA(":"; getCommentText(INDIRETTO(INDIRIZZO(CONFRONTA(E40;name;0);CONFRONTA(A40;date2;0)))); 1)+1; 50);"")
    adattandola, si ha il commento pulito senza il nome iniziale.
    ciao
    ale
    haaa ok
    ottima formula
    Comunque io per togliere il nome iniziale non l'ho scritto nel commento e ho fatto prima!:127:
    ovviamente scherzo, a volte se i commenti sono tanti e scritti da qualcun'altro sicuramente è comodo
    Ciao Ale
    Invia MPPM 

  6. #6
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ma guarda...se vuoi saperla tutta io l'ho tolto perchè mi vergognavo di leggere sempre quel acareri...
    ma a parte gli scherzi è buono e utile, su file utilizzati da diverse persone, sapere di chi è il commento.
    ciao
    ale
    Invia MPPM 

Discussioni Simili

  1. Inserire commento automaticamente
    Di Franco71 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 09/06/17, 13:17
  2. far acquisire calcolo di numeri da foglio 1 a foglio 2-3
    Di bikem4 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 02/12/16, 18:26
  3. Commento al click
    Di bobparr nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 01/08/16, 18:08
  4. Risposte: 3
    Ultimo Messaggio: 08/04/16, 12:34
  5. Cella con commento
    Di roky48 nel forum Domande su Excel VBA e MACRO
    Risposte: 15
    Ultimo Messaggio: 04/11/15, 13:08

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •