Risultati da 1 a 5 di 5

Discussione: Riconosci cella con testo=" " da una cella vuota



  1. #1
    L'avatar di aldomattana
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Modena
    Età
    46
    Messaggi
    184
    Versione Office
    Office 2007
    Likes ricevuti
    9
    Likes dati
    33

    Riconosci cella con testo=" " da una cella vuota

    Ciao a tutti, uso excel anche per ottenere una lunga descrizione di prodotto in base a varie formule e scelte, questa descrizione viene poi copiata e incollata in email o in word e spedita:
    è necessario che sia quindi correttamente formattata senza necessità di controllo ulteriore.

    Il problema che mi ritrovo ora è riassunto nell'esempio che segue:



    http://1drv.ms/1OObNwk (FILE ZIPPATO)
    Grazie, Aldo.
    PS: Se la "cosa" ti ha aiutato, mi piace se mi dai un "mi piace" - Se mi hai aiutato tu, ti ringrazio 2 volte ;-)

  2. #2
    L'avatar di Baloon_50
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano - Italy
    Età
    67
    Messaggi
    3349
    Versione Office
    2013 PC
    Likes ricevuti
    483
    Likes dati
    49
    Non so se si riesce a farlo con le formule (sono un po' scarso in merito) se la cosa ti va si potrebbe fare qualcosa in VBA :183:

    ciao

    A volte basta usare parole inutili come “grazie” e “per favore” per rendere la vita più bella.
    (ELKonigsburg)
    Dice il saggio : "se vuoi essere aiutato devi metter l'allegato"
    (Nick Carter - Ten)

  3. #3
    L'avatar di Baloon_50
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano - Italy
    Età
    67
    Messaggi
    3349
    Versione Office
    2013 PC
    Likes ricevuti
    483
    Likes dati
    49
    Ho provato un po' e senza fare nulla di speciale ci sono riuscito.
    In pratica devi unire 4 celle ed all'interno scrivere la formula (=D3&" "&D4&" "&D5&" "&D6).

    ti allego il tuo file dove è evidenziata in giallo la soluzione.

    :299:

    A volte basta usare parole inutili come “grazie” e “per favore” per rendere la vita più bella.
    (ELKonigsburg)
    Dice il saggio : "se vuoi essere aiutato devi metter l'allegato"
    (Nick Carter - Ten)

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4046
    Versione Office
    2013
    Likes ricevuti
    1239
    Likes dati
    931
    Ciao a tutti,
    @aldomattana
    riferendomi al tuo file allegato....
    potresti modificare le prime formule.
    Nella cella D4 scriverai:
    =SE(B3<1;"";A3&" ha "&B3&" anni."&CODICE.CARATT(10))

    e dopo copi la cella in giù per gli altri nomi. In questo modo però avrai un "a capo" in più alla fine della lista. Per eliminarlo, potresti aggiungere una condizione alla formula di prima. Quindi la formula nella cella D4 diventerebbe:
    =SE(B3<1;"";SE(B4="";A3&" ha "&B3&" anni.";A3&" ha "&B3&" anni."&CODICE.CARATT(10)))

    Mentre nella cella dove vuoi la lista finale (cella H3 nell'esempio), scriverai semplicemente:
    =CONCATENA(D3;D4;D5;D6)

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao a tutti,

    un approccio molto simile a quanto proposto prima qui sopra:

    =D3&SE(D3<>"";CODICE.CARATT(10);"")&D4&SE(D4<>"";CODICE.CARATT(10);"")&D5&SE(D5<>"";CODICE.CARATT(10);"")&D6

    Spero sia d'aiuto

Discussioni Simili

  1. [Risolto] Testo interno di una "Shape" preso da una cella
    Di atievoli nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 11/02/17, 10:51
  2. [Risolto] Come considerare il valore "FALSO" come cella vuota
    Di Emax80 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/12/16, 13:13
  3. Risposte: 5
    Ultimo Messaggio: 27/09/16, 17:06
  4. funzione [conta.se]: contare il valore di un testo in una cella con "concatena"
    Di delittogoloso nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 05/07/16, 23:55
  5. Formula non accetta indirizzamento cella "COMBO BOX"
    Di Mirco nel forum Domande sui Grafici di Excel
    Risposte: 5
    Ultimo Messaggio: 19/06/16, 02:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •