Risultati da 1 a 6 di 6

Discussione: Elenco in righe con duplicati...



  1. #1
    L'avatar di Sminds
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milan
    Età
    34
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Elenco in righe con duplicati...

    Ciao, ho un problema che all'apparenza mi sembrava banale ma non riesco a trovare una soluzione... Qui sotto esempio:
    Questa la situazione di partenza. In colonna A un serie di dati di cui molti duplicati. In colonna B i valori di riferimento
    colonna A Colonna B
    mario 10
    mario 12
    mario 15
    luigi 5
    luigi 3
    franco 14
    franco 12
    franco 44

    Vorrei arrivare ad ottenere in un nuovo foglio di lavoro in colonna A solo elenco senza duplicati delle chiavi principali e a fianco in B, C, D, ecc... i valori.
    Tipo questo:
    A B C D
    mario 10 12 15
    luigi 5 3
    franco 14 12 44

    Ho provato CERCA VERT ma ovviamente mi prende solo il primo risultato per ogni cambiamento in colonna A. Ho provato altre soluzioni ma nulla... Ovviamente l'esempio è proprio solo un esempio il DB è 5000 righe
    GRAZIE a chi vorrà aiutarmi
    Invia MPPM 

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Sminds
    Benvenuto in ForumExcel.it
    effettivamante la tua domanda nonè affatto facile, bisogna conoscere qualche formula

    Visto che hai Excel 2013 ho trovato una soluzione con la funzione AGGREGA

    infatti in D2 ho fatto questa formula da copiare in basso
    =SE.ERRORE(INDICE(data;AGGREGA(15;6;RIF.RIGA(data)-RIF.RIGA($A$2)+1/(FREQUENZA(CONFRONTA(data;data;0);RIF.RIGA(data)-RIF.RIGA($A$2)+1)>0);RIGHE(A$1:A1)));"")


    Mentre per estrarre i dati in E2 fai questa formula e copia in basso e a destra
    =SE.ERRORE(INDICE($B$2:$B$9;AGGREGA(15;6;(RIF.RIGA(data)-RIF.RIGA($A$2)+1)/(data=$D2);COLONNE($E2:E2)));"")

    [EDIT]
    ho dimenticato di dirti che deve dare un nome all' intervallo che lo chiamerai data riferito ad A2:A9
    Fammi sapere se va bene!

    Ciao

    A
    B
    C
    D
    E
    F
    G
    H
    1
    Data NUMERI LISTA UNICA
    2
    mario
    10
    mario
    10
    12
    15
    3
    mario
    12
    luigi
    5
    3
    4
    mario
    15
    franco
    14
    12
    44
    5
    luigi
    5
    6
    luigi
    3
    7
    franco
    14
    8
    franco
    12
    9
    franco
    44
    Ultima modifica fatta da:Gerardo Zuccalà; 14/10/15 alle 00:38
    Invia MPPM 

  3. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  4. #3
    L'avatar di Sminds
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milan
    Età
    34
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2
    Ciao Gerardo, grazie in anticipo! Domattina appena arrivò in ufficio provo...!!! Ti farò sapere. Grazie ancora
    Invia MPPM 

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Sminds Visualizza Messaggio
    Ciao Gerardo, grazie in anticipo! Domattina appena arrivò in ufficio provo...!!! Ti farò sapere. Grazie ancora
    ok per comodità ti ho anche messo l'allegato cosi lo potrai verificare meglio
    Ultima modifica fatta da:Gerardo Zuccalà; 14/10/15 alle 00:39
    Invia MPPM 

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Sminds
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milan
    Età
    34
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2
    PERFETTO!!! Grazie Gerardo! Funziona alla grande.. Un po' di tempo su "calcolo processore 2%"........ ma poi è andata. Ho verificato i dati e vanno benissimo....!!! Grazie ancora.
    ciao
    Invia MPPM 

  8. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Sminds Visualizza Messaggio
    PERFETTO!!! Grazie Gerardo! Funziona alla grande.. Un po' di tempo su "calcolo processore 2%"........ ma poi è andata. Ho verificato i dati e vanno benissimo....!!! Grazie ancora.
    ciao
    Ciao Sminds grazie del tuo riscontro positivo .
    Comunque con 5000 righe è abbastanza normale che la formula ci metta un po di tempo
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Cerca duplicati in matrice e somma duplicati
    Di alleiram87 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 27/03/17, 21:51
  2. Copia righe in excel saltando righe nel foglio di destinazione
    Di Deadman nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 21/02/17, 16:09
  3. [Risolto] estrarre delle righe da un elenco secondo un criterio e tra due date inizio e fine
    Di geometrak nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 05/11/16, 17:03
  4. come eliminare righe vuote, tra righe di testo in una pagina excel
    Di francesco71 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 08/05/16, 14:13
  5. Risposte: 12
    Ultimo Messaggio: 23/03/16, 11:41

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •