Risultati da 1 a 4 di 4

Discussione: Conta se a tre condizioni



  1. #1
    L'avatar di thebigleon
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Como
    Età
    29
    Messaggi
    1
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Conta se a tre condizioni

    Ciao a tutti, ho un file excel cosi composto, da 3 colonne:


    Colonna 1 Colonna 2 Colonna 3


    Tipologia A 01/02/1988 M
    Tipologia C 22/12/1978 F
    Tipologia A 12/12/1999 M
    ....




    Dovrei contare il numero di celle che soddisfino tre condizioni:


    Stessa tipologia, con data di nascita inferiore a 01/01/1998 e sesso M




    Ho provato con:


    =MATR.SOMMA.PRODOTTO((C2:C1318="Tipologia A")*(D2:D1318>="01/01/1998")*(E2:E1318="M"))




    Ma i dati non sono corretti, il conteggio è sballato...

    grazie
    Ultima modifica fatta da:Canapone; 08/02/17 alle 08:15

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ci sarebbe anche la formula SOMMA.PIU.SE... o CONTA.PIU.SE...
    Hai provato con quelle?

    Un piccolo file di esempio con pochi dati sarebbe d'aiuto ;)

    P.S.
    nella formula MATR.SOMMA.PRODOTTO perchè moltiplichi le matrici con "*" ?
    La moltiplicazione e la somma sono intrinseche nella funzione, basta separare le matrici con un ";" (punto e virgola).

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    TheBigleon

    =MATR.SOMMA.PRODOTTO((C2:C1318="Tipologia A")*(D2:D1318>=01/01/1998)*(E2:E1318="M"))


    Prova la formula in questo modo.



    Saluti
    Window 8.1 Excel 2013/2016

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7160
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Un'alternativa:

    =CONTA.PIÙ.SE(A1:A4;"Tipologia A";B1:B4;"<1/1/98";C1:C4;"M")

Discussioni Simili

  1. [Risolto] CONTA.SE() e funzione E()
    Di marcob33 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/02/17, 21:33
  2. [Risolto] Conta se con tre condizioni
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 22/01/17, 19:02
  3. [Risolto] problema con conta.piu.se
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 20/12/16, 12:01
  4. [Risolto] conta caselle
    Di peppe1 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 16/10/16, 10:15
  5. Conta valori con condizioni
    Di Giuliano nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/01/16, 13:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •