Risultati da 1 a 3 di 3

Discussione: matr.somma.prodotto



  1. #1
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    matr.somma.prodotto

    Ciao a tutti,
    mi è capitata una cosa strana.
    Diciamo che ho una formula così':
    =MATR.SOMMA.PRODOTTO((compl_act);1*(compl_team=F10))
    ho definito come nomi
    compl_act=R2:R100
    compl_team=S2:S100 e F10 è un nome.
    La formula l'ho resa sia matriciale che normale, ma il risultato non cambia.

    Quindi l'unica variabile in gioco è quel F10, dove abbiamo
    =SE(B10="Totale complessivo";"";SE(VAL.VUOTO(C10);F9;C10))
    che è a seguire di una pivot (è un semplice campo d'appoggio).
    Funziona tutto perfettamente.
    Se però nella pivot comprimo una parte delle etichette righe, il risultato cambia a mi da zero, nonostante F10 non vari.
    Come è possibile?
    Scusate se non allego il file ma ho ridotto all'osso una formula e un file ben più complesso.
    Volevo solo sapere se così' al volo vi poteva venire in mente qualche idea.
    La formula è attaccata al solo F10, questo non varia (mi sono anche incollato solo valori i due nomi prima e dopo il comprimere la pivot, e sono uguali).
    Fatto sta che prima la formula mi da il suo valore reale poi (comprimo la pivot ma con F10 invariato) e mi da zero.
    Faccio altre prove.
    Grazie anche per dei suggerimenti.
    ciao
    ale
    Invia MPPM 

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    qui una simulazione del file
    https://www.dropbox.com/s/lp1s3asaoa...tel1.xlsx?dl=0
    se facciamo doppio click su A5 per comprimere quell'etichetta il valore non cambia (come è giusto che sia).
    perchè nel mio file si?
    ciao
    ale
    Invia MPPM 

  3. #3
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ragazzi ho risolto...conosco i miei polli (parlo di me ovviamente)...
    il più delle volte per scavare a fondo al problema e analizzare il tutto ho bisogno di scriverlo e solo dopo capisco l'anomalia.
    ora stavo rileggendo il post...ed ecco la soluzione.
    quando comprimevo la pivot in automatico c'erano degli indici (che mi costruivano a loro volta delle altre tabelle) che mi si azzeravano, e la seconda matrice era
    attaccata a sua volta ad altri fogli che, trovando zero tutto, mi davano ovviamente come risultato zero.
    scusate ancora.
    era un NON problema.
    ciao ciao
    ale
    Invia MPPM 

Discussioni Simili

  1. [Risolto] matr.somma.prodotto ma spostato di n posizioni
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 05/10/16, 14:54
  2. MATR.SOMMA.Prodotto... un pò di teoria
    Di Beppe nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 29/05/16, 22:02
  3. Matr.somma.prodotto
    Di Khan nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/03/16, 13:33
  4. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  5. MATR.SOMMA.PRODOTTO per contare o sommare
    Di Baloon_50 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 22/08/15, 22:12

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •