Risultati da 1 a 13 di 13

Discussione: Ricerca e Confronta



  1. #1
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0

    Ricerca e Confronta

    Buongiorno A tutti! Ho un problema a cui non sono riuscito ancora a trovare una soluzione :(
    Ho un foglio composto da due colonne. Nella prima colonna ci sono una decina di codici diversi che si ripetono per circa 200 volte casulamente.(tipo 01,02,02,01,03,04,03 ecc) Nella seconda colonna ci sono delle lettere ( A,B, C). Io dovrei trovare il modo di sapere se, per esempio, al codice 01 corrisponde la lettera A. Se tutti i codici 01 corrisponde la lettera A, bene, se corrispondono lettere diverse allora dovrebbe segnare errore. Esempio, tutti i codici 01 devono avere la lettera A. Se un codice 01 ha la letta B o cella vuota dovrebbe segnarmi errore.
    Qualcuno può illuminarmi? Grazie.


    Invia MPPM 

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1657
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184
    Ciao
    un file di esempio sarebbe stato ottimale, comunque, prova con:
    =SE(MATR.SOMMA.PRODOTTO((B1:B200="a")*(A1:A200="01"))=CONTA.SE(A1:A200;"01");"bene";"errore")
    Invia MPPM 

  3. #3
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Allego un esempio così mi spiego meglio.
    Nella colonna A ho documenti. Nella colonna B ho la resa. Ad un documento corrisponde una resa. Per esempio nella prima riga ho il documento 15406197 a cui corrisponde la resa D nella seconda colonna.
    Come si può vedere, il codice 15406197 si ripete per più righe ed in alcuni casi corrisponde sempre alla resa D, in altri può essere vuota oppure un'altra lettera.
    Il mio problema è: devo verificare che per tutti i documenti 15406197 dell'elenco ci sia una stessa resa. Se tutti hanno resa d, ok, se qualcuno ha resa diversa o vuota mi segnali errore.
    spero di essermi spiegato

    http://www.netdesigner.it/esempio.xlsx
    Invia MPPM 

  4. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno

    IN C2 =SE(E(A2=$A$2;B2=$B$2);"ok";"errore") Copia in basso
    Window 8.1 Excel 2013/2016
    Invia MPPM 

  5. #5
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie per la risposta ma mi segna errore. Funziona con il primo codice, ma dal momento che il codice cambia continua a darmi errore
    Invia MPPM 

  6. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera



    Sicuramente non ho capito ma nel file inviato solo due record corrispondono ad 15406197 e D e sono quelli segnalati con ok dalla formula

    Saluti
    Window 8.1 Excel 2013/2016
    Invia MPPM 

  7. #7
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    il mio era un esempio....a me serve che mi dica ok o errore per tutti i codici della colonna a. Se ad un documento corrisponde una resa, a tutti i documenti uguali deve corrispondere la stessa resa. Questa verifica devo farla per ogni singolo documento.
    Invia MPPM 

  8. #8
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1657
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184
    ciao
    continuo a sostenere che la formula è quella di prima, adattata ai dati del file:
    =SE(MATR.SOMMA.PRODOTTO(($B$2:$B$164="d")*($A$2:$A$164=15406197))=CONTA.SE($A$2:$A$164;"15406197");"bene";"errore")

    ovviamente, se "D" e/o 15406197 cambiano, devi parametrarli in delle celle preposte ed inserirne i riferimenti nella formula

    leggo adesso gli altri commenti, come prevedevo , volevi parametrare i criteri in C2:
    =SE(MATR.SOMMA.PRODOTTO(($B$2:$B$164=B2)*($A$2:$A$164=A2))=CONTA.SE($A$2:$A$164;A2);"bene";"errore")
    e trasscini in basso
    Invia MPPM 

  9. #9
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Alla Grande! Funziona. Ti domando una cosa...è possibile inserire la dicitura "vuota" nel caso nella cella non ci siano valori?
    Invia MPPM 

  10. #10
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1657
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184
    nella cella quale????, presumo in B, prova:
    =SE(B2="";"vuota";SE(MATR.SOMMA.PRODOTTO(($B$2:$B$164=B2)*($A$2:$A$164=A2))=CONTA.SE($A$2:$A$164;A2);"OK";"errore"))
    Invia MPPM 

  11. I seguenti utenti hanno dato un "Like"


  12. #11
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    nella cella quale????, presumo in B, prova:
    =SE(B2="";"vuota";SE(MATR.SOMMA.PRODOTTO(($B$2:$B$164=B2)*($A$2:$A$164=A2))=CONTA.SE($A$2:$A$164;A2);"OK";"errore"))
    Ottimo! Funziona! Grazie mille!
    Adesso vado a studiarmi matr.somma.prodotto che non conosco
    Invia MPPM 

  13. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da bortoly Visualizza Messaggio
    Ottimo! Funziona! Grazie mille!
    Adesso vado a studiarmi matr.somma.prodotto che non conosco
    Ciao bortoly, Ottima la formula di ninai come sempre di livello, comunque se vuoi imparare la funzione MATR.SOMMA.PRODOTTO
    dalla base fino a livello avanzato, guarda tutti e tre questi video tutorial che sicuramente ti aiuteranno.
    Ciao e fammi sapere!





    Invia MPPM 

  14. #13
    L'avatar di bortoly
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Vicenza
    Età
    39
    Messaggi
    7
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Li sto guardando
    . Davvero molto utili, anche se non è molto semplice da capire. grazie mille :)
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Cerca verticale con confronta
    Di vittorio dit nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 11/11/16, 21:17
  2. Indice e confronta co SE(E(O(rif,rig(rrf.col))))
    Di Amerigo nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/09/16, 00:21
  3. Formule orari min e max in indice(confronta)
    Di Sasyjoe nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 15/03/16, 13:01
  4. funzione CONFRONTA con VBA
    Di John nel forum Domande su Excel VBA e MACRO
    Risposte: 21
    Ultimo Messaggio: 06/11/15, 20:34
  5. (ricerca, confronta) disporre dati
    Di Manuel Rolando nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 22/10/15, 21:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •