Risultati da 1 a 14 di 14

Discussione: classifica - ma con alcune discriminanti



  1. #1
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    classifica - ma con alcune discriminanti

    ciao a tutti,
    vorrei costruirmi una classifica partendo da una pivot.
    questa è la pivot:
    Tecnico - Team regione valore
    a1 a h56 1
    a2 b h56 5
    a3 a h45 6
    a4 b h56 4
    a5 a r45 3
    a6 b d12 8
    a7 a a12 2

    i team sono solo due (a b) mentre i tecnici sono diversi.
    Vorrei potermi costruire una classifica così da arrivare a

    Team a
    posizione tecnico regione valore
    1 a3 h45 6
    2 a5 r45 3
    3 a7 a12 2
    4 a1 h56 1
    e lo stesso per il tema b.
    La formula ovviamente è sul tecnico perchè regione e valore li prenderei con un cerca.vert.
    Qualche consiglio.
    ciao
    ale

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    vi allego un file...vedo le tabulazioni saltate...
    scusate.
    ciao
    ale

  3. #3
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    niente...la fame ha preso il sopravvento...
    vado a mangiare..
    a dopo.
    ciao
    ale

  4. #4
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ecco il file
    https://www.dropbox.com/s/b0nfrhxd8h...tel2.xlsx?dl=0
    in pratica la formula è solo per quelle etichette a b c d...per gli altri valori con un cerca.vert risolvo.
    cmq faccio altre prove.
    ciao
    ale

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    in assenza di parimeriti, come sembra, in E19:
    =GRANDE(INDICE(($C$4:$C$10="RR")*$D$4:$D$10;);RIF.RIGA(A1))
    gli altri valori li puoi estrarre con INDICE(....;CONFRONTA(....))

    si deve completare con la gestione dell'errore e/o zeri

    facendola completa:

    E19:
    =SE(RIGHE($E$19:E19)<=CONTA.SE($C$4:$C$10;"RR");GRANDE(INDICE(($C$4:$C$10="RR")*$D$4:$D$10;);RIF.RIGA(A1));"")
    B19:
    =SE.ERRORE(INDICE(A$4:A$10;CONFRONTA($E19;$D$4:$D$10;0));"")
    copia incolla in C19 e D19
    e poi trascini tutto in basso

    ovviamente, la "RR" va adattata oppure parametrata in qualche cella

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Giusto per mettere un'alternativa:

    =SE(C4="RR";GRANDE($D$4:$D$10;RIF.RIGA(A1));"")

    il resto come dice ninni da ricavare con INDICE e CONFRONTA

  7. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    =SE(C4="RR";GRANDE($D$4:$D$10;RIF.RIGA(A1));"")
    ??????

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ??????
    In C4:C10 non ci sono i riferimenti???
    Non avrò capito la richiesta???
    Allego file
    https://www.dropbox.com/s/9ug3xmsm4nvyx5p/C4.xlsx?dl=0

  9. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Ges
    io ho capito che voleva una classifica decrescente dei soli valori di RR (o di PP).
    la tua formula prevede il GRANDE() ennesimo, di tutti i valori. (infatti il terzo valore è errato)

  10. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Si ninai,
    hai ragione, rileggendo la domanda la mia formula non è corretta.

  11. #11
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao ragazzi...scusate il ritardo.
    stavo risolvendo la presenza dei parimeriti.
    sono ottime le formule
    e in B19 inserirei:
    =INDICE($A$1:$A$10;PICCOLO(SE($D$1:$D$10=E19;RIF.RIGA($D$1:$D$10));CONTA.SE(E$19:E19;E19)))
    matriciale
    ciao
    ale
    ps
    la formula di ges francamente l'ho vista solo ora...mi ero fermato a quella di ninai...ma grazie cmq a tutti e due.

  12. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    =INDICE($A$1:$A$10;PICCOLO(SE($D$1:$D$10=E19;RIF.RIGA($D$1:$D$10));CONTA.SE(E$19:E19;E19)))

    Alessandro
    anche la tua formula mi lascia perplesso,

    la mia che problemi ti dava???

    a questo punto falla completa:
    =SE(RIGHE($E$19:$E19)<=CONTA.SE($C$4:$C$10;"RR");INDICE(A$1:A$10;PICCOLO(SE($D$1:$D$10=$E19;RIF.RIGA($D$1:$D$10));CONTA.SE($E$19:$E19;$E19)));"")

    da mettere in B19 e trascinare sia in basso che a destra fino ad D.
    Ultima modifica fatta da:ninai; 23/10/15 alle 19:38

  13. #13
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61
    ciao ninai,
    la tua in E19 era ottima...
    ma la tua in B19
    =SE.ERRORE(INDICE(A$4:A$10;CONFRONTA($E19;$D$4:$D$10;0));"")
    nel caso ci siano due persone con lo stesso valore a parimerito mi da sempre la stessa referenza, mentre l'altra
    =INDICE($A$1:$A$10;PICCOLO(SE($D$1:$D$10=E19;RIF.RIGA($D$1:$D$10));CONTA.SE(E$19:E19;E19)))
    anche con 2/3 o n parimerito...
    non ho fatto tante prove ma mi sembra sia così.
    ciao
    ale

  14. #14
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ok Alessandro
    adesso ho capito, non pensavo che tu avessi dei parimeriti ed avevo inteso che la tua formula sostituisse la mia in E. ora ho capito e la tua mi sembra ok!!

Discussioni Simili

  1. Salvare in csv solo alcune colonne
    Di kantois nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 26/01/17, 17:31
  2. [Risolto] come Nascondere, alcune righe, e creare un pdf
    Di CEPE77 nel forum Domande su Excel VBA e MACRO
    Risposte: 51
    Ultimo Messaggio: 20/12/16, 16:11
  3. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  4. Ho un problema con lo spazio in alcune celle
    Di c.Fabrizio nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 13/05/16, 19:27
  5. Bloccare alcune colonne con password
    Di Lety88 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 29/04/16, 09:48

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •