Risultati da 1 a 18 di 18

Discussione: codici unici



  1. #1
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    codici unici

    salve, ho un problema con una formula, vorrei calcolare il numero di codici unici della colonna A secondo i vari mesi, nelle celle gialle ho provato qualche formula ma non ne vengo fuori, un grazie anticipato
    Ultima modifica fatta da:Canapone; 14/07/17 alle 10:03
    Invia MPPM 

  2. #2
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4937
    Versione Office
    2013
    Likes ricevuti
    1122
    Likes dati
    1131
    Ciao Stefano, ma che buon vento che tira oggi:188:
    Innanzi tutto grazie per la tua generosa donazione che hai fatto per sostenere i costi di questo forum
    grazie grazie grazie

    Per quanto riguarda la tua richiesta prova questa formula in K3 e copia in basso
    Attenzione questa Ŕ una formula matrice e devi attivarla facendo CTRL+Shift+Enter

    =SOMMA(SE(FREQUENZA(SE(TESTO($D$2:$D$200;"mmmm")=J3;CONFRONTA($A$2:$A$200;$A$2:$A$200;0));RIF.RIGA($A$2:$A$200)-RIF.RIGA($A$2)+1);1))

    Ciao Stefano
    e grazie Ancora

    PS sono sicuro che ci sono altre formule a me Ŕ venuta cosi

    ciao a tutti
    Invia MPPM 

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    Ciao Gerardo, sei sempre il numero uno, funziona che Ŕ una meraviglia, questo forum Ŕ utilissimo e se posso aiutarti nel mio piccolo lo faccio volentieri
    Invia MPPM 

  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1692
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    giusto un'alternativa:
    =SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA($A$2:$A$200)-1;SE(MESE($D$2:$D$200)=MESE(1&J3);CONFRONTA($A$2:$A$200;$A$2:$A$200;0);"");0)))
    Invia MPPM 

  6. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  7. #5
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4937
    Versione Office
    2013
    Likes ricevuti
    1122
    Likes dati
    1131
    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    Ciao Gerardo, sei sempre il numero uno, funziona che Ŕ una meraviglia, questo forum Ŕ utilissimo e se posso aiutarti nel mio piccolo lo faccio volentieri
    Ciao Stefano Grazie per il tuo riscontro positivo, comunque di numeri uno ce ne sono tanti prima di me, vedasi la formula di ninai.
    Stefano se la tua domanda Ŕ stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”
    Invia MPPM 

  8. I seguenti utenti hanno dato un "Like"


  9. #6
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    se volessi filtrare anche per anno e COD_CAT?
    Invia MPPM 

  10. #7
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4937
    Versione Office
    2013
    Likes ricevuti
    1122
    Likes dati
    1131
    Ciao Stefano
    Attenzione che per anno in questo caso hai solo il 2012 non so se vale la pena farlo?
    Ciao
    Invia MPPM 

  11. #8
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    si ma nel file originale ho anni diversi
    Invia MPPM 

  12. #9
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    Grazie Ninai, secondo voi qual'e' la formula meno pesante visto che il file Ŕ giÓ bello carico di formule
    Invia MPPM 

  13. #10
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1692
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    basta aggiungere criteri nel primo argomento del SE(). Se in H1 metti l'anno ed in H2 la categoria che vuoi filtrere, la formula diventa:
    =SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA($A$2:$A$200)-1;SE((MESE($D$2:$D$200)=MESE(1&J3)*(ANNO($D$2:$D$200)=$H$1)*($C$2:$C$200=$H$2));CONFRONTA($A$2:$A$200;$A$2:$A$200;0);"");0)))

    Analogo ragionamento si pu˛ adottare per la formula di Gerardo
    Invia MPPM 

  14. #11
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    grazie ancora, quindi con un asterisco, io cercavo con la formula E invece di SE
    Invia MPPM 

  15. #12
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4937
    Versione Office
    2013
    Likes ricevuti
    1122
    Likes dati
    1131
    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    grazie ancora, quindi con un asterisco, io cercavo con la formula E invece di SE
    eccoci qui

    Un approccio di formula leggermente diverso da quella di ninai ma criteri e condizioni uguali
    la mia formula modificata con altri nuovi criteri AND, da attivare con CTRL+SHIFT+ENTER
    =SOMMA(SE(FREQUENZA(SE(TESTO($D$2:$D$200;"mmmm")=J3;SE(ANNO($D$2:$D$200)=$H$3;SE($C$2:$C$200=$I$3;CONFRONTA($C$2:$C$200;$C$2:$C$200;0))));RIF.RIGA($A$2:$A$200)-RIF.RIGA($A$2)+1);1))
    ovviamente i risultati sono bassi perche essendoci tanti criteri di tipo E (AND) per somme uniche


    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    1
    COD_FORN COD_ART COD_CAT DATA_CONS
    2
    RAD0007
    252583
    A
    03/01/2012
    anno cat mese codici unici
    3
    RAD0007
    252584
    A
    03/01/2012
    2012
    a gennaio
    1
    4
    VAR0010
    252585
    A
    03/01/2012
    febbraio
    0
    5
    VAR0010
    252586
    A
    03/01/2012
    marzo
    1
    6
    VAR0010
    252587
    O
    03/01/2012
    aprile
    1
    7
    VAR0010
    252588
    O
    03/01/2012
    maggio
    1
    8
    VAR0010
    252589
    O
    03/01/2012
    giugno
    1
    9
    VAR0010
    252590
    O
    03/01/2012
    luglio
    1
    10
    VAR0010
    252591
    O
    03/01/2012
    11
    VAR0010
    252592
    O
    03/01/2012
    12
    IAC0001
    252593
    L
    03/01/2012
    13
    IAC0001
    252594
    L
    03/01/2012
    14
    IAC0001
    252595
    L
    03/02/2012
    15
    IAC0001
    252596
    O
    03/02/2012
    16
    IAC0001
    252597
    O
    03/02/2012
    17
    IAC0001
    252598
    O
    03/02/2012
    Invia MPPM 

  16. #13
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1692
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    le due procedure credo si equivalgano, solo che il CONFRONTA() dovrebbe riguardare la colonna A:

    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    .. il numero di codici unici della colonna A ..............
    =SOMMA(SE(FREQUENZA(SE(TESTO($D$2:$D$200;"mmmm")=J3;SE(ANNO($D$2:$D$200)=$H$3;SE($C$2:$C$200=$I$3;CONFRONTA($A$2:$A$200;$A$2:$A$200;0))));RIF.RIGA($A$2:$A$200)-RIF.RIGA($A$2)+1);1))


    sulla velocitÓ di esecuzione non so dirti, credo sia simile. Se le righe sono molte migliaia te ne accorgerai man mano che ti allunga la barba aspettando
    :296::296:
    Invia MPPM 

  17. I seguenti utenti hanno dato un "Like"


  18. #14
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    ho provato con il file originale ma non funziona, al momento sono circa 154.000 righe, ho usato i nomi, per˛ non mi da errore ma 0 ho tolto la categoria e messo solo anno e mese
    =SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA(COD_FORN)-1;SE((MESE(DATA_CONS)=MESE(1&P2)*(ANNO(DATA_CONS)=$Q$1));CONFRONTA(COD_FORN;COD_FORN;0);"");0)))
    Invia MPPM 

  19. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1692
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    a parte la sistemazione di qualche parentesi spostata, altro non posso verificare, prova:

    =SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA(COD_FORN)-1;SE((MESE(DATA_CONS)=MESE(1&P2))*(ANNO(DATA_CONS)=$Q$1);CONFRONTA(COD_FORN;COD_FORN;0));0)))

    ricordati di confermarla correttamente CTRL+MAIUSCOLO+INVIO
    Invia MPPM 

  20. #16
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    niente da fare,cosý per˛ funziona
    =SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA(A2:A200)-1;SE((MESE(D2:D200)=MESE(1&P19))*(ANNO(D2:D200)=$Q$1);CONFRONTA(A2:A200;A2:A200;0));0)))
    Invia MPPM 

  21. #17
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    ninai, la formula funziona credo per˛ che il limite siano le 155.000 righe infatti dopo 13 minuti di attesa ho rinunciato. forse con un codice VBA?, al momento ho usato una pivot molto piu' veloce ma se ci fosse una formula sarebbe meglio, grazie
    Invia MPPM 

  22. #18
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1692
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    con 155.000 record le matriciali appesantiscono molto, credo che devi optare per il VBA o pivot
    Invia MPPM 

  23. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. Presentazione e lista unici e univoci
    Di Stefano58 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 11/03/17, 19:32
  2. [Risolto] Contare gli unici valori contrassegnati
    Di Francesca77 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 11/02/17, 23:07
  3. Conta Valori unici
    Di Gerardo ZuccalÓ nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 26/08/16, 13:12
  4. Conteggio valori unici
    Di delusan nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 04/03/16, 11:31
  5. Conteggio valori unici
    Di delusan nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/11/15, 13:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •