Risultati da 1 a 13 di 13

Discussione: lista di valori con criterio



  1. #1
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    lista di valori con criterio

    Salve, ho una tabella con una colonna data consegna un'altra con il codice cliente, vorrei creare una tabella con in una colonna una lista univoca di clienti e nell'altra colonna l'anno della prima consegna, grazie

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    in G2 da copiare in basso per la lista univoca

    =SE.ERRORE(INDICE($A$2:$A$216;AGGREGA(15;6;(RIF.RIGA($A$2:$A$216)-1)/(FREQUENZA(CONFRONTA($A$2:$A$216;$A$2:$A$216;0);CONFRONTA($A$2:$A$216;$A$2:$A$216;0))>0);RIF.RIGA(A1)));"")

    In H2 sfrutto il fatto che le date sono in ordine crescente

    =SE(G2<>"";ANNO(CERCA.VERT(G2;$A$2:$B$216;2;0));"")

    Se le date non avessero un ordine preciso, puoi scomodare AGGREGA in H2 e copi sotto:

    =SE.ERRORE(ANNO(AGGREGA(15;6;$B$2:$B$216/($A$2:$A$216=G2);1));"")

    Saluti

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao di nuovo

    lascio anche un esempio di pivot.

    Mettendo le date fra i campi valore, selezioni MIN al momento dell'impostazione ed esi il formato personalizzato "AAAA".

    Saluti

  4. #4
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    grazie, sei veramente un "guru"

  5. #5
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    scusa, e una formula che mi conti gli univoci per anno?

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Stefano
    in E2 ho messo la condizione cioè gli anni 2008/2009/ ecc. ecc
    in F2 fai questa formula e trascinala in basso:

    =SOMMA(SE(FREQUENZA(SE(ANNO($B$2:$B$216)=E2;CONFRONTA($A$2:$A$216;$A$2:$A$216;0));RIF.RIGA($A$2:$A$216)-RIF.RIGA($A$2)+1)>0;1))

    Attenzione da attivare con la combinazione CTRL+SHIFT+ENTER

    Vedi screen-shot

    A
    B
    C
    D
    E
    F
    1
    COD_FORN DATA_CONS Anno Cod_Unici
    2
    LEP0001
    19/01/2008
    LEP0001
    2008
    7
    3
    LEP0002
    14/02/2008
    LEP0002
    2009
    6
    4
    LEP0003
    24/02/2008
    LEP0003
    2010
    6
    5
    LEP0001
    13/03/2008
    LEP0001
    2011
    7
    6
    LEP0001
    08/04/2008
    LEP0001
    2012
    12
    7
    LEP0001
    25/04/2008
    LEP0001
    8
    LEP0001
    30/04/2008
    LEP0001
    9
    LEP0001
    14/05/2008
    LEP0001
    10
    LEP0001
    30/05/2008
    LEP0001
    11
    LEP0001
    14/06/2008
    LEP0001
    12
    LEP0001
    14/06/2008
    LEP0001
    13
    LEP0002
    28/06/2008
    LEP0002
    14
    LEP0003
    10/07/2008
    LEP0003
    15
    LEP0004
    08/08/2008
    LEP0004
    16
    LEP0005
    10/08/2008
    LEP0005
    17
    LEP0006
    12/08/2008
    LEP0006
    18
    LEP0001
    16/08/2008
    LEP0001

    PS visto che hai Excel 2013 prova a convertirla con l'AGGREGA, cosi ti eserciti un pochettino

  7. #7
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    grazie

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Stefano e Grazie per il tuo riscontro positivo
    ciao:43:

  9. #9
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    scusate ancora, ho sostituito nella formula la parte con un nome però non mi funziona cosa potrebbe essere?

    =SE.ERRORE(INDICE(COD_FORN;AGGREGA(15;6;(RIF.RIGA(COD_FORN)-1)/(FREQUENZA(CONFRONTA(COD_FORN;COD_FORN;0);CONFRONTA(COD_FORN;COD_FORN;0))>0);RIF.RIGA(dati!A1)));"")

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Stefano
    manca la condizione dell'anno
    cioè questo Pezzettino

    ANNO($B$2:$B$216)=E2

  11. #11
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    scusa Gerardo mi riferivo a questa formula

    =SE.ERRORE(INDICE($A$2:$A$216;AGGREGA(15;6;(RIF.RIGA($A$2:$A$216)-1)/(FREQUENZA(CONFRONTA($A$2:$A$216;$A$2:$A$216;0);CONFRONTA($A$2:$A$216;$A$2:$A$216;0))>0);RIF.RIGA(A1)));"")

  12. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Opps! scusa pensavo stavi convertendo la mia formula con l'AGGREGA e i nomi definiti, sono stato un pò troppo precipitoso
    Allora la parola a canapone che l' ha creata lui quella formula

    Ps. Stefano un piccolo grande consiglio, quando hai due Topic diversi ti conviene iniziare due discussioni diverse cosi non si incappa in fraintendimenti.
    Ciao
    Ultima modifica fatta da:Gerardo Zuccalà; 04/11/15 alle 01:19

  13. I seguenti utenti hanno dato un "Like"


  14. #13
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    ok, credo di aver capito, il problema è la quantità dei dati, con meno di funziona

Discussioni Simili

  1. Macro copia/incolla valori di una lista
    Di Lebron5 nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 18/01/17, 00:39
  2. [Risolto] Generare Colonna con valori univoci da una lista
    Di Domynix nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/01/17, 15:01
  3. Formula evidenziare valori in una lista
    Di lordfly78 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 04/09/16, 11:55
  4. Sommare con un criterio su una lista Filtrata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 30/08/16, 10:24
  5. Database e lista valori con etichetta.
    Di Reziell nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 09/06/16, 14:42

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •