Risultati da 1 a 6 di 6

Discussione: Formula confronto link



  1. #1
    L'avatar di maximo890
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Venezia
    Età
    28
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Formula confronto link

    Ciao ragazzi

    avrei un problema da sottoporvi: mi servirebbe una formula che confronterebbe dei link con quelli presenti nel robots.txt e mi direbbe se sono bloccati o no da questo documento.

    Ho provato ad utilizzare cerca.vert, ma il problema che all'interno del robots.txt ci sono solo frazioni di URL.

    Per caso avete qualche consiglio? Grazie in anticipo

    Vi allego un esempio su excel per capire.

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298
    Ciao maximo,
    per il tuo quesito userei questa formula in B2 da copiare in basso

    =SE(E(VAL.ERRORE(TROVA(robots.txt!$A$3;A2));VAL.ERRORE(TROVA(robots.txt!$A$4;A2));VAL.ERRORE(TROVA(robots.txt!$A$5;A2)));"NO";"SI")

  3. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    Non capisco il criterio di assegnazione dei " Si" e "No"


    nel file inviato risultano 3 link uguali con la seguente assegnazione " SI","NO","SI" ?

    Quindi ti chiedo il critierio di assegnazione per i SI e No.

    Saluti
    Window 8.1 Excel 2013/2016

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298
    Ciao Pitagora,
    io l'ho interpretato che se nei link della colonna A del primo foglio c'è una delle parole indicate nelle celle A3,A4 e A5 del foglio robot.txt deve comparire il "SI" nella colonna B.
    Ho visto che per i link uguali c'è " SI","NO","SI", ma ho pensato ad un errore di scrittura.
    Sentiamo però cosa ci dice maximo.

  5. #5
    L'avatar di maximo890
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Venezia
    Età
    28
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    I si saranno assegnati alle URL che contengono indirizzi bloccati dal robots.txt

    Per esempio: Risorsa bloccata all'interno robots = /*.css

    url: www.prova.ti/blocco/ciao.css = SI

    Spero di essere stato chiaro.

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1657
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184
    Ciao a tutti

    ho dato la stessa interpretazione di ges, con una versione Matriciale, qualora i termini di ricerca fossero numerosi:
    =SE(CONTA.NUMERI(TROVA(robots.txt!$A$3:$A$5;A2));"Sì";"No")

Discussioni Simili

  1. [Risolto] Modificare link
    Di Mirco nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 23/12/16, 00:48
  2. prova link
    Di dracoscrigno nel forum Test dei vostri post
    Risposte: 1
    Ultimo Messaggio: 08/12/16, 03:07
  3. [Risolto] cerco formula per confronto tra 2 file
    Di stardust978 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/11/16, 17:32
  4. Test di Link
    Di Irclen nel forum Test dei vostri post
    Risposte: 2
    Ultimo Messaggio: 08/08/16, 10:56
  5. Confronto tra una formula e un test
    Di claudiorossini nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 30/04/16, 23:25

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •