Risultati da 1 a 13 di 13

Discussione: Inserire Guida Function personalizzate



  1. #1
    L'avatar di zio_tom
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Veneto
    Messaggi
    525
    Versione Office
    2010 - Win10
    Likes ricevuti
    63
    Likes dati
    17

    Question Inserire Guida Function personalizzate

    Se si crea un Function personalizzata e si esegue , ad esempio:
    Codice: 
    Sub Guida_Function()
       Dim FuncName As String
       Dim FuncDesc As String
       Dim Category As String
       Dim ArgDesc(1 To 6) As String
    
    '----- gestione della parte decimale con zeri in coda e del segno
    '1 Numero = cella numero input
    '2 sep = carattere separatore decimali            "."  default
    '3 nDec = numero di decimali da visualizzare        2  default
    '4 zeriCoda = se zeri in coda                   False  default
    '5 decCifre = se decimale in cifre o lettere    True   default
    '6 Tipo = True   Fino_miliardi                         default
    '       False  Direttiva_CEE
    
    '=Num2Lett_dec(C5;"/";2;VERO;VERO;FALSO)
    
       FuncName = "Num2Lett_dec"
       FuncDesc = "Trasforma un numero in cifre in numero in lettere, con parte decimale"
       Category = "mie Personalizzate" 'o 14 (Definita dall'utente)
       ArgDesc(1) = "Cella origine numero"
       ArgDesc(2) = "Carattere Separatore"
       ArgDesc(3) = "Numero di decimali"
       ArgDesc(4) = "Zeri in coda"
       ArgDesc(5) = "Decimali in Cifre"
       ArgDesc(6) = "Tipo rappresentazione in lettere "
    
       Application.MacroOptions _
          Macro:=FuncName, _
          Description:=FuncDesc, _
          Category:=Category, _
          ArgumentDescriptions:=ArgDesc
    End Sub
    usando il comando 'Inserisci Formula" e vado a selezionare in "mie Personalizzate"
    la funzione 'Num2Lett_dec' mi compare lasolita maschera da compilare
    e fin qua tutto bene....

    Se uso le funzioni native di Excel e scrivo, as esempio '=SOMM
    mi compare la tendine con tutte le Funzioni che cominciano per SOMM
    appena scrivo '=SOMMA(' mi compare sotto la funzione con le variabili richieste
    =SOMMA(num1;[num2];...)

    qualcuno sa se è possibile ottenere ciò con le Funzioni Personalizzate???

    Se scrivo: '=Num2Lett_dec'
    sotto mi compare il nome con simbolo di funzione
    appena aggiungo la parentesi: '=Num2Lett_dec('
    mi scompare tutto (cioè NON mi presenta le variabili)

  2. #2
    L'avatar di zio_tom
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Veneto
    Messaggi
    525
    Versione Office
    2010 - Win10
    Likes ricevuti
    63
    Likes dati
    17
    aggiungo un quesito su Application.MacroOptions
    si potrebbe aggiungere un vero e proprio file di Help con le seguenti istruzioni
    HelpFile:=ThisWorkbook.Path & "mieFunzioni.chm", HelpContextID:=2000
    ma come si crea il file .chm e che significato ha ID??
    esistono dei software per creare tali file... ma a pagamento
    esiste qualcosa di Public Domain???..... gratis

  3. #3

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    Citazione Originariamente Scritto da zio_tom Visualizza Messaggio
    aggiungo un quesito su Application.MacroOptions
    si potrebbe aggiungere un vero e proprio file di Help con le seguenti istruzioni
    HelpFile:=ThisWorkbook.Path & "mieFunzioni.chm", HelpContextID:=2000
    ma come si crea il file .chm e che significato ha ID??
    esistono dei software per creare tali file... ma a pagamento
    esiste qualcosa di Public Domain???..... gratis
    vedi qui se può servirti:
    http://www.helpandmanual.com/downloads_mscomp.html
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  4. #4
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6
    Originariamente Scritto da zio_tom
    Se uso le funzioni native di Excel e scrivo, as esempio '=SOMM
    mi compare la tendine con tutte le Funzioni che cominciano per SOMM
    appena scrivo '=SOMMA(' mi compare sotto la funzione con le variabili richieste
    =SOMMA(num1;[num2];...)

    qualcuno sa se è possibile ottenere ciò con le Funzioni Personalizzate???
    Con la versioni di excel 2010 è possibile aggiungere le descrizioni della Funzione nel foglio.

    http://www.ozgrid.com/VBA/DesciptionToUDF.htm
    Segue un esempio
    http://spreadsheetpage.com/index.php/tip/C32/

  5. #5
    L'avatar di zio_tom
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Veneto
    Messaggi
    525
    Versione Office
    2010 - Win10
    Likes ricevuti
    63
    Likes dati
    17
    Citazione Originariamente Scritto da Bruno Visualizza Messaggio
    Con la versioni di excel 2010 è possibile aggiungere le descrizioni della Funzione nel foglio.

    http://www.ozgrid.com/VBA/DesciptionToUDF.htm
    Segue un esempio
    http://spreadsheetpage.com/index.php/tip/C32/
    Questo è già quello che ho descritto nel primo post!!!!
    con il relativo codice per ottnere appunto la maschera
    i link postati gli ho già letti ed applicati!!!
    La maschera quindi mi appare facendo inserisci Function
    rileggi quanto ho scritto
    Voglio la riga di aiuto che compare quando ad una funzione nativa si aggiunge la parentesi '('
    e compare appunto una sola riga con la funzione con le variabili previste
    e man mano che si inseriscono le variabili quella da inserire si presenta in grassetto
    =miaFunzione(var1;[var2];[var3];...)
    prova!!!


    PS: grazie a SCOSSA, ma l'editor di Microsoft è piuttosto astruso da usare, ho trovato diversi video che tentano di spiegarlo
    nelle sole funzioni elementari
    bisogna usare la sua sintassi, che non ho trovato, riesco ad accodare alcuni file
    ed inserire un testo con <p> ...... </p>
    ma non trovo le istruzioni per la struttura ad albero
    e nemmeno come usare ID, che permete alla Function di puntare nel file .chm
    che dovrebbe avere l'Help di più funzioni e con l'ID si punta alla specifica
    gli editor più 'easy' costano dai 100€ in su, quelli, diciamo più immediati, arrivano ai 500€
    ed il gioco non vale la candela

  6. #6
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6
    Ciao

    Originariamente Scritto da zio_tom
    Voglio la riga di aiuto che compare quando ad una funzione nativa si aggiunge la parentesi '('
    Ho letto che utilizzi Excel 2010, prova ad inserire la formula e quando compare "(" premi:
    Ctrl + Maiusc + A

    Otterrai l'elenco nella barra della formula
    :32:

  7. #7
    L'avatar di zio_tom
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Veneto
    Messaggi
    525
    Versione Office
    2010 - Win10
    Likes ricevuti
    63
    Likes dati
    17
    Citazione Originariamente Scritto da Bruno Visualizza Messaggio
    Ciao
    Ho letto che utilizzi Excel 2010, prova ad inserire la formula e quando compare "(" premi:
    Ctrl + Maiusc + A
    Otterrai l'elenco nella barra della formula :32:
    Ma caro Bruno mi sembra di parlare con un sordo (scusa il paragone)
    ma io NON voglio ottenere la mascherina.... che conosco abbondantemente in tutti i suoi risvolti
    Voglio la riga di aiuto, di una sola riga,.... come ho più volte detto e riportato nei post sopra

  8. #8
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6
    Ciao
    Originariamente Scritto da zio_tom
    Voglio la riga di aiuto, di una sola riga,....
    Allego il file d'esempio
    File Allegati File Allegati

  9. #9
    L'avatar di zio_tom
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Veneto
    Messaggi
    525
    Versione Office
    2010 - Win10
    Likes ricevuti
    63
    Likes dati
    17
    Con il mio 2010 NON funziona come dici
    se premo CTRL+TAB+A mi compare la finestra di aiuto all'input
    se premo CTRL+Shift+A mi aggiunge il testo: 'Foglio1!N'
    cioè: =EXTRACTELEMENT(Foglio1!N22
    ma vedo che le immagini sono del 2013

    con le funzioni standard di excel, appena inserisco la parentesi mi compare come da allegato
    File Allegati File Allegati

  10. #10
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6
    Ciao

    Dispiace che non compaiono le descrizioni...
    Ho utilizzato solo Excel 2003 per poi aggiornarmi al Excel 2013.
    Non ho avuto modi di utilizzare le precedenti versioni

    Allego immagine della Function = somma( solo per confronto


  11. I seguenti utenti hanno dato un "Like"


  12. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Bruno
    Per inserire una immagine statica ti consiglio di vedere questo video tutorial, niente di particolarmente difficile ma se non sai è meglio che ti vedi questo video
    Ciao e buon anno!

  13. #12

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6747
    Versione Office
    2013
    Likes ricevuti
    711
    Likes dati
    162
    Ciao a tutti e scusate l'intrusione.

    Se interpreto bene la richiesta di zio_tom credo che la cosa non si possa fare.

    Guardate questo link http://www.ozgrid.com/forum/showthread.php?t=78123

    oppure fate una ricerca con Google inserendo "Excel vba udf tooltip"; verranno fuori molti link ma nessuno con una risposta risolutiva.

    In passato mi ero imbattuto in questo tipo di problema ed avevo già un po' approfondito l'argomento non trovando però soluzione

    Alfredo

  14. #13
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215
    Pare che non sia possibile risolvere la prima domanda di zio_tom con le vecchie versioni di excel, mentre con le versioni più recenti sembra si possa fare qualcosa che non ho testato...
    Vi allego i link di una mia ricerca.
    http://stackoverflow.com/questions/1...nction-tooltip

    per le versioni precedenti, in fondo a questo link l'MVP che sostiene non sia possibile
    http://answers.microsoft.com/en-us/o...es&auth=1#tabs

    è interessante anche questo link che riguarda l'argomento anche se non risponde alla domanda.
    http://dailydoseofexcel.com/archives...-intellisense/
    http://www.bettersolutions.com/excel...N723710331.htm

Discussioni Simili

  1. Problema ricalcolo automatico function vba
    Di sarena76 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 07/09/16, 19:26
  2. Dim di tutte variabli in function a Double
    Di zio_tom nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 12/07/16, 23:11
  3. Macro personalizzate nella Barra Multifunzione di Excel
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 18/05/16, 14:04
  4. Acquista passaporti , patenti di guida , carte d'identità
    Di manuxavi7 nel forum Pausa caffè (Off-Topic)
    Risposte: 3
    Ultimo Messaggio: 15/03/16, 13:42
  5. Una semplicissima guida VBA by Alessandro Lubisco
    Di Gerardo Zuccalà nel forum Link Utili
    Risposte: 0
    Ultimo Messaggio: 02/11/15, 09:32

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •