Risultati da 1 a 6 di 6

Discussione: Inserire Formula con Se Nidificati in VBA



  1. #1
    L'avatar di Aldo1070
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Firenze
    Età
    28
    Messaggi
    1
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0

    Inserire Formula con Se Nidificati in VBA

    Buongiorno,


    Vi scrivo in quanto necessito di inserire questa formula in VBA:


    "=+SE(A2="lm";SE(J2="Merce";SE(SINISTRA(H2;2)="47";SE(F2<DATA.VALORE("09/6/2010");"PreAp Perugia";SE(F2<DATA.VALORE("09/12/2010");"PostAp Perugia"));SE(SINISTRA(H2;2)="48";SE(F2<DATA.VALORE("15/07/2010");"PreAp Busnago";SE(F2<DATA.VALORE("15/01/2011");"PostAp Busnago"));SE(SINISTRA(H2;2)="49";SE(F2<DATA.VALORE("09/06/2011");"PreAp PalMondello";SE(F2<DATA.VALORE("09/12/2011");"PostAp PalMondello"));SE(SINISTRA(H2;2)="50";SE(F2<DATA.VALORE("14/09/2011");"PreAp PalForum";SE(F2<DATA.VALORE("14/03/2012");"PostAp PalForum"));SE(SINISTRA(H2;2)="51";SE(F2<DATA.VALORE("22/11/2011");"PreAp Vicenza";SE(F2<DATA.VALORE("22/05/2012");"PostAp Vicenza"));SE(SINISTRA(H2;2)="52";SE(F2<DATA.VALORE("30/06/2012");"PreAp Udine";SE(F2<DATA.VALORE("30/12/2012");"PostAp Udine"));SE(SINISTRA(H2;2)="53";SE(F2<DATA.VALORE("13/10/2012");"PreAp PteNapoli";SE(F2<DATA.VALORE("13/04/2013");"PostAp PteNapoli"));SE(SINISTRA(H2;2)="22";SE(F2<DATA.VALORE("01/04/2009");"PreAp Assago";SE(F2<DATA.VALORE("01/10/2009");"PostAp Assago"))))))))))))"


    Anche registrando una macro in cui la prendo copio e incollo quella che mi restituisce in VBA non funziona.


    Non capisco se sia un problema di lunghezza o di non so cosa.


    Sapreste come aiutarmi cortesemente?
    Invia MPPM 

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Inserire Formula con Se Nidificati in VBA

    Ciao,
    sono al cellulare e non posso provare nulla, ma direi che l'errore dipende dai doppi apici all'interno della formula.
    Dovresti sostituirli con un altro simbolo (es. cancelletto) e poi rimetterli prima della sua esecuzione.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

  3. #3

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Inserire Formula con Se Nidificati in VBA

    Fai una prova:
    Scrivi la funzione in una cella;
    Avvia il registratore di macro;
    Posizionati sulla cella con la formula e premi F2 Enter;
    Stop al registratore;
    Usa la macro dall'editor VBA (cambiando i riferimenti naturalmente)

    Inviato dal mio GT-I9301I utilizzando Tapatalk
    Invia MPPM 

  4. #4
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Inserire Formula con Se Nidificati in VBA

    Secondo me la formula non funziona.

    Faccio solo un' esempio perchè tutta la formula non la capisco.
    Primo pezzo =SE(A2="lm";SE(J2="Merce";SE(SINISTRA(H2;2)="47";SE(F2<DATA.VALORE("09/6/2010");"PreAp Perugia";"SBAGLIATO")))) la formula funziona

    Se scrivi in una cella =SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="47";F2<DATA.VALORE("09/6/2010"));"PreAp Perugia";"SBAGLIATO")
    Ora se noti senza "quei SE" la formula funziona lo stesso.

    OK, primo pezzo è a posto. Passiamo al secondo...in teoria
    =SE(F2<DATA.VALORE("09/12/2010");"PostAp Perugia";"SBAGLIATO") la formula funziona

    Però che significa? che deve tralasciare tutte le altre info precedenti, oppure intendi dire =SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="47";F2<DATA.VALORE("09/12/2010"));"PostAp Perugia";"SBAGLIATO")

    In teoria se metti a posto tutti i vari "Pezzi" (alla fine li riunisci) in modo che funzioni, vedrai che iserendola in VBA sarà OK
    Codice: 
    1)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="47";F2<DATA.VALORE("09/6/2010"));"PreAp Perugia";"SBAGLIATO")
    2)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="47";F2<DATA.VALORE("09/12/2010"));"PostAp Perugia";"SBAGLIATO")
    3)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="48";F2<DATA.VALORE("15/07/2010"));"PreAp Busnago";"SBAGLIATO")
    4)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="48";F2<DATA.VALORE("15/01/2011"));"PostAp Busnago";"SBAGLIATO")
    5)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="49";F2<DATA.VALORE("09/06/2011"));"PreAp PalMondello";"SBAGLIATO")
    6)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="49";F2<DATA.VALORE("09/12/2011"));"PostAp PalMondello";"SBAGLIATO")
    7)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="50";F2<DATA.VALORE("14/09/2011"));"PreAp PalForum";"SBAGLIATO")
    8)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="50";F2<DATA.VALORE("14/03/2012"));"PostAp PalForum";"SBAGLIATO")
    9)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="51";F2<DATA.VALORE("22/11/2012"));"PreAp Vicenza";"SBAGLIATO")
    10)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="51";F2<DATA.VALORE("22/05/2012"));"PostAp Vicenza";"SBAGLIATO")
    11)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="52";F2<DATA.VALORE("30/06/2012"));"PreAp Udine";"SBAGLIATO")
    12)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="52";F2<DATA.VALORE("30/12/2012"));"PostAp Udine";"SBAGLIATO")
    13)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="53";F2<DATA.VALORE("13/10/2012"));"PreAp PteNapoli";"SBAGLIATO")
    14)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="53";F2<DATA.VALORE("13/04/2013"));"PostAp PteNapoli";"SBAGLIATO")
    15)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="22";F2<DATA.VALORE("01/04/2009"));"PreAp Assago";"SBAGLIATO")
    16)=SE(E(A2="lm";J2="Merce";SINISTRA(H2;2)="22";F2<DATA.VALORE("01/10/2009"));"PostAp Assago";"SBAGLIATO")
    Ps. Per me i "pezzi" sono questi, lascio a Te il compito di riunirli in un'unica formula.
    Pps. Secondo me la 9 va messa dopo la 10
    Invia MPPM 

  5. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Inserire Formula con Se Nidificati in VBA

    Ciao a tutti,
    come detto al post #2, sono ancora convinto che il problema principale siano i doppi apici ("), ma....

    @aldo1070
    a scanso di equivoci, allega un file d'esempio che includa la formula proposta e il codice che hai usato... per fugare ogni dubbio.

    Visto che sei nuovo, ti consiglio di leggere il Regolamento e la sezione Annunci dallo staff del forum, e per sapere quello che serve nell'esposizione di un problema (es. allegare un file d'esempio), puoi leggere qui:
    http://www.forumexcel.it/forum/7-dom...semplice-leggi

    P.S.
    Visto che si parla di VBA, questa discussione è stata spostata nella giusta sezione: Domande su Excel VBA e MACRO

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

  6. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Inserire Formula con Se Nidificati in VBA

    Come non detto....

    A quanto pare anche a te piace "fare l'uovo" in più posti per poi andare a recuperare le soluzioni....

    I link "utili" te li ho già dati nel post precedente, ti consiglio di leggerli prima di postare nuovamente.

    Cross-posting:
    http://www.excelvba.it/Forum/thread.php?f=1&t=10890

    Regola nr.3 "Crossposting" la stessa domanda vietata su più forum
    Non è consentito postare lo stesso messaggio o parti di esso in più aree del forum o su altri forum di excel, salvo casi di particolare interesse che dovranno comunque essere autorizzati da un Admin
    Messaggi crossposting verranno chiusi e quando possibile riuniti.
    Se ripetuti potranno portare all'allontanamento dell'utente.
    Questa discussione verrà chiusa!

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

Discussioni Simili

  1. inserire formula se cella è colorata
    Di Kiter nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 05/01/17, 19:05
  2. inserire un immagine in una formula
    Di Raffaele Esposito nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 30/12/16, 20:04
  3. Inserire un Commento tramite una Formula senza usare VB
    Di maury63 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 19/11/16, 18:57
  4. Inserire formula relativa ad una cella in vba
    Di Rosaria79 nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 16/09/16, 16:28
  5. Inserire la stessa formula in uno spazio di celle
    Di solonename nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 16/04/16, 10:28

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •