Risultati da 1 a 12 di 12

Discussione: Casella di selezione dinamica



  1. #1
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Casella di selezione dinamica

    Salve, avrei bisogno di una mano.

    Ho creato una tabella che preleva l'ultimo valore in un determinato foglio tramite la funzione indice e conta.valori.

    Nel mio file di excel foglio "ANALISI" cella (B3) vorrei creare una casella di selezione da un elenco dinamico di date (le date vengono aggiunte con il passar dei giorni) in modo da prelevare i dati che corrispondano alla data selezionata.

    E' un lavoro complesso?

    Grazie per le eventuali risposte
    File Allegati File Allegati

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Casella di selezione dinamica

    Dati/Convalida/elenco

    =SCARTO(Foglio1!$A$4;1;;CONTA.VALORI(Foglio1!$A:$A)-1)

  3. #3
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Ciao Rubik grazie per la risposta ma potresti essere più preciso perchè non ho compreso ciò che devo fare.

    in B3 inserisco l'elenco come hai detto tu ma (MA NON POSSO FAR RIFERIMENTO AD ALTRI FOGLI CON LA FUNZIONA CONVALISA DATI) e poi non volevo inserire l'elenco ma un campo con frecce sopra e sotto che corre le date, se uso l'elenco avrà una lunghezza enorme perchè le date sono più di mille
    e poi come faccio a far cambiare i dati nella mia tabella ANALISI ad ogni cambio di data?

  4. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Casella di selezione dinamica

    Posizionati in B3 e vai sulla scheda Dati
    Premi "convalida dati/Convalida dati..."
    Nella scheda "Impostazioni" vai su "Consenti" e scegli "Elenco"
    in "Origine" scrivi la funzione:
    =SCARTO(Foglio1!$A$4;1;;CONTA.VALORI(Foglio1!$A:$A)-1)
    premi OK e nella cella B3 comparirà una "liguetta" che premuta ti farà scegliere una delle date del Foglio1

  5. #5
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    Posizionati in B3 e vai sulla scheda Dati
    Premi "convalida dati/Convalida dati..."
    Nella scheda "Impostazioni" vai su "Consenti" e scegli "Elenco"
    in "Origine" scrivi la funzione:
    =SCARTO(Foglio1!$A$4;1;;CONTA.VALORI(Foglio1!$A:$A)-1)
    premi OK e nella cella B3 comparirà una "liguetta" che premuta ti farà scegliere una delle date del Foglio1
    scusami avevo modificato il messaggio mentre mi scrivevi la risposta,

    NON POSSO FAR RIFERIMENTO AD ALTRI FOGLI CON LA FUNZIONA CONVALIDA DATI e poi non volevo inserire l'elenco ma un campo con frecce sopra e sotto che corre le date, se uso l'elenco avrà una lunghezza enorme perchè le date sono più di mille
    e poi come faccio a far cambiare i dati nella mia tabella ANALISI ad ogni cambio di data?

  6. #6
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Citazione Originariamente Scritto da Japogi Visualizza Messaggio

    e poi come faccio a far cambiare i dati nella mia tabella ANALISI ad ogni cambio di data?
    ho provato ad usare cerca.vert per i dati credo per ora vada bene, ho il problema delle date che non posso far riferimenti ad altri fogli

  7. #7

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Casella di selezione dinamica

    Se vuoi usare una formula nella cella B3 e una casella di selezione da controllo modulo devi usare obbligatoriamente una cella di appoggio che sottragga un valore alla formula.

    Es.
    Inserisci una casella di selezione da controllo modulo e come cella di collegamento scegli A1 (una cella libera);
    nella cella B3 modifica la formula in
    =TESTO(INDICE(Foglio1!A:A;CONTA.VALORI(Foglio1!A:A)+3;1); "gg-mm-aaaa")-A1

    ad ogni click sulle freccette, sottrarrà un valore al valore ultimo del Foglio1

    Fammi sapere

  8. I seguenti 2 utenti hanno dato un "Like" a Rubik72 per questo post:


  9. #8
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    Se vuoi usare una formula nella cella B3 e una casella di selezione da controllo modulo devi usare obbligatoriamente una cella di appoggio che sottragga un valore alla formula.

    Es.
    Inserisci una casella di selezione da controllo modulo e come cella di collegamento scegli A1 (una cella libera);
    nella cella B3 modifica la formula in
    =TESTO(INDICE(Foglio1!A:A;CONTA.VALORI(Foglio1!A:A)+3;1); "gg-mm-aaaa")-A1

    ad ogni click sulle freccette, sottrarrà un valore al valore ultimo del Foglio1

    Fammi sapere
    direi che va bene così, anche se non considera le date che non sono presenti nell'elenco, poco importa

    grazie

  10. #9
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    posso aprofittare di chiederti se è possibile modificare la formula= =CERCA.VERT($B$3;Foglio1!A:T;5;)
    impostando come riferimento del foglio il valore della cella?
    Nel senso, invece di scrivere ad ogni cella la formula con un foglio diverso posso scrivere =CERCA.VERT($B$3;Foglio&A5!A:T;5;) dove A5 corrisponde a 1?
    questo per scorrere le formule in tutte le colonne, ma non sò usare la sintassi corretta

  11. #10
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Citazione Originariamente Scritto da Japogi Visualizza Messaggio
    posso aprofittare di chiederti se è possibile modificare la formula= =CERCA.VERT($B$3;Foglio1!A:T;5;)
    impostando come riferimento del foglio il valore della cella?
    Nel senso, invece di scrivere ad ogni cella la formula con un foglio diverso posso scrivere =CERCA.VERT($B$3;Foglio&A5!A:T;5;) dove A5 corrisponde a 1?
    questo per scorrere le formule in tutte le colonne, ma non sò usare la sintassi corretta
    volevo scrivere "per scorrere in tutte le righe"

  12. #11

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Casella di selezione dinamica

    Se ho capito bene:

    =CERCA.VERT(VALORE($B$3);INDIRETTO("Foglio" & A5 & "!A:T");5;0)

  13. I seguenti utenti hanno dato un "Like"


  14. #12
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: Casella di selezione dinamica

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    Se ho capito bene:

    =CERCA.VERT(VALORE($B$3);INDIRETTO("Foglio" & A5 & "!A:T");5;0)
    si perfetto. grazie mille

Discussioni Simili

  1. Classifica dinamica
    Di Pabexcel nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 08/03/17, 04:22
  2. sub dinamica per outlook
    Di mb63 nel forum Domande su Outlook
    Risposte: 0
    Ultimo Messaggio: 21/02/17, 17:29
  3. [Risolto] convalida dinamica
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 04/11/16, 21:22
  4. [Risolto] Come ottenere un valore in una casella combinata, da un'altra casella combinata
    Di ProgrammD69 nel forum Domande su Microsoft Access
    Risposte: 13
    Ultimo Messaggio: 26/07/16, 14:14
  5. path dinamica
    Di Andys nel forum Domande su Excel VBA e MACRO
    Risposte: 15
    Ultimo Messaggio: 25/05/16, 11:20

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •