Risultati da 1 a 7 di 7

Discussione: Cerca.vert con risultati multipli



  1. #1
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Cerca.vert con risultati multipli

    Ciao a tutti, ho un nuovo rompicapo.
    nel file allegato ho due fogli: "Riepilogo" e "sheet".
    Entrambi sono delle estrazioni di due database separati.
    Il mio problema è che in entrambi ci sono dei valori duplicati nelle colonne B. (ne ho dato evidenza con la formattazione condizionale)
    il mio terget è quello di far comparire in ogni riga del foglio Riepilogo i valori duplicati prelevati in corrispondenza della cella trovata nel foglio Sheet corrispondente alla colonna A.
    come nell'esempio allegato per quanto contenuto nelle relative colonne C, D ed E del foglio Riepilogo.

    ho messo il post nella sezione VBA perchè dubito che con le formule si riesca ad ottenere il risultato (forse).
    ho tentato in vari modi ma il ciclo mi si ferma sempre al primo risultato, mentre ce ne sono per lo più di doppi ma anche di più.
    potete valutare se esiste soluzione e quindi darmi la solita traccia per sbloccare il mio stallo?.
    come sempre, grazie in anticipo.
    File Allegati File Allegati

  2. #2
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Cerca.vert con risultati multipli

    Ci sono diverse formule che lo fanno già.
    Sicuro che desideri VBA?

    Vedendo l'allegato, mi sembra un minestrone di VBA.
    Se Ti và, Ti devi spiegare (mani su altri codici non metto)

  3. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Cerca.vert con risultati multipli

    Ciao a tutti,

    io inizierei con una formula (ammesso che abbia capito il problema)...

    Quindi, nella cella C2 da copiare poi in basso e a destra:

    =SE(CONTA.SE(Sheet!$B$2:$B$728;'Riepilogo con formule'!$B2)<=1;"";SE.ERRORE(INDICE(Sheet!$A$1:$A$728;AGGREGA(15;6;RIF.RIGA($B$2:$B$728)/(Sheet!$B$2:$B$728='Riepilogo con formule'!$B2);RIF.COLONNA(A1)));""))

    Nel file, le formule le ho messe in un foglio aggiunto: "Riepilogo con formule"
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  4. #4
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Re: Cerca.vert con risultati multipli

    Citazione Originariamente Scritto da Raffaele_53 Visualizza Messaggio
    Ci sono diverse formule che lo fanno già.
    Sicuro che desideri VBA?

    Vedendo l'allegato, mi sembra un minestrone di VBA.
    Se Ti và, Ti devi spiegare (mani su altri codici non metto)
    Grazie mille per la risposta Raffaele. vero, il contesto rientra in uno più ampio che fa anche dell'altro e mi sono dimenticato di rimuovere del codice.

  5. #5
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Re: Cerca.vert con risultati multipli

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Ciao a tutti,

    io inizierei con una formula (ammesso che abbia capito il problema)...

    Quindi, nella cella C2 da copiare poi in basso e a destra:

    =SE(CONTA.SE(Sheet!$B$2:$B$728;'Riepilogo con formule'!$B2)<=1;"";SE.ERRORE(INDICE(Sheet!$A$1:$A$728;AGGREGA(15;6;RIF.RIGA($B$2:$B$728)/(Sheet!$B$2:$B$728='Riepilogo con formule'!$B2);RIF.COLONNA(A1)));""))

    Nel file, le formule le ho messe in un foglio aggiunto: "Riepilogo con formule"
    grazie mille cromagno, ieri sera (meglio dire stanotte) gironzolando per il forum mi sono accorto che l'argomento è già stato trattato. dovevo solo insistere un po' di più e scegliere le parole chiavi per la ricerca giuste. la formula funziona benissimo e ti ringrazio. appesantisce notevolmente il file perchè di dati ne contiene davvero parecchi ma è addolutamente funzionale. fuori dalla mia portata, non sarei mai riuscito a comporla. di nuovo grazie.
    e scusate se ho sbagliato sezione (non è cosa da vba).

  6. #6
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Re: Cerca.vert con risultati multipli

    perdonate ... mi sono perso qualcosa... come si fa a contrassegnare la discussione come risolta?
    grazie mille.
    saluti a tutti.

  7. #7

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6771
    Versione Office
    2013
    Likes ricevuti
    716
    Likes dati
    164

    Re: Cerca.vert con risultati multipli

    Ciao Nessi

    Per un problema tecnico del forum non è più possibile farlo (almeno sinora).

    Alfredo

Discussioni Simili

  1. Funzione cerca.vert con risultati multipli
    Di Keishusan nel forum Domande su Excel in generale
    Risposte: 24
    Ultimo Messaggio: 31/10/17, 12:15
  2. [Risolto] Funzioni di ricerca con risultati multipli
    Di WILCOYOTE nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 22/03/17, 00:27
  3. Funzione cerca.vert con risultati multipli
    Di Parassmtt nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 01/07/16, 18:33
  4. Indice confronta con risultati multipli
    Di yari1 nel forum Domande su Excel VBA e MACRO
    Risposte: 18
    Ultimo Messaggio: 07/04/16, 12:50
  5. Cerca.Vert si ferma al primo elemento. Alternativa per analizzare tutti i risultati?
    Di DaylighterSL nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/12/15, 19:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •