Risultati da 1 a 4 di 4

Discussione: Compattare tabella eliminando celle "falso"



  1. #1
    L'avatar di Giannib
    Clicca e Apri
    Data Registrazione
    Oct 2016
    Località
    Carlazzo, Como
    Messaggi
    2
    Versione Office
    Google Docs
    Likes ricevuti
    0
    Likes dati
    1

    Compattare tabella eliminando celle "falso"

    Ciao a tutti, ho dei numeri divisi su 4 colonne, intervallati da alcuni valori "FALSO". Vorrei "pulire" questi numeri copiandoli in colonne adiacenti eliminando i valori "FALSO" e inserendo al loro posto il primo numero utile. Esempio su una sola colonna:

    A1=2
    A2=FALSO
    A3=FALSO
    A4=3
    A5=5

    Il risultato che vorrei ottenere è:

    B1=2
    B2=3
    B3=5

    Utilizzo Google Fogli, e allego un file di esempio nel caso serva. Grazie fin da ora a chi vorrà/potrà aiutarmi. Saluti.
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 05/10/16 alle 23:24 Motivo: Messo Risolto

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4743
    Versione Office
    Office 365
    Likes ricevuti
    1059
    Likes dati
    1060

    Re: Compattare tabella eliminando celle "falso"

    Ciao GianniB
    Credo che non avevi ricevuto ancora una risposta perchè questa sezione è poco visitata, comunque ti ho preparato una formula matriciale*** da inserire nella cella F1 da trascinare a destra ed in basso

    =INDICE(A$1:A$7;PICCOLO(SE($A$1:$A$7<>"FALSO";RIF.RIGA($A$1:$A$7)-RIF.RIGA($A$1)+1);RIGHE(F$1:F1)))

    credo però che in google "Fogli" devi inserire le formule in Inglese

    qui sotto ti linko un traduttore di formule "Excel Traslator" che sicuramente ti servirà per tradurre queste formule

    http://excel-translator.de/

    questo è il risultato

    A
    B
    C
    D
    E
    F
    G
    H
    I
    1
    1
    0
    2
    0
    1
    0
    2
    0
    2
    FALSO
    FALSO
    FALSO
    FALSO
    2
    0
    0
    3
    3
    FALSO
    FALSO
    FALSO
    FALSO
    1
    1
    1
    1
    4
    2
    0
    0
    3
    0
    0
    1
    4
    5
    1
    1
    1
    1
    6
    FALSO
    FALSO
    FALSO
    FALSO
    7
    0
    0
    1
    4

    *** le formule matriciali devono essere inserite utilizzando la combinazione della tastiera
    premendo CTRL, MAIUSC, INVIO (e non solo INVIO). Tenere premuto sia il tasto CTRL e il tasto MAIUSC poi premi INVIO. Se la formula è stata attivata correttamente, dovresti vedere delle parentesi graffa {} all’inizio e alla fine della formula nella barra della formula.

    in attesa di un tuo riscontro
    Un saluto

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Giannib
    Clicca e Apri
    Data Registrazione
    Oct 2016
    Località
    Carlazzo, Como
    Messaggi
    2
    Versione Office
    Google Docs
    Likes ricevuti
    0
    Likes dati
    1

    Re: Compattare tabella eliminando celle "falso"

    Ciao Gerardo, prima di tutto ti ringrazio per la risposta, che è stata comunque per me piuttosto veloce, anche perché utilizzando Google Fogli ho pensato bene di postare nella sezione non dedicata ad Excel. Per quanto riguarda la formula, ti dico da subito che l'ho provata ed è perfetta. Inoltre non ho dovuto inserire le parentesi graffe, funziona anche senza, e non ho neanche dovuto tradurre le formule perché sono comunque in italiano. Quindi non mi resta altro da fare che dirti grazie mille per il tuo aiuto che mi è stato prezioso, anche perché penso che non ci sarei arrivato tanto presto a risolvere la cosa nel modo suggeritomi da te. Quindi rinnovo i ringraziamenti e ti faccio i complimenti per il forum, veramente molto utile. Saluti.

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4743
    Versione Office
    Office 365
    Likes ricevuti
    1059
    Likes dati
    1060

    Re: Compattare tabella eliminando celle "falso"

    Ciao Gianni
    Grazie del riscontro e torna quando vuoi
    Un saluto

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 13:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 13:54
  3. [Risolto] Come considerare il valore "FALSO" come cella vuota
    Di Emax80 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/12/16, 12:13
  4. SE(A1 contiene "ant" o se contiene "con";"vero";"falso")
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 16/05/16, 20:43
  5. Collegamento "foglio elenco" e "fogli singoli"
    Di Maurizio76 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/11/15, 09:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •