Risolto Applicare una funzione all'intervallo di CONTA.SE

sandman42

Utente junior
15 Agosto 2019
20
1
Office 365
0
Ciao,

ho una colonna di testo, e voglio contare quante caselle NON terminano con XYZ.
Ad esempio:

PIPPO
PLUTO
PAPERINOXYZ
TOPOLINO

Per estrarre gli ultimi tre caratteri pensavo di usare DESTRA(CELLA,3), ma come specifico una cosa così all'intervallo?

Pensavo una cosa del tipo:

=CONTA.PIÙ.SE('A:A;"<>'XYZ'")

che significa (correggetemi se sbaglio) "conta tutti gli elementi della colonna A che sono diversi da XYZ".
ma come specifico DESTRA() invece della stringa intera, cioè come esprimo "conta tutti gli elementi della colonna A di cui DESTRA(ciascuna cella di A, 3) è diversa da XYZ".????


Grazie e saluti
 

cromagno

Excel/VBA Expert
Supermoderatore
Expert
9 Agosto 2015
6.756
183
39
Sardegna
2013 (64 bit)
247
Ciao,
un'alternativa, anche se scrivo da Cell e non posso verificare...
=CONTA.SE(A2:A1000;"<>*XYZ")
 
  • Like
Reactions: D@nilo

genio66

Utente assiduo
Expert
25 Marzo 2017
1.296
83
Friuli
LibreOffice 6
119
Buondì aggiungo la mia
=MATR.SOMMA.PRODOTTO(--NON(VAL.NUMERO(RICERCA("XYZ";A1:A4))))
o meglio (prendendo spunto da quella di D@nilo @D@nilo )
=MATR.SOMMA.PRODOTTO(--NON(VAL.NUMERO(RICERCA("XYZ";A1:A100)))*(A1:A100<>""))
 
Ultima modifica:

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
20.682
1.713
66
Napoli
2013
398
Se hai risolto segna la discussione come risolta; per come fare guarda gli avvisi dello staff.

Relativamente all'ultima domanda devi aprire una nuova discussione.
 
Ultima modifica di un moderatore:

sandman42

Utente junior
15 Agosto 2019
20
1
Office 365
0
Scusa, non sono stato chiaro.
Intendo: se oltre alla colonna suindicata ne ho un’altra numerica, es:

PIPPO 2
PLUTO 3
PAPERINOXYZ 4
TOPOLINO 5

Voglio sommare tutti i valori della seconda colonna in cui la prima non contiene XYZ, cioè voglio ottenere 10.

Grazie e ciao
 

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
20.682
1.713
66
Napoli
2013
398
S @sandman42

Non sono stato chiaro?

Ti ho detto che per questa ultima domanda devi aprire una nuova discussione.
 

sandman42

Utente junior
15 Agosto 2019
20
1
Office 365
0
Chiarissimo, ma ho visto il tuo messaggio dopo aver postato. Se ci guardi vedi la nuova discussione.

Ciao
 
Ultima modifica di un moderatore:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!