Risolto calcolare la media dei valori settimanali di ogni anno

Luc2072

Nuovo utente
17 Maggio 2019
9
1
Excel 2007
0
Buongiorno avrei bisogno di calcolare la media dei valori relativi ad una settimana per i diversi anni.
Per esempio la media dei valori della prima settimana dell'anno, della seconda, ecc.
Inserisco il file di esempio
 

Allegati

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.279
63
Roma
Excel 2016
108
Buongiorno
Non è molto chiaro....se rialleghi il file con i risultati che vuoi ottenere scritti a mano é più facile rispondere
 

Rubik72

Excel/VBA Expert
Supermoderatore
Expert
12 Dicembre 2015
5.392
83
47
Cosenza
Excel 2016
165
Un saluto a tutti.
Io ho capito questo.
Visto che la funzione NUM.SETTIMANA non supporta le matrici prova con questa formula:
=MEDIA(SE(INT(GIORNO360(DATA(ANNO($A$2:$A$240);1;1);$A$2:$A$240)/7)+1=RIF.RIGA(A1);$B$2:$B$240))
da ricopiare in basso e da inserire in formato matriciale (CTRL+SHIFT+ENTER)
eventualmente inserire una colonna con numerazione della settimana
 

Luc2072

Nuovo utente
17 Maggio 2019
9
1
Excel 2007
0
Scusate provo a spiegarmi meglio:

Ho una tabella dati con valori per ogni settimana dell'anno.
Quindi ho un valore per la prima settimana del 2015, del 2016, 2017, 2018, 2019. Quindi 52 valori settimanali per ogni anno.
Avrei necessita di mediare i valori relativi alla stessa settimana dell'anno, considerando tutti gli anni per cui ho dei valori.

il problema che la formula deve riconoscere la sequenza delle settimane e deve calcolarne la media.

Ho riallegato il file sperando che sia più comprensibile.
Grazie
 

Allegati

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
5.087
113
Latina
Excel 2010
248
Un saluto a tutti
L @Luc2072 ho visto che come inizio settimana parti dal martedì non so se voluto o errore.
Cma se quello che hai chiesto dal martedì è corretto avrei pensato alla seguente soluzione
Ho inserito l'anno di partenza in C1 e con questa formula ricavo il primo giorno di martedì di quell'anno:

=DATA($C$1;1;((TROVA("Mar";"DomLunMarMerGioVenSab";1))/3)+RESTO(7-GIORNO.SETTIMANA(DATA($C$1;1;1);3);7))

una volta avuto il giorno di partenza del primo anno è semplice con Cerca.vert ricavare l'importo.
Naturalmente il problema è aggiungere anno per anno alla formula
e poi passare da settimana a settimana
Con la tabella che ti ho preparato si risolve anche questo

Alla fine la formula finale in J6 da trascinare a destra ed in basso:

=SE.ERRORE(CERCA.VERT(DATA($C$1+J$5;1;((TROVA("Mar";"DomLunMarMerGioVenSab";1))/3)+RESTO(7-GIORNO.SETTIMANA(DATA($C$1+J$5;1;1);3);7));$A$2:$G$500;2;0);"")

in I6 quella per la media:
=SOMMA(J6:P6)/CONTA.NUMERI(J6:P6)

Fai sapere
 

Allegati

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!