Risolto Calcolo ore tra due date

Gianfranco55

Utente senior
5 Novembre 2015
5.427
213
64
Valdagno
excel 365
300
ciao non mi torna

che intervalli usi?

8/1/19 6.00 AM 9/1/19 7.00 PM 08/01/2019 18 37:00

dove le vedi le 18 ore a me sembrano 37
poi cosa centra la data in verde?
 
Ultima modifica:

fvenz

Utente junior
27 Gennaio 2019
75
8
2016 pc
1
Ciao Gianfranco55,
io devo calcolare singolarmente ogni giorno quante ore il macchinario resta acceso, nel caso che hai preso in esame:
il macchinario resta acceso ininterrottamente dal 8/1/19 6.00 AM al 9/1/19 7.00 PM
Quindi:
l'8/1/19 6.00 AM = sono 18 Ore acceso (24-6=18)
l'9/1/19 7.00 Pm = sono 19 ore acceso (19-0=19)
 

fvenz

Utente junior
27 Gennaio 2019
75
8
2016 pc
1
In questo modo mi restituisce 37, che non è il risultato ricercato









DATA-ORA ON DATA-ORA OFF

8/1/19 6.00 AM​

9/1/19 7.00 PM​
Nel caso dell'intervallo di tempo (a4-b4) vorrei come risultato:










08/01/2019​

18​

09/01/2019​

19
Oltretutto non considera se lo stesso giorno compare in due intervalli diversi, nell'esempio che ho allegato la cella colorata di giallo è quello che intendo.





10/1/19 3.00 AM​
11/1/19 1.00 PM​
11/1/19 8.00 PM​
13/1/19 7.00 AM​
in questo caso vorrei:






10/01/2019​
21​
11/01/2019​
13+4=17
 

ninai

Excel Expert
Moderatore
Expert
11 Luglio 2015
2.563
63
57
Barcellona P.G.
2010 PC
79
Ciao
dai 4 presupposti che:
- sia A che B siano nello stesso giorno , risultato: B-A
-A sia precedente al giorno e B successivo al giorno, risultato: 24 ore
- A sia di uguale giorno e B maggiore del giorno, risultato: giorno +1 meno A
-A sia minore del giorno e B di uguale giorno, risultato: B - giorno


Per "giorno" intendo le date in F

unendo tutti sti presupposti e mettendoli in forma di matrice mi è venuto:

in G4:
=MATR.SOMMA.PRODOTTO((INT($A$4:$A$55)=F4)*(INT($B$4:$B$55)=F4)*($B$4:$B$55-$A$4:$A$55)+(INT($A$4:$A$55)<F4)*(INT($B$4:$B$55)>=F4+1)+(INT($A$4:$A$55)=F4)*(INT($B$4:$B$55)>=F4+1)*(F4+1-$A$4:$A$55)+(INT($A$4:$A$55)<F4)*(INT($B$4:$B$55)=F4)*($B$4:$B$55-F4))*24
da trascinare in basso
mi sembra giusta ma con date ed orari il test è obbligatorio

allego link con formule anche intermedie
 
Ultima modifica:

ninai

Excel Expert
Moderatore
Expert
11 Luglio 2015
2.563
63
57
Barcellona P.G.
2010 PC
79
OK, anche se da qui a mercoledì mi sarò dimenticato anche il mio nome ;) speriamo lo stia testando qualche altro utente
 
  • Like
Reactions: ges

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!