Calcolo trasferte

FabIla

Utente junior
5 Giugno 2015
21
0
1
46
Napoli
Excel 2016
Miglior risposte
0
#1
Salve a tutti, ho un DB con 4 fogli che a tre di questi ho assegnato una targa, e al quarto il calcolo delle trasferte; Allora vorrei che nel foglio "trasferte" quando nella cella A1 inserisco il nome dell'autista, si compili in automatico ricercando le date la targa e la zona relativa a quella data. Ho inserito un esempio per farvi capire meglio cosa vorrei fare.
Grazie in anticipo.
 
Ultima modifica da un moderatore:

Ste

Utente abituale
7 Giugno 2015
207
0
0
17
Brescia
2016 PC
Miglior risposte
0
#2
Salve a tutti, ho un DB con 4 fogli che a tre di questi ho assegnato una targa, e al quarto il calcolo delle trasferte; Allora vorrei che nel foglio "trasferte" quando nella cella A1 inserisco il nome dell'autista, si compili in automatico ricercando le date la targa e la zona relativa a quella data. Ho inserito un esempio per farvi capire meglio cosa vorrei fare.
Grazie in anticipo.


View attachment 137
Ciao, posso modificare il file così è più comodo?
 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#4
Ciao,

per utilizzare sempre le stesse formule potresti aggiungere una colonna di servizio E dove indichi per ogni riga la targa

=$C$1


Nel foglio trasferte

In A3

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(A1)));INDICE(CC456DD!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


In B3

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(B1)));INDICE(CC456DD!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(B1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(B1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


In C3

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(C1)));INDICE(CC456DD!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(C1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(C1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


Saluti
 

FabIla

Utente junior
5 Giugno 2015
21
0
1
46
Napoli
Excel 2016
Miglior risposte
0
#5
Grazie Canapone, solo che io ho la versione excel 2007 e la formula "AGGREGA" non è disponibile, con quale formula posso sostituirla?
 
Ultima modifica da un moderatore:

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#7
Ciao,

devi usare formule matrice da confermare con control+maiusc+invio. Provo a passarti le prime tre formule in a3 b3 e c3, ricorda di mettere la colonna targhe in ogni foglio

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$A$3:$A$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$A$3:$A$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$A$3:$A$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$E$3:$E$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$E$3:$E$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$E$3:$E$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

=SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$C$3:$C$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$C$3:$C$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$C$3:$C$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

Mi spiace che siano formule difficilmente gestibili.


Qui trovi il file dove ho fatto una prova veloce:

https://www.dropbox.com/s/rbt4h27mv4fwlsg/Prova (2).xlsx?dl=0
 
Ultima modifica:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!