Risolto Classifiche corsa podistica

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#1
Da diverse settimane sono al lavoro su un file che è stato cominciato da altri e successivamente ampliato e modificato dal sottoscritto ma che ora mi vede fermo al palo perché, con tutta sincerità, non sono stato capace di realizzare quello che di seguito vi sottoporrò.
Premetto che ho ricercato in ogni dove sui vari forum ma, la soluzione molto vicina alla mia richiesta l'ho quasi trovata in questo forum e quindi mi rivolgo a voi per lo spunto finale.
Dopo questa premessa veniamo al problema:
Mi ritrovo a cronometrare una gara podistica e devo realizzare, se possibile, in tempo reale le classifiche in base ad una serie di casistiche.
In un primo foglio inserisco i dati principali dei partecipanti man mano che mi vengono consegnati i fogli di iscrizione (si differenziano dall'1 al 200 coloro che partecipano alla corsa di 9 km mentre dal 201 al 400 coloro che partecipano alla 5 km). In automatico vengono "trasferiti" in altro foglio in ordine di pettorale e vengono "identificati" in varie categorie in base al sesso, all'età e alla corsa che andranno a fare.
Il foglio Excel realizzato "dispone" di cronometro che alla partenza viene avviato e man mano che i vari concorrenti arrivano passando sotto il traguardo, io procedo alla registrazione del tempo che successivamente viene associato al pettorale (registrazione manuale cartacea). A questo punto, completate tutte le operazioni di registrazioni dei pettorali io dovrei essere in grado di stampare, seduta stante, le classifiche generali uomini e donne per la 5 e la 9 km e le varie classifiche in base alle classificazioni più particolareggiate ovvero: fasce di età.
Ho provato con la funzione PICCOLO associata con RIGHE ma il risultato è stato nullo.
Vorrei allegare il file così da poterci capire meglio perché son certo che la mia spiegazione, se chiara a me che ci sto lavorando da settimane, non sarà chiara a chi vorrà provarci a cimentarsi e darmi un aiuto perché domenica è il giorno della gara ma, le dimensioni sono di 700 k e quindi non mi permette di allegare... ...risolto questo ovviamente la applicherò ad altre gare a cui sono chiamato a cronometrare.
In pratica ho bisogno di capire come fare a mettere nella colonna PETTORALE del foglio CLASS. GEN. - 9K - M tutti i pettorali, in ordine cronologico di arrivo, Uomini che hanno fatto la 9 km. In automatico, coi pettorali riportati si assocerà i relativi dati identificativi:
La formula deve contenere 2 condizioni SE (1° che sia "M" e la 2° che il pettorale sia compreso tra 1 e 200) e la funzione PICCOLO (per dare ordine dal tempo più basso al più alto)
Applicando poi la stessa funzione agli altri fogli, con le dovute modifiche, avrò tutte le classifiche in tempo reale.
Attendo fiducioso una dritta o ancor più un aiutino.
 
Ultima modifica da un moderatore:

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#4
Per tutta la notte ho provato e riprovato formule e incasti ma il risultato è sempre stato negativo
Di seguito vi mostro i fogli su cui bisogna lavorare.
Quello che segue è quello di input chiamata CRONOMETRO:

PETTORALE TEMPO COGNOME NOME SESSO DISCIPLINA CAT
33 45.22 Rossi Mario M 9K1M A
21 45.58 Bianchi Maria F 9K2F A
65 46.13 Verdi Luigi M 5K2M B

quello che segue è la classifica

ORD ARR. PETTORALE TEMPO


nello specifico:
nella prima delle tante classifiche che devo creare devo avere il 1° pettorale in ordine di arrivo (relativamente al foglio CRONOMETRO) che sia appartenente alla CATEGORIA "A" e sia di SESSO "M"
questa è la classifica generale degli uomini relativa alla corsa dei 9 KM
Applicherò poi la formula con le dovute modifiche per realizzare la stessa classifica generale per le DONNE e poi anche per UOMINI e DONNE della 5 KM (CATEGORIA "B")

Avrò poi altre classifiche più specifiche in base alla disciplina.

Ultima domanda: nella colonna ordine di arrivo è possibile dare una numerazione progressiva che si conclude con l'ultimo arrivato?

Spero di essere stato chiaro e spero di ricevere l'input giusto al più presto perché per me i tempi stringono.

GRAZIE A TUTTI
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#5
Ciao mdr66
la data della gara si avvicina e dobbiamo risolvere il tuo problema ma abbiamo bisogno del tuo aiuto

Ti voglio dare dei consigli per riuscire a risolvere il tuo problema che magari necessita di formule non particolarmente difficili.

1) le domande lunghe come queste rischiano di non essere neanche lette per cui fai domande molto sintetiche e chiare

2) cerca di risolvere un problema alla volta (apri una discussione alla volta)

3) Poi allega un file con 1 foglio solo con poche righe e poche colonne giusto quanto basta per sciogliere il nodo, poi una volta ottenuto il risultato inspirato sarai tu ad adattare la formula ai tuoi file

4) Scrivi il risultato desiderato a mano per confrontarlo con le potenziali formule

Prova a seguire i miei consigli perché ho notato che la gente (ed io compreso) fa più fatica a capire le realtà lavorative di file con tanti fogli che fare delle semplici formule

Proviamoci!!
 

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#6
Ecco fatto quanto richiesto.
Il file è composto da 2 fogli.
Quello che mi serve è scritto nel secondo, denominato classifica.
Speriamo di aver fatto operazione corretta.

GRAZIE
 
Ultima modifica da un moderatore:

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#7
Diciamo che fino alla formula ci sarei arrivato:

=SE(Cronometro!$E$4:$E$12="M";SE(Cronometro!$F$4:$F$12="A";Cronometro!$A$4:$A$12;""))

Il problema è che applicata ad ogni cella mi da la risposta che corrisponde all'interrogazione della funzione ma, ovviamente, nelle celle non corrispondenti a quanto richiesto da altro "risultato" ed io, per produrre una classifica ho bisogno SOLO dei pettorali che corrispondono a quanto sto ricercando che nello specifico sono MASCHI di cat: "A".

Cosa aggiungo alla funzione sopra per ottenere solo quello che cerco?
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#8
Ecco fatto quanto richiesto.
Il file è composto da 2 fogli.
Quello che mi serve è scritto nel secondo, denominato classifica.
Speriamo di aver fatto operazione corretta.

GRAZIE

View attachment 109

Ciao un saluto a tutti gli amici del forum
piano piano ce la faremo

1)quando lavori su due fogli ti consiglio di lavorare con i nomi dei campi cosi non devi saltare da un foglio all'altro
2)io ho scritto i criteri in celle esterne nelle celle H14 sesso e in H15 la Cat. cosi puoi anche cambiarli questo ti farà risparmiare tanti fogli perche ti bastera cambiare il criterio

per motivi di visualizzazione ho fatto tutto su un foglio.

in E17 ho fatto una formula per definire il tempo migliore:
=PICCOLO($B$4:$B$12;RIGHE($E$17:E17))


in B17 ho fatto questa formula che per essere attivata devi afre CTRL+SHIF+ENTER (se hai excel 2010 potrei fare anche un'ltra formula):
=SE.ERRORE(INDICE(PETTORALE;PICCOLO(SE(TEMPO=E17;SE(SESSO=$H$14;SE(CAT.=$H$15;RIF.RIGA(PETTORALE)-RIF.RIGA($A$4)+1)));CONTA.SE($E$17:E17;E17)));"")


in C17 formule basta fare ENTER per attivarla:
=SE(B17="";"";INDICE(COGNOME;CONFRONTA(B17;PETTORALE;0)))

in D17 formule basta fare ENTER per attivarla:
=SE(B17="";"";INDICE(NOME;CONFRONTA(B17;PETTORALE;0)))

Vedi Allegato!

PS. credo che comunque ci siano altre soluzioni perchè in excel non c'è mai una soluzione
Ciao
 
Ultima modifica da un moderatore:

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#9
Ciao,
il suggerimento sui criteri lo avevo pensato anche io e nel frattempo lo avevo sviluppato creando una cella nascosta dove univa sesso e categoria (CONCATENA) per creare un solo campo di ricerca così da poter stampare le 4 classifiche principali in un solo foglio (MA; MB; FA; FB) lo stesso criterio lo applicavo anche alle classifiche particolareggiate (per intenderci quelle di categoria)
Premesso che il file che hai allegato non contiene nulla, vorrei però, alla luce dello sviluppo che hai fatto sopra sottoporti il problema più importante ovvero: la classifica deve contenere SOLO i pettorali che rispondono a quanto richiesto e quindi, le righe 18, 19, 20, 23, 24 ecc non devo comparire e nel cella posizione deve esserci un progressivo.
 

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#11
Mi sono guardato il tutto è direi che la cosa funziona ma, solo sul tuo allegato, riportata, adattata e rivista (considerato che lavora su più fogli) il risultato è NEGATIVO.
Spero di riuscire nell'intento.
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#12
Forse ci siamo!
in E17 formula matrice CTRL+SHIFT+ENTER per attivarla

=SE.ERRORE(INDICE(TEMPO;PICCOLO(SE(SESSO=$H$17;SE(CAT.=$H$18;RIF.RIGA(PETTORALE)-RIF.RIGA($A$4)+1));RIGHE($B$17:E17)));"")

in B17;
=SE.ERRORE(INDICE($A$4:$A$12;CONFRONTA(E17;$B$4:$B$12;0));"")

in C17:
=SE(B17="";"";INDICE(COGNOME;CONFRONTA(B17;PETTORALE;0)))

in d12:
=SE(B17="";"";INDICE(NOME;CONFRONTA(B17;PETTORALE;0)))

in A17 :
=SE(B17="";"";RIGHE($A$17:A17))
 
Ultima modifica:

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#13
Vorrei aggiungere una considerazione.
Avendo un foglio denominato "CRONOMETRO" dove compaiono in ordine di tempo tutti coloro che sono arrivati al traguardo e quindi, UOMINI, DONNE, partecipanti alla 5KM o alla 9 KM perché fare una formula così complessa (per me) invece che una diversa che prende da quell'ordine di arrivo solo i pettorali che rispondono alle esigenze richieste e creando un altro ordine di arrivo più specifico e non generale come quello creato in CRONOMETRO???. Esempio: solo i maschi (M) che hanno fatto la 9 KM (A)
 

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#15
Forse ci siamo!

Quello che fondamentalmente mi serve è solo un cronologico dei pettorali in base a quanto scritto sopra. Il resto ho già le formule che recupera tutto automaticamente.
Ora provo ad applicare il tuo ultimo suggerimento.
GRAZIE della pazienza credo sia davvero poco...
 
Ultima modifica da un moderatore:

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#17
Non ho buone notizie. Ci ho provato e riprovato e sono arrivato ad avere quello che volevo ma il problema è che lascia righe vuote dove non trova la corrispondenza con quanto richiesto.
in pratica mi riporta le stesse informazioni del foglio cronometro nelle stesse righe e mi lascia le righe vuote quando non trova quanto richiesto.
ora, come far cancellare automaticamente le righe vuote???
 

mdr66

Nuovo utente
16 Giugno 2015
11
0
1
Sondrio
Office 2017
Miglior risposte
0
#19
Ho applicato le istruzioni che mi hai fornito e diciamo che per quanto riguarda le righe vuote il problema è presumibilmente risolto. Dico questo perché ho fatto alcune prove facendo inserimenti manuali per verificare che tutto funzionava.
Il problema però sono le formule relative al riporto del pettorale in ordine cronologico (quella che si applica nella cella B17 a scendere, per intenderci). NON da le risposte che cerco.
L'ho provata e riprovata ma il risultato è sempre lo stesso: cella VUOTA
La soluzione a questo punto la vedo complessa, dal mio punto di vista anche se, con l'uso dei FILTRI, pur essendo una cosa più laboriosa dal punto di vista del "taglia e cuci" comunque il risultato lo ottengo lo stesso. Lo scopo finale era però quello di avere in pronta disponibilità tutte le classifiche nel momento esatto in cui l'ultimo concorrente passava sotto il traguardo.
 
27 Dicembre 2017
8
0
0
Toscana
2010 64 bit
Miglior risposte
0
#20
ciao
ho scaricato il programma MdP20151 per fare le classifiche per le gare podistiche. in un computer con Excel 2010 plus a 32bit mi funziona mentre con un'altro pc con Excel plus 2010 a 64 bit mi dà errore perchè non trova i riferimenti in libreria, praticamente non fa partire il cronometro.
mi potete gentilmente aiutare?

Grazie mille
 
Ultima modifica da un moderatore:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!