Risolto Come cercare valore con corrispondenza NON esatta, in un intervallo da filtrare con delle condizioni?

frog123

Utente junior
9 Gennaio 2018
92
6
Napoli
2016
0
Ciao a tutti
Usando la funzione AGGREGA sono risucito ad ottenere la soluzione per una ricerca in corrispondenza ESATTA
Qualcuno può aiutarmi nel caso di corrispondenza NON ESATTA? perche non so come adattare questa formula oppure non so come usare l'intervallo filtrato in un Indice Confronta

La formula usata per la corrispondenza ESATTA è questa:
Codice:
=INDICE($E$6:$E$14;AGGREGA(15;6;(RIF.RIGA($E$6:$E$14)/(($C$6:$C$14=H6)*($D$6:$D$14=I6 )))-RIF.RIGA($A$6)+1;1))
 

Allegati

frog123

Utente junior
9 Gennaio 2018
92
6
Napoli
2016
0
Grazie funziona perfettamente
Sto provando ad imparare meglio, potrei chiedere una parte che non capisco/conoscevo?
quando cerchi *testo* all'interno di testocompleto è un modo per trovare parte della stringa all'interno della stringa completa?
 

frog123

Utente junior
9 Gennaio 2018
92
6
Napoli
2016
0
grazie a tutti
aggiungo un paio di domande visto che mi trovo:

[email protected] non riesco a far funzionare la formula, mi da un errore che non riesco ad inviduare

-c'è differenza pratica tra formula matriciali e non? cioè escludendo il dover usare la combinazione di tasti per inserirle, non c'è piu alcun vantaggio o svantaggio nell'uso di una formula matriciale rispetto ad una non matriciale e viceversa?

-se volessi ampliare la domanda, nel caso in cui ad esempio aggiungessi POLIGNANO A MARE, e quindi aggiungessi POL nella ricerca non esatta, otterrei NAPOLI che contiene la stringa POL
è possibile effettuare sempre una ricerca prima per ottenere il valore che inizia con la stringa fornita e poi nel caso non trovi niente, allora effettuare la ricerca all'interno?
 

paoloard

Utente assiduo
Expert
18 Febbraio 2018
4.044
245
fra BO e FE
www.riolab.org
365
526
....

-se volessi ampliare la domanda, nel caso in cui ad esempio aggiungessi POLIGNANO A MARE, e quindi aggiungessi POL nella ricerca non esatta, otterrei NAPOLI che contiene la stringa POL
è possibile effettuare sempre una ricerca prima per ottenere il valore che inizia con la stringa fornita e poi nel caso non trovi niente, allora effettuare la ricerca all'interno?
Prendendo spunto dalla formula di pkrome59 @pkrome59 direi:
=INDICE($E$6:$E$14;SE.ERRORE(INDICE(CONFRONTA(1&I6&"*";1*($C$6:$C$14=H6)&$D$6:$D$14;0););INDICE(CONFRONTA(1&"*"&I6&"*";1*($C$6:$C$14=H6)&$D$6:$D$14;0);)))
 
Ultima modifica:

[email protected]

Utente assiduo
Expert
19 Gennaio 2016
4.670
145
Roma
Excel 2016
462
Ciao
Scrivo da cellulare e non c è bisogno della conferma matriciale quindi o confermi con CTRL+SHIFT +INVIO o modifichi così

=INDICE($E$6:$E$14;CONFRONTA(1;INDICE((TROVA(I6;$D$6:$D$14))*($C$6:$C$14=H6);;);0))
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.604
145
61
Reggio Calabria
Office 2019
178
Ciao, prova così:

=INDICE($E$6:$E$14;CONFRONTA(VERO&I6&"*";($C$6:$C$14=H6)&$D$6:$D$14;0))
da attivare con i tasti ctrl+maiuscolo+invio.

oppure così:
=INDICE($E$6:$E$14;CONFRONTA(1&I6&"*";--($C$6:$C$14=H6)&$D$6:$D$14;0))
sempre da attivare.

Ciao.
 
Ultima modifica:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!