Risolto Come sommare le ore di lavoro notturno

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
7.683
345
Latina
Excel 2010
697
Ciao
come indicazioni sono scarse...
cosa vuol dire inserire l'orario dalle 22?
dove?
di quale cella parli?
fai un esempio
 

avda

Nuovo utente
1 Agosto 2020
12
3
2016
0
ciao grazie per la risposta....praticamente come in allegato oltra alla somma totale delle ore lavorative vorrei ottenere anche il notturno che parte dalle ore 22:00 - 06:00
 

alfrimpa

VBA Expert
Supermoderatore
18 Dicembre 2015
29.810
1.845
67
Napoli
2019 Pro Plus
819
A @avda

Il titolo della discussione deve sinteticamente rappresentare il problema; foglio di lavoro, ai fini di una ricerca, non significa nulla.
 
  • Like
Reactions: avda and Powerwin

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
7.683
345
Latina
Excel 2010
697
Potresti fare un esempio?
con la tua formula inserita e gli orari riportati non capisco
Il controllo va fatto giorno per giorno?
 

avda

Nuovo utente
1 Agosto 2020
12
3
2016
0
si giorno per giorno sempre dalle 22:00 alle 06 il notturno e 6/22 diurno
questo in allegato il file che noi usiamo ma calcola solo la somma mensile di ognuno ed io vorrei inserire anche la somma delle notti sempre di ognuno di noi
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
7.683
345
Latina
Excel 2010
697
Nel modo com'è impostato il file la vedo dura.
Esempio in cella J24:L24 varia l'orario e metti 22.00 - 06.00
la formula che hai in V47:
=SOMMA.SE($B$4:$AF$41;"minichini";$D$4:$AF$41)
Ti riporta sempre lo stesso totale....
Vediamo cosa mi viene in mente
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
7.683
345
Latina
Excel 2010
697
Dunque come dicevo la cosa non è semplice
ci sono celle unite la scritta Ferie, Riposo dentro le c
elle dove inserisci l''orario.
Per me visto che vuoi fare un cambiamento fallo in modo radicale
metti in verticale i giorni invece di orizzontale poi usa le colonne
per orario entrata/uscita ferie o altro su altra colonna

Quei nomi non ho capito se è uno al giorno o più di uno...

ti posso dare la formula per calcolare il notturno tra B4:D4

=ARROTONDA(RESTO(RESTO(D4;1)-RESTO(B4;1);1)*24-(RESTO(D4;1)< RESTO(B4;1))*(22-6)+MEDIANA(6;22;RESTO(B4;1)*24)-MEDIANA(6;22;RESTO(D4;1)*24);5)

e tra F4:H4

=ARROTONDA(RESTO(RESTO(H4;1)-RESTO(F4;1);1)*24-(RESTO(H4;1)< RESTO(F4;1))*(22-6)+MEDIANA(6;22;RESTO(F4;1)*24)-MEDIANA(6;22;RESTO(H4;1)*24);5)

poi adatta per gli altri giorni ed alla fine fai la somma esempio
per i primi 2 giorni è:

=ARROTONDA(RESTO(RESTO(D4;1)-RESTO(B4;1);1)*24-(RESTO(D4;1)< RESTO(B4;1))*(22-6)+MEDIANA(6;22;RESTO(B4;1)*24)-MEDIANA(6;22;RESTO(D4;1)*24);5)+ARROTONDA(RESTO(RESTO(H4;1)-RESTO(F4;1);1)*24-(RESTO(H4;1)< RESTO(F4;1))*(22-6)+MEDIANA(6;22;RESTO(F4;1)*24)-MEDIANA(6;22;RESTO(H4;1)*24);5)

finita una riga e completata la formula poi la trascini in basso tieni solo la riga che ti serve e cancelli le altre celle,
Vedi colonna AM
Poi avendo il totale delle ore complessive sottrai le ore notturne ed ottieni il diurno
 

Allegati

alfrimpa

VBA Expert
Supermoderatore
18 Dicembre 2015
29.810
1.845
67
Napoli
2019 Pro Plus
819
Marco1975 @Marco1975

Le soluzioni (formule o macro) vanno inserite nel post oltre che nell’allegato.
 

avda

Nuovo utente
1 Agosto 2020
12
3
2016
0
no non mi interessa lo straordinario basta già il totate che sta nelle riga 49 , vorrei inserire il totale notturno di ognuno di noi
 

lukereds

Excel/VBA Expert
Staff
17 Luglio 2018
2.070
115
Milano
www.formazione-milano.net
2013 e 2016
159
Cosi calcola le ore notturne; per persona (e non solo il totale come ho scrtitto al post prec)
Nelle celle AK2:AK8 i nominativi delle persone
=SOMMA(SE.ERRORE(($B$9:$AE$9=AK2)*($D$9:$AG$9);""))+SOMMA(SE.ERRORE(($B$19:$AE$19=AK2)*($D$19:$AG$19);""))+SOMMA(SE.ERRORE(($B$29:$AE$29=AK2)*($D$29:$AG$29);""))+SOMMA(SE.ERRORE(($B$39:$AE$39=AK2)*($D$39:$AG$39);""))


Celle in verde, le righe considerate per il calcolo sono la 9, 19, 29, 39

PS: tutte quelle celle unite complicano la vita, basta allargare la colonna se la vuoi pIù larga
 

Allegati

Ultima modifica:
  • Like
Reactions: avda

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!