Risolto Confronto orario

LeTenebre

Utente junior
9 Aprile 2018
51
6
ROMA
OFFICE 2013
0
Buongiorno ragazzi...
spero che qualcuno mi aiuti mi servirebbe una formula che dato un orario andasse indietro di 30 min e mi contasse quanti eventi sono successi in quei 30 min. Io ho provato con Conta.Se ma non da il risultato sperato.
Grazie della collaborazione buona giornata
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.984
113
Latina
Excel 2010
236
Ciao LeTenebre @LeTenebre
dovresti allegare un esempio
per evitare tentativi a vuoto.
 

LeTenebre

Utente junior
9 Aprile 2018
51
6
ROMA
OFFICE 2013
0
Ecco l'esempio, in breve parole vorrei nella cella b il valore delle volte dell'evento nei 30 min. nella cella b1 c'è la formula con conta.se mentre nella cella b2 una formula che mi da il tempo trascorso
 

Allegati

cromagno

Excel/VBA Expert
Supermoderatore
Expert
9 Agosto 2015
6.381
83
39
Sardegna
2013 (64 bit)
192
Sempre che abbia interpretato bene il tuo file....
in cella B2 (da copiare poi in basso):
=MATR.SOMMA.PRODOTTO(--(($C$2:$C2+$E$2:$E2)>=((C2+E2)-30/(24*60))))
 

Gianfranco55

Utente assiduo
5 Novembre 2015
4.557
83
64
Valdagno
excel 365
175
sai mica l'ho capita il due volte???

non è che il primo evento non lo vuoi contare?
allora basta un -1
metti un risultato a mano
altrimenti ci sono mille interpretazioni
 

LeTenebre

Utente junior
9 Aprile 2018
51
6
ROMA
OFFICE 2013
0
Ragazzi va benissimo
ho un problemino con questa formula con una formula riferita sempre al file di prima =SE(L9="";"";SE(O(A9=0;A9="");0;SE(F9<"07:30";SE(B9<7;M9-20;SE(D9>=8;M9-50;SE(G9>"7:30";SE(D9<2;M9-20;SE(M9>3;M9-50;M9-35)))))))) ovvero se la cosa succede prima delle sette e trenta deve fare alcune cose altrimenti se la cosa succedesse dopo le sette e trenta deve fare altre cose, la formula quando è minore funziona quando è maggiore mi ristituisce il valore di falso perche? aiuto
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.984
113
Latina
Excel 2010
236
Si, ma dovresti mettere sull'altra colonna il risultato corretto
indicando le condizioni quali debbono essere ...quel B cosa c'entra?
 

LeTenebre

Utente junior
9 Aprile 2018
51
6
ROMA
OFFICE 2013
0
Non capisco... io dico alla formula di verificare se l’orario è maggiore o minore delle 07:30 a volte potrebbero essere altri orari però se funziona con uno poi basta cambiare l’orario, comunque se l’ora è minore devo togliere dei minuti rispettivamente 20 35 e 50 Minuti rispettivamente se è minore di 6 della colonna b se è maggiore di 6 35 se è maggiore di 8 50 se invece l’orario è maggiore delle 7:30 allora controllo la colonna b e se è minore uguale a due allora meno 20 se maggiore 35 se maggiore di 4 50 min
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.984
113
Latina
Excel 2010
236
Prova a fare in questo modo
o metti 07.30 in una cella esempio J1
e nella formula sostituisci "07.30" con... E2<$J$1 ...

oppure usa : ....E2<ORARIO(7;30;)....
in quanto in quel modo non lo riconosce.
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.984
113
Latina
Excel 2010
236
LeTenebre @LeTenebre
prova a vedere se funziona:

=SE(G2="";"";SE(O(A2=0;A2="");0;SE(E(E2<$J$1;B2<7);H2-20;SE(E(E2<$J$1;B2>=8);H2-50;SE(E(E2>$J$1;B2<2);H2-20;SE(E(E2>$J$1;B2>3);H2-50;H2-35))))))

ho nesso 07.30 in J1 oppure lo sostituisci con ORARIO come detto sopra.
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!