Risolto Conta ID univoci

claudiolui

Utente junior
12 Ottobre 2018
22
1
2016
0
Ciao a tutti

ho provato a guardare tra le varie risposte ma non sono riuscito a trovare una soluzione da adattare:

sapete aiutarmi a scrivere una formula che calcola in modo univoco gli id sotto riportati ? :

gli id si ripetono, vedi 44765515, 44805859,.

devo fare un conteggio di quanti sono gli id univoci, senza contare i duplicati, triplicati ecc.
il risultato è 4 ma non riesco a farlo con una formuletta.

grazie

Claudio





























































ID UNIVOCI

4​

CORRETTO

MIO CONTEGGIO

7​

ERRATO
ID
41047995
43524989
44765515
44765515
44765515
44805859
44805859
 

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.664
83
Roma
Excel 2016
147
Buongiorno
poniamo questi dati da A2 a A8 nella cella di output

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(A2:A8;A2:A8&""))

se devi gestire un range più ampio con eventuali celle vuote

=MATR.SOMMA.PRODOTTO((A2:A100<>"")/CONTA.SE(A2:A100;A2:A100&""))
 
  • Like
Reactions: claudiolui

klingklang

Ciappinaro VBA_Expert
Expert
20 Ottobre 2017
5.032
213
42
San Giovanni in Persiceto (BO)
www.excelswissknife.com
2016, 365
350
ho provato a guardare tra le varie risposte ma non sono riuscito a trovare una soluzione da adattare:
Ciao, se non vuoi trovarti bloccato a ogni passo, ti conviene imparare a cercare sulla rete... L'argomento è stato trattato innumerevoli volte anche qui, e una ricerca per "conta univoci excel" su Google ti darà più soluzioni di quante riuscirai a provarne in una vita intera.
 

claudiolui

Utente junior
12 Ottobre 2018
22
1
2016
0
Ciao, in realtà ho cercato su google e quasi contemporaneamente ho ricevuto risposte dal forum e ho trovato risultati online.

grazie , hai ragione su quello che dici

Claudio
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!