Risolto conta valori copia incolla

john_cash

Utente junior
20 Maggio 2018
49
0
6
milano
2007
Miglior risposte
0
#1
Ciao a tutti.
devo copiare un range da un foglio ad un altro.
Per trovare quante sono le celle non vuote uso:
=CONTA.VALORI($A$1:$A$20)
non capisco perchè continua a uscire sempre per esempio 20 anche se è 1
Il copia incolla forse formatta la celle in qualcosa che la formula riconosce come tutte non vuote.
john
 

john_cash

Utente junior
20 Maggio 2018
49
0
6
milano
2007
Miglior risposte
0
#3
Il range è un esempio.
C'è una macro che copia/incolla da un foglio ad un'altro.
Nel primo foglio il range ha formule e questa macro copia/incolla
Codice:
Sub copia_in_packinglist_2() 
    
    Sheets("packing").Select
    Range("K3:V202").Select

        Selection.Copy
    Sheets("list").Select
    Range("A7").Select
    Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
        :=False, Transpose:=False
    'Range("A7").Select    
            
End Sub
john
 

genio66

Utente abituale
Expert
25 Marzo 2017
625
67
28
Friuli
LibreOffice 6
Miglior risposte
19
#4
Buondì io di macro non ci capisco niente, ma potrebbe essere che come, ad esempio, quando si usa la formula SE.ERRORE le celle siano bianche ma non senza contenuto.
 

john_cash

Utente junior
20 Maggio 2018
49
0
6
milano
2007
Miglior risposte
0
#8
Questo è un file di esempio.
La macro copia il range K3:V15 del foglio1 nel range A7:L19 del foglio2
Ora in questo esempio la formula =CONTA.VALORI(A7:A25) in A26 funziona
Non funziona su il workbook in ufficio esce sempre 25 che sono tutte le celle.
john
 

Allegati

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
3,881
67
48
Latina
Excel 2010
Miglior risposte
55
#9
Un saluto a tutti
p strano quello che dici
hai verificato in ufficio se in Opzioni calcolo è su automatico o manuale?
Hai provato la formula suggerita da Klingkcappello_saluta che adattata sarebbe:

=CONTA.VALORI(A7:A25)-CONTA.VUOTE(A7:A25)
 

john_cash

Utente junior
20 Maggio 2018
49
0
6
milano
2007
Miglior risposte
0
#10
Ciao,
la formula di Kingk se non sono celle piene mi dà negativo.
In rete ho trovato questa:

=MATR.SOMMA.PRODOTTO(--(LUNGHEZZA($A7:$A207)>0))

e mi sembra qui a casa funzioni.
Vediamo domani.
Un saluto a tutti.
john
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!