Risolto Conta valori una sola volta

flaviolab

Nuovo utente
6 Aprile 2019
10
0
1
OFFICE 365 MAC
0
Buonasera,
chiedo scusa se pongo una domanda sicuramente già posta, ma non riesco ad applicare le soluzioni al caso particolare.

Allego file esempio.

Le mie necessità sono:
1) ottenere il numero di ID presenti nella colonna A, considerati UNA SOLA VOLTA.
2) ottenere il numero di ID presenti nella colonna A, legati al colore: ad esempio, quanti ID sono di colore bianco? Quanti ID di colore nero? Ripetendo sempre l'ID una sola volta.

Il file sembra senza senso, ma è solo un esempio di un file con migliaia di valori....
Vi ringrazio!
 

Allegati

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
16.333
523
113
Como
2011MAC 2016WIN
235
Ciao,
se ogni ID può avere solo un colore basterebbe la semplice (in E3 da trascinare in basso):

=CONTA.SE($B$2:$B$26;D3)
 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
16.333
523
113
Como
2011MAC 2016WIN
235
Forse allora così (sempre in E3 da trascinare in basso):

=MATR.SOMMA.PRODOTTO(1/CONTA.SE($A$2:$A$26;$A$2:$A$26)*($B$2:$B$26=D3))
 

Andrea

Utente abituale
22 Giugno 2015
163
20
18
61
Levico Terme
2016
9
Per estrarre i valori univoci di ID da copiare in cella C2 con Ctrl+Shift+Enter e ricopiare in basso

=SE.ERRORE(INDICE($A$2:$A$26;CONFRONTA(0;CONTA.SE($C$1:C1;$A$2:$A$26);0));"")

Per contare il totale dei valori univoci di ID

=SOMMA(SE(FREQUENZA($A$2:$A$26;$A$2:$A$26)>0;1))
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.578
531
113
Latina
Excel 2010
171
Ciao F @flaviolab
vedi nel link sotto come chiudere la discussione
Grazie

 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!