Risolto Conteggio delle ricorrenze

taranto57

Nuovo utente
20 Giugno 2018
10
0
1
Taranto
Excel 2013
1
Buona sera,
vorrei risolvere il seguente problema. In un foglio Excel da B2 a B500 periodicamente devo registrare dei nominativi e vorrei, a partire da E2 l'elenco in ordine decrescente dei cognomi (senza duplicati) e dalla cella F2 il numero di volte presente. Il tutto deve ignorare le celle vuote.
Allego file esempio.
Ringrazio in anticipo
 

Allegati

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.073
183
63
Roma
Excel 2016
74
Ciao
in E2 da attivare con CTRl+SHIFT+INVIO e poi trascinare in basso

=SE.ERRORE(INDICE($B$2:$B$500;CONFRONTA(0;CONTA.SE($B$2:$B$500;"<"&$B$2:$B$500)-SOMMA(CONTA.SE($B$2:$B$500;E$1:E1));0));"")

in F2 da trascinare in basso

=MATR.SOMMA.PRODOTTO(($B$2:$B$500=E2)*($B$2:$B$500<>""))

FILE DA SCARICARE
 
  • Like
Reactions: Abe76 and ges

Abe76

Utente abituale
23 Agosto 2017
665
108
43
42
Milano
Office16/19xWin
27
Buongiorno,
giusto per utilizzare un'altra opzione.
Allego file con formula suggerita da D@nilo @D@nilo Saluto_saluto ed affiancato un tabella pivot che non necessita di formule,
cosi' puoi confrontarne le differenze a parita' di risultato. PollicioneInSu
 

Allegati

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!