Domanda conteggio numeri in una stringa alfanumerica

Chisum

Nuovo utente
9 Giugno 2020
9
1
2019
0
esiste una formula che mi permette di ottenere in una cella il conteggio di quanti numeri ci sono in una stringa alfanumerica della cella accanto? potete aiutarmi?
 

Allegati

Rubik72

Excel/VBA Expert
Supermoderatore
12 Dicembre 2015
11.865
1.445
49
Cosenza
Excel 2016
1.014
Ciao, se il delimitatore è sempre il trattino ( - ) prova con:

=LUNGHEZZA(A1)-LUNGHEZZA(SOSTITUISCI(A1;"-";""))+1
 
  • Like
Reactions: eddie

alfrimpa

VBA Expert
Supermoderatore
18 Dicembre 2015
42.301
2.445
68
Napoli
Office 365
1.365
La funzione CONTA.NUMERI() ti restituisce il conteggio dei valori numerici di un intervallo non nel contenuto di una cella dove i numeri sono stringhe.

E' per questo che tu hai 0 perchè in A1 numeri non ce ne sono; è un'unica stringa.
 

Il_Nidificatore

Nuovo utente
21 Ottobre 2021
10
3
2019
0
esiste una formula che mi permette di ottenere in una cella il conteggio di quanti numeri ci sono in una stringa alfanumerica della cella accanto? potete aiutarmi?
Ciao Chisum,

un'altra soluzione potrebbe essere quella di separare i numeri che attualmente sono formattati come stringa in più colonne utilizzando la funzione "Testo in Colonne", per poi applicare la funzione CONTA.NUMERI alle colonne interessate.


Ciao
 
  • Like
Reactions: Pitagora

Canapone

Excel Expert
Moderatore
2 Giugno 2015
2.939
145
Firenze
Excel 2016
452
Ciao a tutti

sulla premessa condivisa da Rubik72, potresti contare i trattini ( e quindi i numerio) così

=MATR.SOMMA.PRODOTTO(--(STRINGA.ESTRAI(A1&"-";RIF.RIGA($1:$100);1)="-"))
 
  • Like
Reactions: genio66

Terio

Utente abituale
6 Gennaio 2021
918
75
51
Arce
2016, 2019
105
Prova anche:
=CONTA.VALORI(VALORE(FILTRO.XML("<t><s>"&SOSTITUISCI(RIMPIAZZA(A1;1;TROVA(": ";A1)+1;"");"-";"</s><s>")&"</s></t>";"//s")))

Ciao.
 

Chisum

Nuovo utente
9 Giugno 2020
9
1
2019
0
Grazie a tutti, ho sperimentato la formula più breve di Rubik72 ed è andata in porto, anche spostando i trattini funziona. Grazie mille.
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!