Risolto Copiare riga al verificarsi di... parte seconda

KARLO16

Utente abituale
17 Giugno 2016
326
18
Cagliari
excel 2013
2
Come suggeritami inizio una nuova discussione a seguito di quella precedente conclutasi con successo e chiusa.
Ritornando a noi, il file che allego (risolto precedentemente) avrebbe bisogno di essere incrementato con il copiare la riga completa al verificarsi che nella colonna L (data rinnovo 2019 e M data rinnovo 2020) sia presente una qualsiasi data (che la cella non sia vuota) nella pagina 2019 e 2020.
Spero di aver esposto correttemente il quanto necessita.
Grazie anticipatamente
 

Allegati

davideb

Utente abituale
26 Luglio 2019
221
20
office 2016
17
Buongiorno lorenzo trovato @lorenzo trovato , da quello che ho capito:
- sul suo file c'e' il foglio TOTALE , nelle colonne L e M deve inserire delle date relative ai rinnovi compiuti in un anno o nell'altro ; lui vorrebbe poter copiare nei relativi fogli 2019 o 2020 , le righe relative a queste colonne.
N.B.( solo sè' compilate con una data , scartando le righe prive di questa informazione).

Poi attendiamo risposta dal diretto interessato....
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
6.458
245
Latina
Excel 2010
487
In saluto a tutti
se ho capito bene nel foglio 2019 e 2020 in A2:

=SE.ERRORE(INDICE(TOTALE!A$2:A$10;AGGREGA(15;6;(RIF.RIGA(A$2:A$10)-1)/((TOTALE!$L$2:$L$10<>"")/(TOTALE!$M$2:$M$10<>""));RIGHE($A1:$A$1)));"")

trascinare a destra ed in basso, e formattare le colonne date come tali.
Togliere dal foglio Totale le // nelle celle vuote altrimenti non saranno mai vuote.
 
  • Like
Reactions: pkrome59

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.028
85
60
Reggio Calabria
Office 2013
75
Ciao, se ho capito bene, copia la seguente:

Foglio2019:
In A2:
=SE.ERRORE(INDICE(TOTALE!A$2:A$4;AGGREGA(14;6;(RIF.RIGA(TOTALE!$AD$2:$AD$4)-1)/(ANNO(TOTALE!$L$2:$L$4)=VALORE(DESTRA(CELLA("nomefile";A1);4))>0);RIGHE($A$2:$A2)));"")
da trascinare verso destra e poi da tirare giù.
Per i fogli relativi agli anni successivi basta sostituire TOTALE!$L$2:$L$4 con TOTALE!$M$2:$M$4 (evidenziato in rosso) e così via.
Allego il file di prova, ciao.
 

Allegati

KARLO16

Utente abituale
17 Giugno 2016
326
18
Cagliari
excel 2013
2
Grazie a tutti per l'impegno. Pkrome59 hai centrato il problema. Solo per curiosità, se al posto di una data, in una altra colonna qualsiasi, quindi con dei caratteri alfanumerici, come si evolverebbe la formula? Esempio colonna email. Ti ringrazio.
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.028
85
60
Reggio Calabria
Office 2013
75
Ciao, nel caso tu voglia fare la ricerca per E-Mail, la formula va modificata nel seguente modo:

In A2:
=SE.ERRORE(INDICE(TOTALE!A$2:A$4;AGGREGA(14;6;(RIF.RIGA(TOTALE!$AD$2:$AD$4)-1)/(STRINGA.ESTRAI(TOTALE!$J$2:$J$4;TROVA("@";TOTALE!$J$2:$J$4);1)=DESTRA(CELLA("nomefile";A1);1));RIGHE($A$2:$A2)));"")
da trascinare verso destra e poi da tirare giù.
Allego il file di prova, ciao.
P.S. Il foglio di ricerca tramite E-Mail va opportunamente nominato "@"
 

Allegati

KARLO16

Utente abituale
17 Giugno 2016
326
18
Cagliari
excel 2013
2
Sei una forza della natura. Non ci sarei mai riuscito. Quindi ho capito che nella pagina bisogna inserire obbligatoriamente un riferimento. Grazie infinite
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
6.458
245
Latina
Excel 2010
487
Quindi, ricorda di mettere il Risolto vedi link sotto:


 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!