Domanda Creare database da tabella

rudysmoke

Utente abituale
4 Novembre 2016
109
16
40
Poggibonsi
excel 2013
0
Buongiorno a tutti,
ho una tabella preimpostata che riepiloga dei dati, avrei cortesemente bisogno di trovare una soluzione per creare un database dettagliato che elenchi tutte le tipologie di incrocio della tabella senza dover manualmente riscrivere tutto.
Come posso fare?
Allego esempio.
-Nel foglio "tabella preimpostata" la tabella
-nel foglio "database" quello che dovrebbe essere il risultato finale.
Grazie come sempre dell'aiuto
 

Allegati

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
22.672
1.745
66
Napoli
2019 Pro Plus
492
Prova questa macro ovviamente cancellando prima i dati dal foglio Database (non l'intestazione)

Visual Basic:
Sub CreaDatabase()
Dim i As Integer
Dim ur As Long
Dim rng As Range
Dim cel As Range
Set rng = Sheets("tabella preimpostata").Range("b1:e1")
For Each cel In rng
    For i = 0 To 4
        ur = Sheets("database").Cells(Rows.Count, "a").End(xlUp).End(xlUp).Row
        Sheets("database").Cells(ur + 1, "A").Value = "A" & i + 1
        Sheets("database").Cells(ur + 1, "B").Value = cel.Value
    Next i
Next cel
End Sub
 

genio66

Utente assiduo
Expert
25 Marzo 2017
1.431
115
Friuli
LibreOffice 6
135
Un saluto ad Alfredo. Con le formule potresti fare: in A2
=INDICE('Tabella preimpostata'!$A$2:$A$6;RESTO(RIF.RIGA(A1)-1;5)+1)
e in B2
=INDIRETTO(INDIRIZZO(1;QUOZIENTE(RIF.RIGA(A1)-1;5)+2;;;"Tabella preimpostata"))
Entrambe da tirare in basso.
 

rudysmoke

Utente abituale
4 Novembre 2016
109
16
40
Poggibonsi
excel 2013
0
Buonasera,
ringrazio tutti delle risposte, le due formule funzionano perfettamente, la vba purtroppo non la sò adattare al file originale, cmq grazie anche per questo suggerimento.
Nella tabella preimpostata ci sono delle righe che vorrei escludere dal database perchè sono dei totali, come posso fare?
Allego esempio
Foglio "budget" le righe denominate "Azioni A" B e C sono i totali
Foglio "consuntivo" le righe sottolineate in arancione sono quelle che riportano i totali e non vorrei ci fossero perchè mi alterano il database.
Grazie dei preziosi aiuti.
 

Allegati

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!