Risolto Creazione elenco con sommatoria valori riferiti allo stesso codice cliente

PaoloDA

Utente abituale
1 Agosto 2017
450
18
ROMA
EXCEL 2013
8
Ciao a tutti,

eccomi di nuovo con un nuovo quesito.

Allego un file di esempio, composto da due fogli: “RIEPILOGO GENERALE” e “Riepilogo GAV Cliente” (il Foglio1 è di appoggio).

Ciò che vorrei è questo:
  • Con la selezione del GAV nella cella D2 e del periodo nelle celle J2 e L2 del foglio “Riepilogo GAV Cliente”, a partire dalla riga 6 in ordine DECRESCENTE;
  • fare una sommatoria del “Volume Fatturato in mc” (colonna Q del foglio “RIEPILOGO GENERALE”) e del “Margine di Contribuzione €” (colonna AI del foglio “RIEPILOGO GENERALE”) delle righe del foglio “RIEPILOGO GENERALE” corrispondenti allo stesso codice cliente (colonna B del foglio “RIEPILOGO GENERALE”);
  • riportare i valori nelle corrispondenti colonne del foglio “Riepilogo GAV Cliente”;
  • ad una diversa selezione del GAV e/o del periodo, i dati precedenti dovranno essere cancellati.
Qualcuno di Voi lo ritiene fattibile?

Attendo fiducioso.

Grazie mille.

Saluti,
PDA
 

Allegati

paoloard

Utente assiduo
Expert
18 Febbraio 2018
3.318
145
fra BO e FE
www.riolab.org
365
434
Non so se ho capito bene.
Se periodo da 1 a 8 significa mesi da Gennaio a Agosto:
in C6: =SE.ERRORE(INDICE('RIEPILOGO GENERALE'!$A$25:$A$1500;AGGREGA(15;6;(RIF.RIGA($25:$1500)-24)/($D$2='RIEPILOGO GENERALE'!$D$25:$D$1500&" - "&'RIEPILOGO GENERALE'!$C$25:$C$1500);RIF.RIGA(A1)));"")

in D6: =SE.ERRORE(MATR.SOMMA.PRODOTTO((MESE('RIEPILOGO GENERALE'!$O$25:$O$1500)>=J2)*(MESE('RIEPILOGO GENERALE'!$O$25:$O$1500)<=L2)*('RIEPILOGO GENERALE'!$A$25:$A$1500=$C6 )*'RIEPILOGO GENERALE'!$Q$25:$Q$1500);"")

in E6: =SE.ERRORE(MATR.SOMMA.PRODOTTO((MESE('RIEPILOGO GENERALE'!$O$25:$O$1500)>=$J$2)*(MESE('RIEPILOGO GENERALE'!$O$25:$O$1500)<=$L$2)*('RIEPILOGO GENERALE'!$A$25:$A$1500='Riepilogo GAV Cliente'!$C6 )*'RIEPILOGO GENERALE'!AI$25:AI$1500);"") questa va trascinata a destra di una cella.

il tutto da trascinare in basso.

Non ho completato il CTC perché non so a quale colonna fa riferimento.
Penso che con le formule qui sopra sarai in grado di farlo tu.
 

Allegati

  • Like
Reactions: PaoloDA

PaoloDA

Utente abituale
1 Agosto 2017
450
18
ROMA
EXCEL 2013
8
Ciao ragazzi,
scusami del ritardo nelle risposte ai Vostri riscontri.
Il periodo è il mese della DATA USCITA MERCE (colonna O del foglio RIEPILOGO GENERALE), mentre il CTC è il codice cliente.

Ringrazio PaoloArd per il suo suggerimento, ma gli chiedo un po' di pazienza perché mi occorreranno un paio di giorni per la verifica.

Vi tengo aggiornati.

Grazie mille.

Saluti,
PDA
 

paoloard

Utente assiduo
Expert
18 Febbraio 2018
3.318
145
fra BO e FE
www.riolab.org
365
434
...mentre il CTC è il codice cliente.
..
Allora, aggiungi:

in B6: =SE.ERRORE(INDICE('RIEPILOGO GENERALE'!$B$25:$B$1500;AGGREGA(15;6;(RIF.RIGA($25:$1500)-24)/($D$2='RIEPILOGO GENERALE'!$D$25:$D$1500&" - "&'RIEPILOGO GENERALE'!$C$25:$C$1500);RIF.RIGA(A1)));"")

sostituisci la formula in C6 con la seguente, più veloce:
in C6: =INDICE('RIEPILOGO GENERALE'!$A$25:$A$1500;CONFRONTA(B6;'RIEPILOGO GENERALE'!$B$25:$B$1500;0))
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!