Domanda Data prima occorrenza valore "contato"

Canepulcioso

Nuovo utente
26 Maggio 2019
8
1
Office 365
0
Ciao a tutti,

ho un quesito in apparenza semplice ma che non sono riuscito a risolvere.

Ho un foglio di calcolo con il quale gestisco la pianificazione delle squadre (planning). Su un secondo file concatenato recupero con conta.se quante occorrenze di ogni commessa compaiono nel planning in modo da capire quanto tempo è stato impiegato su ogni commessa.
Vorrei recuperare anche la data di INIZIO e FINE pensavo "banalmente" recuperando la data della prima occorrenza e quella dell'ultima ma non so come fare...

Allego estratto del planning.

Grazie.
Lorenzo
 

Allegati

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.476
83
Roma
Excel 2016
126
Buonasera
e dove vanno messi questi risultati ? e con i dati inseriti nel file quali risultati ti aspetti?
Se li metti a mano è più facile rispondere
 

Canepulcioso

Nuovo utente
26 Maggio 2019
8
1
Office 365
0
Ciao Danilo,

ho aggiunto il foglio3 che è un estratto del mio file di riepilogo.
Quello che vorrei è alimentare in automatico la data di inizio e fine partendo dal foglio1 rispettivamente prima e ultima occorrenza della commessa (es. 19-E001).

Dimmi se così è più chiaro.

Grazie, Lorenzo
 

Allegati

ninai

Excel Expert
Moderatore
Expert
11 Luglio 2015
2.537
63
57
Barcellona P.G.
2010 PC
73
ciao
in D2:
=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;AGGREGA(15;6;RIF.RIGA(Foglio1!$C$2:$C$14)-1/(A2=Foglio1!$D$2:$J$14);1));"")
in F2:
=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;AGGREGA(14;6;RIF.RIGA(Foglio1!$C$2:$C$14)-1/(A2=Foglio1!$D$2:$J$14);1));"")

e trascini in basso
 

Canepulcioso

Nuovo utente
26 Maggio 2019
8
1
Office 365
0
ciao
in D2:
=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;AGGREGA(15;6;RIF.RIGA(Foglio1!$C$2:$C$14)-1/(A2=Foglio1!$D$2:$J$14);1));"")
in F2:
=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;AGGREGA(14;6;RIF.RIGA(Foglio1!$C$2:$C$14)-1/(A2=Foglio1!$D$2:$J$14);1));"")

e trascini in basso

Ottimo!
Sul file funziona perfettamente.
Ora sto cercando di farlo funzionare anche su Google SpreadSheet... incrocio le dita! Se hai qualche suggerimento è ben accetto.
Comunque grazie mille.
 

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.476
83
Roma
Excel 2016
126
Buonasera e un saluto a Ninai
credo che quella versione non supporti aggrega quindi la versione matriciale in D2 da attivare con CTRL+SHIFT+INVIO e trascinare in basso

=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;PICCOLO(SE(A2=Foglio1!$D$2:$J$14;RIF.RIGA($C$2:$C$14)-1);1));"")

e in F2

=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;GRANDE(SE(A2=Foglio1!$D$2:$J$14;RIF.RIGA($C$2:$C$14)-1);1));"")

in alternativa a tutto un'altra ipotesi in D2 da trascinare in basso

=INDICE(Foglio1!$C$2:$C$100;CONFRONTA($A2;INDICE(INDIRETTO(INDIRIZZO(2;CONFRONTA($B2;Foglio1!$D$1:$J$1;0)+3;;;"Foglio1")&":"&INDIRIZZO(100;CONFRONTA($B2;Foglio1!$D$1:$J$1;0)+3));;);0))

in F2

=SOMMA(D2;MATR.SOMMA.PRODOTTO((Foglio1!$D$2:$J$14=$A2)*(Foglio1!$D$1:$J$1=$B2)))-1
 

Canepulcioso

Nuovo utente
26 Maggio 2019
8
1
Office 365
0
Buonasera e un saluto a Ninai
credo che quella versione non supporti aggrega quindi la versione matriciale in D2 da attivare con CTRL+SHIFT+INVIO e trascinare in basso

=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;PICCOLO(SE(A2=Foglio1!$D$2:$J$14;RIF.RIGA($C$2:$C$14)-1);1));"")

e in F2

=SE.ERRORE(INDICE(Foglio1!$C$2:$C$14;GRANDE(SE(A2=Foglio1!$D$2:$J$14;RIF.RIGA($C$2:$C$14)-1);1));"")

in alternativa a tutto un'altra ipotesi in D2 da trascinare in basso

=INDICE(Foglio1!$C$2:$C$100;CONFRONTA($A2;INDICE(INDIRETTO(INDIRIZZO(2;CONFRONTA($B2;Foglio1!$D$1:$J$1;0)+3;;;"Foglio1")&":"&INDIRIZZO(100;CONFRONTA($B2;Foglio1!$D$1:$J$1;0)+3));;);0))

in F2

=SOMMA(D2;MATR.SOMMA.PRODOTTO((Foglio1!$D$2:$J$14=$A2)*(Foglio1!$D$1:$J$1=$B2)))-1


La versione con se.errore funziona con Google. Mi sto abbottonando per linkare un foglio esterno.
Ho adattato la formula come segue:

Codice:
IFERROR(INDEX("https://docs.google.com/spreadsheets/d/etc...";  "Planning!$C$3:$C$367");SMALL(IF(A8="https://docs.google.com/spreadsheets/d/etc...";"Planning!$C$3:$Z$367";ROW($C$8:$C$90)-1);1));"")
Mi dice che mancano delle parentesi di apertura. La formula funziona, sono sicuro dipenda dal "link" ma non riesco a trovare l'arcano....
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!