Risolto Estrapolare valori univoci da una colonna

NICO CINQUIN

Nuovo utente
16 Maggio 2017
1
1
33
LUCCA
2013
0
Buonasera Utenti del Forum,
avrei bisogno di estrapolare da una colonna con circa 1000 nomi solo i nomi univoci e copiarli in un'altra colonna di un altro foglio (ma dello stesso documento).
Questa operazione è possibile farla senza macro?
Come posso fare?
Saluti
 
Ultima modifica di un moderatore:

ges

Excel/VBA Expert
Amministratore
21 Giugno 2015
29.539
2.465
Como
2011MAC 365WIN
1.010
Ciao,
certo che è possibile farlo solo con una formula.

Per esempio, mettiamo che hai i tuoi mille nomi nella colonna A, precisamente in A2:A1000, in B2 scrivi la seguente formula, trascinandola verso il basso:

=SE.ERRORE(INDICE($A$2:$A$1000;CONFRONTA(0;INDICE(CONTA.SE(B$1:$H1;$A$2:$A$1000&""););0));"")


 

alfrimpa

VBA Expert
Supermoderatore
18 Dicembre 2015
37.931
2.445
67
Napoli
Office 365
1.210
Oppure copiare i dati della colonna A in una colonna dell'altro foglio e su questa dal menù Dati rimuovere i duplicati.
 

Wep

Nuovo utente
30 Settembre 2019
7
1
2016
0
Buongiorno,

scusate se rispondo a questo vecchio post ma sto applicando questa formula ed ho un dubbio.
=SE.ERRORE(INDICE($A$2:$A$1000;CONFRONTA(0;INDICE(CONTA.SE(B$1:$H1;$A$2:$A$1000&""););0));"")

Non riesco a capire cosa mi sta dicendo il range B1:H1 indicato nella formula.
Il B1 ho capito che indica la cella superiore a quella dove voglio far comparire i valori univoci, invece H1 che significato ha?
 

genio66

Utente assiduo
Expert
25 Marzo 2017
2.111
145
Friuli
Libo exc-onl
280
Buondì, ti sei accodato a una vecchia discussione. Era meglio se ne aprivi una nuova con magari un link che porta a questa.
Comunque quel $H1 credo sia un refuso nella formula di ges @ges . Dovrebbe essere $B1.
 

vera88

Utente abituale
30 Dicembre 2019
148
18
2013
2
quella formula prevede pero la cella A2 vuota, se invece fosse piena come si può adattare?
 

genio66

Utente assiduo
Expert
25 Marzo 2017
2.111
145
Friuli
Libo exc-onl
280
Casomai prevede che B1 sia vuota. Se nella prima riga hai delle intestazioni di colonna puoi inserire una riga vuota da nascondere e metti la formula in B3 così:
=SE.ERRORE(INDICE($A$3:$A$1000;CONFRONTA(0;INDICE(CONTA.SE([B]B$2:[B]$B2[/B][/B];$A$3:$A$1000&""););0));"")
comunque vale per te quanto detto a W @Wep riguardo l'opportunità di non accodarsi a vecchie discussioni e per di più risolte cappello_saluta
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!