Risolto Estrapolazione Dati Secondo Più Criteri

Osvaldo Favero

Nuovo utente
15 Marzo 2019
5
0
1
2017
Best answers
0
Salve a tutti.Ho una tabella già ordinata (secondo valori crescenti colonna B - C e decrescenti colonna F).
Il risultato che vorrei ottenere consiste nel cancellare tutte le righe che hanno valori uguali sulla colonna B-C e tenere la riga con valore
più grande della colonna F.

Esempio
A B F
0.8 1.8 80 Tengo
0.8 1.8 71 Cancello
0.8 1.8 63 Cancello
0.8 1.8 56 Cancello
0.8 1.8 50 Cancello
0.8 2 125 Tengo
0.8 2 112 Cancello
0.8 2 100 Cancello
etc.

Grazie in anticipo per la disponibilità
 

Marius44

VBA Expert
Moderatore
Expert
9 Settembre 2015
4.960
123
63
75
Catania
Excel2010
Best answers
82
Ciao
Invece di "mostrare" tutto quel po' po' di roba perchè non alleghi (depurato di eventuali dati sensibili, ma non mi sembra questo il caso) il tuo file?

Ciao,
Mario
 
Ultima modifica:

Osvaldo Favero

Nuovo utente
15 Marzo 2019
5
0
1
2017
Best answers
0
Ciao
il file l'avevo allegato ma mi dava errore ho verificato è più piccolo dei 400 KB (come da regolamento) e non capisco perchè non lo carica è un file Excel normale Ho provato ancora ma non riesco ho fatto anche un rar ma non lo carica perchè?
 

Marius44

VBA Expert
Moderatore
Expert
9 Settembre 2015
4.960
123
63
75
Catania
Excel2010
Best answers
82
Ciao
Hai provato di nuovo a caricare il file? Hai provato tramite un sito di filesharing?
Prova anche con Dropbox (a mio parere uno fra i più affidabili).

Ciao,
Mario
 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
15.461
418
83
Como
2011MAC 2016WIN
Best answers
184
Ciao
il file l'avevo allegato ma mi dava errore ho verificato è più piccolo dei 400 KB (come da regolamento) e non capisco perchè non lo carica è un file excel normale Ho provato ancora ma non riesco ho fatto anche un rar ma non lo carica perchè???????
Strano che non carica un file excel meno di 400KB, ma ti esce qualche messaggio?
 

eddie

Utente junior
28 Maggio 2017
43
0
6
san marino
2010
Best answers
1
Ciao,
in B da trascinare a dx e in basso del foglio risultato
=SE(CERCA.VERT($A1;'Tabella Ordinata'!$A:$M;COLONNE(Risultato!$A$1:B1);0)=0;"";CERCA.VERT($A1;'Tabella Ordinata'!$A:$M;COLONNE(Risultato!$A$1:B1);0))
 

paoloard

Utente assiduo
Expert
18 Febbraio 2018
1.040
280
83
prov. BO
2016
Best answers
104
Ciao, per ricavare un elenco univoco dei dati in colonna A a cui applicare poi la formula di eddie @eddie (ciao) puoi usare questa formula:

in A1:=SE.ERRORE(SE(RIF.RIGA()=1;'Tabella Ordinata'!A1;INDICE('Tabella Ordinata'!$A$1:$A$5000;AGGREGA(15;6;(RIF.RIGA($A$1:$A$5000)+1)/('Tabella Ordinata'!$B$1:$B$5000&'Tabella Ordinata'!$C$1:$C$5000<>'Tabella Ordinata'!$B$2:$B$5001&'Tabella Ordinata'!$C$2:$C$5001);RIF.RIGA(A1)-1)));"")&""

da trascinare in basso.
 

Allegati

Osvaldo Favero

Nuovo utente
15 Marzo 2019
5
0
1
2017
Best answers
0
Ringrazio tutti!!!Con le mie capacità non sarei mai riuscito sto provando a capire le soluzioni proposte da Eddie e di paoloard!!!
Difficile anche avendo la soluzione!!! (anche perchè la dovrei applicare ad altri casi simili)!!!!

Grazie ancora
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!