[Risolto] estrarre dati

nick0573

Utente assiduo
1 Giugno 2015
1,471
5
38
Pistoia
Excel 2016
Miglior risposte
1
#1
Ciao a tutti vorrei ricavare con le formule nella seconda tabella quello che ho scritto a mano come risultato


Grazie
 
Ultima modifica da un moderatore:
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#2
Ciao a tutti gli amici del forum!!

@Nick0573 Complimenti per l'inserimento dell'immagine dinamica
adesso è tutto più chiaro



Prova questa formula in H13 e copia in basso

=CERCA(2;1/(($C$2:$C$26=G2)*($A$2:$A$26=F2));$D$2:$D$26)
 
Ultima modifica:

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#6
Ciao,

ti giro un primo esempio, dove uso delle formule matrice da confermare con control+maiusc+invio



=SE.ERRORE(INDICE($D$13:$D$1000;PICCOLO(SE($G$13:$G$1000<>"";RIF.RIGA($A$13:$A$1000)-12);RIGHE($A$1:$A1)));"")

Se usi Excel 2010 puoi anche servirti di AGGREGA, senza bisogno del control+maiusc+invio

=SE.ERRORE(INDICE($D$13:$D$1000;AGGREGA(15;6;RIF.RIGA($A$13:$A$1000)-12/($G$13:$G$1000<>"");RIGHE($A$1:$A1)));"")

Saluti
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#8
Ciao,

ti giro un primo esempio, dove uso delle formule matrice da confermare con control+maiusc+invio


=SE.ERRORE(INDICE($D$13:$D$1000;PICCOLO(SE($G$13:$G$1000<>"";RIF.RIGA($A$13:$A$1000)-12);RIGHE($A$1:$A1)));"")


Se usi Excel 2010 puoi anche servirti di AGGREGA, senza bisogno del control+maiusc+invio

=SE.ERRORE(INDICE($D$13:$D$1000;AGGREGA(15;6;RIF.RIGA($A$13:$A$1000)-12/($G$13:$G$1000<>"");RIGHE($A$1:$A1)));"")

Saluti

Grande @Canapone!!
ed è per questo che sei un Guru!!!
anche se io quel pezzo di formula che ti ho segnato in rosso lo farei cosi:
RIF.RIGA($A$13:$A$1000)-RIF.RIGA($A$13)+1
perchè se accidentalmente si aggiunge una riga in alto la formula salta, invece cosi no



@Nik0573
la formula che avevo fatto io con la funzione =CERCA(2;1/.......... funziona ma avevo capito male la domanda, pensavo che tu volessi cercare un valore (data in esecuzione) con i criteri (Data) e (Visto)
comunque discussione da 5 stelle!!! :)

 
Ultima modifica:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!