Domanda estrarre righe da tabella in base ad un criterio

Maffa

Nuovo utente
31 Maggio 2019
3
1
excel 2007
0
Buongiorno a tutti.

su un foglio excel ho una tabella composta da più righe e più colonne in cui vengono inseriti vari dati numerici.

nello stesso foglio, ma in una seconda cartella, vorrei riportare in automatico la tabella base ma composta dalle sole righe che contengono il valore x nella colonna Y.

Come posso fare ?

Grazie mille

Roby
 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
21.646
1.733
Como
2011MAC 2016WIN
463
Ciao,
allega un file di esempio anche con poche righe.
 

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
20.682
1.713
66
Napoli
2013
398
Allega file di esempio con dati non sensibili mostrando il risultato desiderato inserendolo a mano.
 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
21.646
1.733
Como
2011MAC 2016WIN
463
Da trascinare in basso e a destra:

=SE.ERRORE(INDICE(Foglio1!B$4:B$33;AGGREGA(15;6;(RIF.RIGA($B$4:$B$33)-3)/(Foglio1!$C$4:$C$33=2);RIGHE($1:1)));"")

P.S. - La date vanno formattate in formato data!
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!