Risolto formula indice aggrega con tre condizioni

tony2019

Utente junior
3 Marzo 2019
27
1
3
2011
0
Buon giorno io avrei questa formula cosi composta:


=SE.ERRORE(INDICE($D$3:$D$121;AGGREGA(15;6;RIF.RIGA($D$3:$D$121)/(($D$3:$D$121 >= CERCA.VERT($Z$3;$Z$3:$AB$3;2;0))*($D$3:$D$121<=CERCA.VERT($Z$3;$Z$3:$AB$3;3;0))*(($K$3:$K$121>=CERCA.VERT($Z$4;$Z$4:$AB$4;2;0))*($K$3:$K$121<=CERCA.VERT($Z$4;$Z$4:$AB$4;3;0))))-RIF.RIGA($D$3)+1;RIF.RIGA(U1)));"")

Vorrei aggiungere un terzo intervallo.
Allego un esempio
Saluti
 

Allegati

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.151
203
63
Roma
Excel 2016
86
Buonasera
i tuoi dati partono da riga 1 ma la formula li considera da riga 3 e tutti quei cercavert sono inutili quindi

=SE.ERRORE(INDICE($D$1:$D$121;AGGREGA(15;6;RIF.RIGA($D$1:$D$121)/(($D$1:$D$121 >= $AA$3)*($D$1:$D$121<=$AB$3)*(($K$1:$K$121>=$AA$4)*($K$1:$K$121<=$AB$4))*(($O$1:$O$121>=$AA$5)*($O$1:$O$121<=$AB$5)));RIF.RIGA($A1)));"")
 
  • Like
Reactions: Gerardo Zuccalà

Gerardo Zuccalà

Utente senior
30 Maggio 2015
5.417
111
63
51
Milano, Italy
office 365/2016
37
Ciao Ragazzi,
con il futuro motore di calcolo di excel sarà cosi

=@FILTRO($D$1:$D$121;(($D$1:$D$121>=$AA$3)*($D$1:$D$121<=$AB$3)*(($K$1:$K$121>=$AA$4)*($K$1:$K$121<=$AB$4))*(($O$1:$O$121>=$AA$5)*($O$1:$O$121<=$AB$5))))
Tanto per ...
Un saluto
 

tony2019

Utente junior
3 Marzo 2019
27
1
3
2011
0
Buonasera
i tuoi dati partono da riga 1 ma la formula li considera da riga 3 e tutti quei cercavert sono inutili quindi

=SE.ERRORE(INDICE($D$1:$D$121;AGGREGA(15;6;RIF.RIGA($D$1:$D$121)/(($D$1:$D$121 >= $AA$3)*($D$1:$D$121<=$AB$3)*(($K$1:$K$121>=$AA$4)*($K$1:$K$121<=$AB$4))*(($O$1:$O$121>=$AA$5)*($O$1:$O$121<=$AB$5)));RIF.RIGA($A1)));"")
La formula funziona ma non come speravo, perchè per esempio se manca un valore in una delle 3 colonne D K O mi riporta ugualmente gli altri due valori nella riga del risultato, ma vorrei che invece comparisse solo il risultato che soddisfa contemporaneamente i tre requisiti cioè dovrei visualizzare solo le righe con i valori compresi in quelli intervalli. lo riuscivo a fare con la mia formula precedente il cerca.vert è rimasto perchè prima avevo una convalida dati in effetti non serve però comunque ottenevo quello che volevo quando ho aggiunto un terzo blocco di condizione Excel non me la identifica più come una formula e mi dice troppi argomenti.
In allegato ho modificato il file.
 

Allegati

tony2019

Utente junior
3 Marzo 2019
27
1
3
2011
0
Ciao Ragazzi,
con il futuro motore di calcolo di excel sarà cosi

=@FILTRO($D$1:$D$121;(($D$1:$D$121>=$AA$3)*($D$1:$D$121<=$AB$3)*(($K$1:$K$121>=$AA$4)*($K$1:$K$121<=$AB$4))*(($O$1:$O$121>=$AA$5)*($O$1:$O$121<=$AB$5))))
Tanto per ...
Un saluto
Ciao Gerardo la formula non sono riuscito ad applicarla con Excel 2019 forse non funziona.Grazie p.s ho visto tutti i tuoi video.
ciao
 

D@nilo

Utente assiduo
Expert
19 Gennaio 2016
2.151
203
63
Roma
Excel 2016
86
ciao
se ti funzionava e vuoi aggiungere una condizione la condizione è questa

(($O$1:$O$121>=$AA$5)*($O$1:$O$121<=$AB$5)) al posto di AA5 e AB5 metti i relativi cerca vert
 

tony2019

Utente junior
3 Marzo 2019
27
1
3
2011
0
=SE.ERRORE(INDICE($P$3:$P$121;AGGREGA(15;6;RIF.RIGA($P$3:$P$121)/(($P$3:$P$121 >= CERCA.VERT($AA$7;$AA$7:$AC$7;2;0))*($P$3:$P$121<=CERCA.VERT($AA$7;$AA$7:$AC$7;3;0))*(($L$3:$L$121>=CERCA.VERT($AA$8;$AA$8:$AC$8;2;0))*($L$3:$L$121<=CERCA.VERT($AA$8;$AA$8:$AC$8;3;0))*(($S$1:$S$121>=$AB$9)*($S$1:$S$121<=$AC$9))))-RIF.RIGA($P$3)+1;RIF.RIGA(U1)));"")

Come mi è stato suggerito ho inserito la stringa in rosso e la formula funziona, mentre se provo a mettere il cerca vert non funziona (al posto di AB9 e AC9).

Ho provato ad inserire una quarta condizione dettata da un altro intervallo di valori ed Excell non riconosce più la formula.

La formula cosi com'è funziona su tre condizioni ma rimane il fatto che non ho capito su quale logica funziona perchè teoricamente come dovrebbe funzionare per 1 o 2 o 3 condizioni così dovrebbe funzionare con numero di condizioni maggiori.
Se mi potete suggerire qualche video o guida in tal senso ve ne sarei grato.

Grazie
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!