Risolto Formula per calcolare dei valori in base al menu a tendina.

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Un saluto a tutti e anche agli amanti della pizzacappello_saluta
Il file che allego serve a preparare la ricetta per pizza soprattutto per chi utilizza il lievito madre liquido. Ho necessità di moltiplicare i valori in base alla scelta del menù della cella A6. Selezionando una delle voci mi dovrebbe calcolare i valori in base alla riga 5 da B > N e riportarli in riga 6 nelle celle corrispondenti da B6 > N6. Così la cella C9 rispetto alla C8.
Il file è già pronto per calcolare tutto il resto. Chiedo se potete darmi una dritta.
Grazie.
Fausto
N.B.: nel file ho simulato una ricetta che non è da provare perché non autentica..
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.351
345
Latina
Excel 2010
815
Ciao F @Fausto62
se ho capito vorresti ricavare le quantità in base alla riga 5 x1 teglia
per le teglie scelte in A6

in C6 metti:

=SE(C5="";"";SINISTRA($A$6;LUNGHEZZA($A$6)-7)*C5)

trascina a destra
 
  • Like
Reactions: Fausto62

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Grazie Berna11, è proprio questo il risultato. Ho adattato la formula anche alla cella B9. Scusami ma, per capire meglio la formula, per favore mi puoi indicare a cosa fa rif: SINISTRA; LUNGHEZZA; e il -7 in relazione al mio file.
Allego il lavoro finito.
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.351
345
Latina
Excel 2010
815
Coap F @Fausto62
a cosa fa rif: SINISTRA; LUNGHEZZA; e il -7
In parole povere la formula dice:
prendi la parte SINISTRA della cella $A$6
Vedi la LUNGHEZZA che conta quanti caratteri ci sono in quella cella
e al totale dei caratteri ci togli 7 e restituisci la parte rimanente che
avevo detto di sinistra.
7 perchp avendo un testo standard Teglie su tutte le ipotesi
sono 6 caratteri + 1 spazio diventano 7-
Spero sia stato comprensivo.
 

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Chiedo venia, ma mi sono impantanato su un errore che non riesco a risolvere. Se le celle L6 e M6 sono vuote la C20 mi restituisce errore. Ho provato secondo le mie conoscenze ma niente da fà..
Per la cella C19 ho risolto con "SE.ERRORE" ma non sono sicuro che sia la soluzione giusta.
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.351
345
Latina
Excel 2010
815
Ciao F @Fausto62
trovando le celle vuote da errore.
in C20 metti :

=SE.ERRORE(SOMMA(C18+C19+L6+M6);0)

in C19 hai messo che, se trova errore, mette J6
non so se voluto il J6 oppure volevi rettificare
l'errore e metterci 0 in questo caso modifica in.

=SE.ERRORE(J6+K6+C11;0)
 
  • Like
Reactions: Fausto62

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Ciao Berna11, avevo già provato questa soluzione e non va bene, perché se la ricetta non prevede sale ma il lievito sì -oppure il contrario- il risultato in C20 rimane 0. Ecco perché in C19 ho messo se errore restituisci J6 visto che l'acqua è sempre un valore presente in J6.:confusostelle:
 

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Buona sera, scusatemi ma l’odissea continua. Spero sia l’ultimo intoppo. Se potete aiutarmi di nuovo.
Nella cella J5 ho questa formula: = SOMMA((H5+I5+P5)-(B$13+K5))
Ho necessità di sottrarre la cella N5 ma se modifico come segue mi dà errore:
= SOMMA((H5+I5+P5)-(B$13+K5+N5)).
Ho provato anche =CONTA.VALORI(H5;I5;P5)-CONTA.VALORI(B13;K5) ma se aggiungo la cella N5 dà sempre errore.
La stessa cosa la cella B19 ho inserito la seguente formula: =SOMMA(J5;K5;B11)
Ho necessità di sommare/addizionare la cella N5 e se modifico come segue mi dà errore:
=SOMMA(J5;K5;B11;N5)
Grazie. Allego il file:
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.351
345
Latina
Excel 2010
815
Ciao
non puoi fare quel tipo di calcolo
in N5 hai =B19*5%

in b19 hai:

=SOMMA(J5;K5;B11)

se vuoi aggiungere N5
sarebbe la stessa cella
e ti da errore circolare.
B19 non puoi metterci N5 se in N5 ti serve il B19
 
  • Like
Reactions: Fausto62

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Ho cambiato l'ordine:
In cella N6: =SOMMA(J5;K5;B11)*5%
In B19: =SOMMA(J5;K5;B11)*105%
Poi ho spostato la formula di J5 in T5
In fine in J5: =T5-N5
Prima o poi attacco l’hobby pizza a qualcunoMartelloTesta
La pw è: 1234
 

Allegati

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Grazie Berna11, ...non esattamente perché sia tu che Paolo mi avete messo in modalità progettazione. Non riuscivo a capire l'intreccio dell'"errore circolare". Ricordo, per chi non lo sapesse, che sono un appassionato di Excel e della matematica, e cerco di capire cosa c'è alla base del problema. Per cui, vi ringrazio per avermi dato quest'altra nozione.
Buona notte.
f.
 

Fausto62

Utente junior
23 Gennaio 2018
66
6
Cupello
2016
0
Buona sera a tutti, sono di nuovo alle prese con il mio file per pizza. Devo modificare alcuni valori ma...
per favore se potete darmi una dritta così impastiamo più velocemente:felice: non riesco a correggere il riferimento circolare con la formula inserita in foglio1 F5 che deve riportare il 20 per cento della cella Foglio2 I5 come da file allegato.
Grazie.
f.
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.351
345
Latina
Excel 2010
815
Ciao
non devi riaprire una discussione già chiusa e risolta da tempo
apri una nuova ma, se non rivedi l'impostazione dei tuoi calcoli, difficile darti una mano.
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!