Risolto Funzione SE

Roberto B.

Nuovo utente
21 Marzo 2017
16
1
3
Vicenza
2010
0
Ciao a tutti.
Vi chiedo cortesemente di darmi una mano su questo quesito...
nel file allegato, nella colonna " N " mi appaiono i valori del budget anche se non sono presenti i partecipanti.
Nel caso presente, non dovrebbe comparire alcun valore perchè gli unici due partecipanti hanno cenato entrambi.
dovrebbe compilarsi solo nel caso fosse scritto un altro o più nomi ( in colonna B ) e questi non avessero mangiato
quindi non fosse compilata la colonna " F " "Costo cena".
Vi ringrazio anticipatamente.
 

Allegati

Abe76

Utente abituale
23 Agosto 2017
609
94
28
42
Milano
Office16/19xWin
23
Ciao Roberto,
Prova a modificare il riferimento della formula in colonna N da colonna "M"a colonna "F".
In questo modo si attiva la formula nella colonna "N", solo se presente un costo cena che implica un calcolo.
 

Shadow-R6

Nuovo utente
25 Marzo 2019
13
1
3
2013
0
come dice Abe76 la formula fa riferimento alla colonna M e non F, credo che la formula che cerchi sia :

=SE(F4<>"";0;$D$2)
 
  • Like
Reactions: Abe76

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.578
531
113
Latina
Excel 2010
171
Un saluto a tutti
Roberto B. @Roberto B.
dovresti allegare il file con il risultato desiderato messo a mano
indicando dove la colonna/cella ..
per evitare di andare per tentativi

Inoltre, la formula in colonna M, è giusta?
così rimane sempre vuota...
 

Shadow-R6

Nuovo utente
25 Marzo 2019
13
1
3
2013
0
Roberto B. @Roberto B. ho notato che la formula in M restituisce sulla prima cella il nome della persona che "non ha mangiato" quindi la formula da me messa funziona ma non è corretta.

probabilmente sarebbe più opportuno usare un cerca verticale sulla cella N con controllo sulla cella M:

=CERCA.VERT(M4;B4:D19;3;)

Ma il risultato resta vuoto e non capisco perchè.

Lascio la parola ai più esperti.

Sha
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.578
531
113
Latina
Excel 2010
171
Rileggendo ed interpretando ...
se in colonna M vendono fuori solo i nomi che hanno in colonna F vuoto
ed in colonna N vuoi vedere D2 solo in questi casi
metti in N4:

=SE.ERRORE(SE(CERCA.VERT(M4;$B$4:$F$19;5;0)="";$D$2;"");"")

e trascina in basso
Altrimenti, come detto sopra, allega il file con risultato messo a mano.
 

Shadow-R6

Nuovo utente
25 Marzo 2019
13
1
3
2013
0
Ciao Berna11 @Berna11 ,
perdonami se ti faccio una domanda su un topic di un altro, ma secondo te perché la mia formula
=CERCA.VERT(M4;B4:D19;3;)
non riportava il valore segnato nella terza cella della matrice ma mi dava un valore Vuoto?

Giusto per capire e imparare qualcosa
 

Abe76

Utente abituale
23 Agosto 2017
609
94
28
42
Milano
Office16/19xWin
23
=CERCA.VERT(M4;B4:D19;3;)
La formula e' incompleta.
Alla cella di riferimento M4, chiedi di cercare nella terza colonna dell'intervallo b4:d19(che andrebbe bloccato), ma non assegni la condizione se si tratti di valore relativo o assoluto.
Per far cio', alla fine devi aggiungere la condizione "VERO" o "FALSO".
=CERCA.VERT(M4;$B$4:$D$19;3;FALSO)
Saluto_saluto
 

Berna11

Excel Expert
Moderatore
Expert
20 Febbraio 2016
4.578
531
113
Latina
Excel 2010
171
Ciao Shadow-R6 @Shadow-R6
oltre a quanto detto da Abe76 @Abe76 (ciao)
su come impostare la formula e mettere i riferimenti assoluliti nel range di ricerca
per poi quando si trascina in basso rimangono fissi.
Per il VERO o FALSO 1 o 0
bella tua formula è mancante.
Nel caso specifico non ti dava il risultato in quanto, se hai messo un nome in colonna B
e lasciato vuote le altre colonne, essendo vuota la colonna D (3) non ti dava nessun risultato.
Prova a mettere qualcosa in D vedrai che lo riporta.
 
  • Like
Reactions: Shadow-R6 and Abe76

Roberto B.

Nuovo utente
21 Marzo 2017
16
1
3
Vicenza
2010
0
Ciao ragazzi
Grazie mille a tutti per l'aiuto. Ho appena provato le vostre formule. Con quella di Berna 11 funziona perfettamente.
Solo se non mangia deve comparire il nome in colonna " M " e di conseguenza comparire il Budget.
Perfetto. Grazie mille ancora.
Buona giornata a tutti Saluto_saluto
 
  • Like
Reactions: Abe76

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!