Risolto impostare un formato data

picmau

Utente junior
11 Aprile 2017
51
0
6
H&B 2013
0
buonasera a tutti
selezionando una colonna in cui sono contenute esclusivamente date con vari formati, attraverso la funzione Formato celle non riesco a formattare tutte le celle dell'elenco tipo queste due
12\11\2002 e 07/07/2003 nel formato che desidero 12 febbraio 2000. E' possibile farlo in qualche altro modo senza VBA? grazie





 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
16.333
523
113
Como
2011MAC 2016WIN
235
Ciao,
inserisci questa formula in D2 e trascina in basso, poi vai e fai la tua formattazione

=SOSTITUISCI(C2;"\";"/")+0
 

picmau

Utente junior
11 Aprile 2017
51
0
6
H&B 2013
0
grazie molte funziona bene
se la colonna da formattare fosse il risultato di una formula, aggiungendo la tua formula a quella esistente, come faccio ad eliminare il #VALORE! che si quando nelle celle nen c'è nulla da formattare?
allego nuovo file
 

Allegati

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
16.333
523
113
Como
2011MAC 2016WIN
235
Aggiungendo la funzione SE.ERRORE (in D2 da trascinare in basso)

=SE.ERRORE(SOSTITUISCI(SE(NON(VAL.VUOTO(B2));B2;);"\";"/")+0;"")

In realtà basterebbe questo:

=SE.ERRORE(SOSTITUISCI(B2;"\";"/")+0;"")
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!