Risolto incremento di un valore dopo intervallo di un anno

gabrir

Utente junior
25 Marzo 2019
20
3
excel 2016
0
Buongiorno,
spero di essere nella sezione giusta.

Avrei bisogno di una formula che mi incrementi di uno il valore delle celle di una colonna ogni 1 giugno dell'anno successivo:

nome valore
anna 1
carlo 8
paolo 3

Quindi al 1 giugno 2022 :

nome valore
anna 2
carlo 9
paolo 4

Magari è una cosa semplicissima ma non so proprio come fare

Grazie per l'aiuto che vorrete darmi
 

Terio

Utente abituale
6 Gennaio 2021
918
75
51
Arce
2016, 2019
105
Questa la proposta:
=valoreiniziale+ANNO(OGGI())-2021
il primo valore e l'anno 2021 possono essere resi dinamici, in funzione del risultato voluto.

Ciao
 

[email protected]

Utente assiduo
Expert
19 Gennaio 2016
4.700
145
Roma
Excel 2016
468
Ciao
Non è chiaro se questo incremento si deve realizzare nelle celle della prima tabella in alto o in quelle sotto
Per quelle sotto basta una formula per la prima ci vuole il VBA oppure mettere un altra colonna con i valori iniziali
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
10.086
1.445
Latina
Excel 2010
1.158
Un saluto a tutti
da come ho capito io farei nel seguente modo:
inserire anno iniziale in cella D1 in questo caso 2021
visto che vuoi far scattare il calcolo dal dal 1 giugno
in cella E1 metti:
=SE(MESE(OGGI())>6;D1-ANNO(OGGI()))

in cella B13:
=B2+$E$1
e trascini in basso.
Se serve anche l'altro (non so)
B23:
=B13+$E$1

e trascini in basso.
 

gabrir

Utente junior
25 Marzo 2019
20
3
excel 2016
0
l'incremento va fatto solo sulla prima tabella in altro, le altre sono di esempio.
Scusate se sono stata poco chiara.
 

gabrir

Utente junior
25 Marzo 2019
20
3
excel 2016
0
grazie,
con le formule proposte non riesco a risolvere.
In sostanza la colonna "valore" dovrebbe aumentare di un numero ogni primo giugno dell'anno seguente restando nella stessa posizione.
L'esempio che ho caricato forse non era chiaro, scusate.

Va bene anche il VBA, devo spostare la discussione?
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
10.086
1.445
Latina
Excel 2010
1.158
Con la formula proposta lo puoi fare se usi una nuova colonna
Esempio se in D2 metti:
=B2+$E$1
e trascini in basso

Se devi mantenere la stessa colonna B
e variarlo ci vuole il VBA come detto.
 

gabrir

Utente junior
25 Marzo 2019
20
3
excel 2016
0
ciao Berna11,
si funziona anche così, grazie mille.

Lascio ancora aperta la discussione per un po', se qualcuno trova il sistema di non dover aggiornare l'anno a mano.

Così va comunque bene.
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
10.086
1.445
Latina
Excel 2010
1.158
Cosa intendi per aggiornare anno a mano?
Se non vuoi mettere in D1 l'anno ma lo vuoi in automatico
proviamo con:
D1:
=2021-ANNO(OGGI())
2021 è anno di partenza del conteggio
ed in E1:
=SE(MESE(OGGI())>6;D1;D1-1)
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!